2 Replies Latest reply on Sep 8, 2009 3:56 AM by Hardy Massen

    <a4j:log> broken in Internet Explorer 7.0

    Hardy Massen Novice

      Hi!

      If I use <a4j:log> with JBoss Portal 2.7.2, Facelets and RichFaces 3.3.1.GA and browse with Internet Explorer 7.0.5730.13, I will get a javascript-runtime-exception as soon as I press a key (any key!).

      The pages:
      Template-file my_template.xhtml:

      <?xml version="1.0" encoding="utf-8"?>
      <ui:composition xmlns="http://www.w3.org/1999/xhtml" xmlns:h="http://java.sun.com/jsf/html" xmlns:f="http://java.sun.com/jsf/core" xmlns:ui="http://java.sun.com/jsf/facelets" xmlns:rich="http://richfaces.org/rich" xmlns:a4j="http://richfaces.org/a4j">
      
       <a4j:log hotkey="H" popup="true" level="WARN" />
       <div id="content">
       <f:view>
       <ui:insert name="content">
       <h:outputText value="Default Text for content" />
       </ui:insert>
       </f:view>
       </div>
      </ui:composition>
      


      Template-using file:
      <?xml version="1.0" encoding="utf-8"?>
      <ui:composition xmlns="http://www.w3.org/1999/xhtml" xmlns:h="http://java.sun.com/jsf/html" xmlns:f="http://java.sun.com/jsf/core" xmlns:ui="http://java.sun.com/jsf/facelets" xmlns:a4j="http://richfaces.org/a4j" xmlns:rich="http://richfaces.org/rich" template="../../templates/my_template.xhtml">
       <ui:define name="content">
       foo...bar...
       </ui:define>
      </ui:composition>
      


      RichFaces-script-settings:
      <context-param>
       <param-name>org.richfaces.LoadStyleStrategy</param-name>
       <param-value>ALL</param-value>
      </context-param>
      
      <context-param>
       <param-name>org.richfaces.LoadScriptStrategy</param-name>
       <param-value>ALL</param-value>
      </context-param>
      


      The <a4j:log>-demo-site at http://livedemo.exadel.com/richfaces-demo/richfaces/log.jsf?c=log&tab=usage does work in the Internet Explorer 7.

      Any ideas, what's happening here?

      Best regards, LeoLo