0 Replies Latest reply on Aug 25, 2011 4:51 PM by Kar V

    Jboss AS7 mail issue

    Kar V Newbie

      Hi,

       

      I am having problems with the mail stuff. I am getting the following exceptions

      java.lang.NoClassDefFoundError: javax/net/ssl/SSLPeerUnverifiedException

      com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1900)

      com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:638)

      javax.mail.Service.connect(Service.java:295)

      javax.mail.Service.connect(Service.java:176)

      javax.mail.Service.connect(Service.java:125)

      javax.mail.Transport.send0(Transport.java:194)

      javax.mail.Transport.send(Transport.java:124)

      com.vz.ag.util.UrlMailer.SendMail(UrlMailer.java:106)

      com.vz.ag.servlet.sso.VerifyServlet.activatePwreset(VerifyServlet.java:149)

      com.vz.ag.servlet.sso.VerifyServlet.processRequest(VerifyServlet.java:91)

      com.vz.ag.servlet.sso.VerifyServlet.doPost(VerifyServlet.java:49)

      javax.servlet.http.HttpServlet.service(HttpServlet.java:754)

      javax.servlet.http.HttpServlet.service(HttpServlet.java:847)

       

      java.lang.ClassNotFoundException: javax.net.ssl.SSLPeerUnverifiedException from [Module "javax.mail.api:main" from local module loader @4aeb52 (roots: C:\Tools\jboss-as-web-7.0.0.Final\modules)]

      org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:191)

      org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:358)

      org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:330)

      org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:307)

      org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:101)

      com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1900)

      com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:638)

      javax.mail.Service.connect(Service.java:295)

      javax.mail.Service.connect(Service.java:176)

      javax.mail.Service.connect(Service.java:125)

      javax.mail.Transport.send0(Transport.java:194)

      javax.mail.Transport.send(Transport.java:124)

      com.vz.ag.util.UrlMailer.SendMail(UrlMailer.java:106)

      com.vz.ag.servlet.sso.VerifyServlet.activatePwreset(VerifyServlet.java:149)

      com.vz.ag.servlet.sso.VerifyServlet.processRequest(VerifyServlet.java:91)

      com.vz.ag.servlet.sso.VerifyServlet.doPost(VerifyServlet.java:49)

      javax.servlet.http.HttpServlet.service(HttpServlet.java:754)

      javax.servlet.http.HttpServlet.service(HttpServlet.java:847)

       

      someone plz help me fix this.