2 Replies Latest reply on Aug 31, 2011 10:55 AM by Pierpaolo Lombardi

    BIRT reports "wrong username and password" error

    Pierpaolo Lombardi Newbie

      Hi,

       

      I'm trying to configure the report generation but I cannot do that.

      I installed BIRT manually in the JBoss 5.1.0.GA following the steps in the file build.xml.

       

      From the jbpm console I firstly had an error related to the missing of some classes and to solve it I copied the h2.jar at the path BIRT_HOME\ReportEngine\plugins\org.eclipse.birt.report.data.oda.jdbc_2.3.2.r232_v20090212\drivers

       

      It worked but another error occurs now:

       

      11:18:50,901 SEVERE [odaconsumer] Cannot open connection.

      org.eclipse.birt.report.data.oda.jdbc.JDBCException: There is an error in get connection, Wrong user name or password [28000-158].

       

       

      I tried modifying the file plugin.properties in the following way

       

       

      datasource.property.odaURL=jdbc:h2:tcp://localhost/~/test

      datasource.property.odaUser=admin

      datasource.property.odaPassword=admin

       

      but no good result.

       

      Can you help me to understand where to configure the username and the passowrd BIRT uses to connect to the dbms?

       

      Thanks in advance,

      Pierpaolo

        • 1. Re: BIRT reports "wrong username and password" error
          Chris Melas Apprentice

          Hi,

          Try openning up the reports and check out the connection properties in there. The reports are in jbpm-gwt-console-server.war within WEB-INF\classes, they are the rptdesign files and their format is xml.

          • 2. Re: BIRT reports "wrong username and password" error
            Pierpaolo Lombardi Newbie

            Hi,

             

            thenka for the answer.

            I checked those files and I found out they were wrong.

            I modified them to have the following:

             

                    <oda-data-source extensionID="org.eclipse.birt.report.data.oda.jdbc" name="MySQL Local" id="6">
                        <property name="odaDriverClass">org.h2.jdbcx.JdbcDataSource</property>
                        <property name="odaURL">jdbc:h2:tcp://localhost/~/test</property>
                        <property name="odaUser">admin</property>
                        <property name="odaPassword">admin</property>
                    </oda-data-source>

             

            but the problem still happens.

            Why?

             

            Thanks,

            Pierpaolo