0 Replies Latest reply on Sep 11, 2011 3:29 PM by Adrien Adrien

    [RF 4.1M1]Possible bug using rich:editor in a4j:repeat , rich:list ...

    Adrien Adrien Apprentice

      Hi

      When rich:editor in only display in a4j:repeat or a  rich:list ... then it was not displayed, if an rich:editor is declared out of the list then, the editor is well displayed in the list or repeat .

       

      Dont' works

      {code:xml}

      <a4j:outputPanel id="xx">

        <a4j:commandButton execute="@this"   value="Test" render="xx" action="#{ctrlAdminTestimonies.load}">

        <f:param  name="type" value="inalltestimonies" />

        </a4j:commandButton>

        <a4j:repeat id="testilist" var="testi" value="#{ctrlAdminTestimonies.result}" rows="6">

        <rich:panel header="#{testi.id} " >

        <rich:editor  id="cmsg" value="#{testi.testimony}"     required="true">

       

        </rich:editor>

        </rich:panel>

        </a4j:repeat>

        </a4j:outputPanel>

      {code}

       

      Works

      {code:xml}

      <a4j:outputPanel id="xx">

      <!--HERE I PUT AN EDITOR OUTSIDE a4j:repeat => then all is well display -->

                 <rich:editor  autoResize="true"   value="#{ctrlAdminSendEmails.msg}"  toolbar="full" required="true"  >                                                  

                                                        </rich:editor>

       

                <a4j:commandButton execute="@this"   value="Test" render="xx" action="#{ctrlAdminTestimonies.load}">

                                               <f:param  name="type" value="inalltestimonies" />

                          </a4j:commandButton>

                <a4j:repeat id="testilist" var="testi" value="#{ctrlAdminTestimonies.result}" rows="6">

                <rich:panel header="#{testi.id} " >

                          <rich:editor  id="cmsg" value="#{testi.testimony}"     required="true">

       

                                    </rich:editor>

                                    </rich:panel>

                </a4j:repeat>

                </a4j:outputPanel>

      {code}

       

      Any idea if i m doing something wrong or it is a bug?

      Thanks