0 Replies Latest reply on Nov 13, 2011 12:13 AM by Niraj Salot

    JBOSS 7 Oracle Datasource - Connection Closed Issue

    Niraj Salot Newbie

      Hi All,

       

      When my system is acceesed my multiple users and for long amount of time , suddenly I users "Connection Closed" Error.

       

      In my code , Connection are closed Properly. below is my configureation file. We are using JBOSS 7.0.2 final

       

      <datasource jndi-name="jdbc/xxxx" pool-name="datasource0_Pool" enabled="true" jta="true" use-java-context="true" use-ccm="true">

                          <connection-url>

                              jdbc:oracle:thin:@xxx

                          </connection-url>

                          <driver>

                              oracle

                          </driver>

                          <pool>

                              <min-pool-size>

                                  20

                              </min-pool-size>

                              <max-pool-size>

                                  100

                              </max-pool-size>

                              <prefill>

                                  true

                              </prefill>

                              <use-strict-min>

                                  false

                              </use-strict-min>

                              <flush-strategy>

                                  FailingConnectionOnly

                              </flush-strategy>

                          </pool>

                          <security>

                              <user-name>

                                  xxxx

                              </user-name>

                              <password>

                                  yyyyy

                              </password>

                          </security>

                          <validation>

                              <valid-connection-checker class-name="org.jboss.jca.adapters.jdbc.extensions.oracle.OracleValidConnectionChecker"/>

                              <validate-on-match>

                                  false

                              </validate-on-match>

                              <background-validation>

                                  false

                              </background-validation>

                              <use-fast-fail>

                                  false

                              </use-fast-fail>

                          </validation>

                          <timeout>

                              <idle-timeout-minutes>

                                  1

                              </idle-timeout-minutes>

                          </timeout>

                      </datasource>

       

      Can we some one please update me on this ? How we can resolve this issue ?