2 Replies Latest reply on Dec 7, 2011 10:01 PM by jaikiran pai

    Jboss 7.0.1 Deployment issue

    Syed Hussain Newbie

      Hi,

       

      I am having a trouble with deploying a war file in Jboss 7.0.1 ... Issue is I have deleted my war file from standalone/deployments folder and still when I start my server through commandline It starts deploying mywar.war ... What is the problem here? I have deleted all deployment files as well as all the builds. How is it able to find this file? And how is it possible that without any "mywar.war" file present in deployments folder its still deploying it on the server?

       

      Can any one explain me whats going on here?

       

      Thanks,

       

      Regards,

      Brat

        • 1. Re: Jboss 7.0.1 Deployment issue
          Adetunji Adegbite Newbie

          I will just like to ask some questions that will help ing giving a good answer.

          Which browser are you using, have you tried to clear the cache.

          Have you worked with any other jboss before this one you are talking about, it could be that that one resides somewhere.

          If you answer yes to both questions above, i will suggest you delete and re-download jboss and try to restart your system.

          Hope these gets u somewhere.

          • 2. Re: Jboss 7.0.1 Deployment issue
            jaikiran pai Master

            In JBoss AS 7.0.1 (I think) we used to persist the deployment information into the JBOSS_HOME/standalone/standalone.xml. If you open it, you'll probably find a deployment section with your deployment name in it. Removing that entire deployment section and saving the file and restarting the server will get you past this.

             

            This has been fixed in later releases. So you can upgrade to 7.0.2 or 7.1.0.Beta1