4 Replies Latest reply on Jan 12, 2012 12:45 AM by Stephen Coy

    JBoss installation problem ClassLoader

    manolakis Newbie

      Hi there,

       

      I am tried to run JBoss for the first time (actually to install and then run) but I get the following error.

       

       

      ./standalone.sh

      =========================================================================

       

       

        JBoss Bootstrap Environment

       

       

        JBOSS_HOME: /Users/student/Desktop/jboss-as-7.1.0.CR1b

       

       

        JAVA: java

       

       

        JAVA_OPTS: -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true

       

       

      =========================================================================

       

       

      Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file

                at java.lang.ClassLoader.defineClass1(Native Method)

                at java.lang.ClassLoader.defineClass(ClassLoader.java:676)

                at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)

                at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)

                at java.net.URLClassLoader.access$100(URLClassLoader.java:56)

                at java.net.URLClassLoader$1.run(URLClassLoader.java:195)

                at java.security.AccessController.doPrivileged(Native Method)

                at java.net.URLClassLoader.findClass(URLClassLoader.java:188)

                at java.lang.ClassLoader.loadClass(ClassLoader.java:317)

                at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:280)

                at java.lang.ClassLoader.loadClass(ClassLoader.java:252)

                at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:375)

       

       

      Does anybody know what should I do to fix this?

       

      Thank you.