0 Replies Latest reply on Jan 15, 2012 6:17 AM by kiva

    Problem with hot deploy and VFS (Jboss 6)

    kiva Newbie

      Hi guys,

       

      I have a problem with my application and the hot deployment.

      Here is my environnement:

       

      • Eclipse Indigo (I have the same problem with Helios)
      • Jboss tools 3.3
      • M2eclipse 1.0
      • Jboss 6.0.0

       

      I use Jsf in my application and I have the next problem:

       

      When I run my jboss server in debug mode, I can modify every Java Class (in war or jar dependencies) and Jboss takes modifications directly.

      I can modify xhtml in the war and Jboss takes modifications directly.

      BUT, if I modify a xhtml in jar dependencies, Jboss doesn't take modificatons.

       

      I spend many time to find why ? I thought m2eclipse have some problem but, I tried to uninstall it and to work with maven command line. The problem is the same.

       

      Finally, I found this "problem" (I don't know if it's really a problem):

       

      All xhtml in war aren't deployed in the directory JBOSS_HOME/server/default/tmp/vfs

      So, when Jboss publishes modifications in JBOSS_HOME/server/default/deploy/mywar.war/, modifications work fine.

       

      Xhtml in jar are deployed in the directory JBOSS_HOME/server/default/tmp/vfs

      So, when Jboss publishes modifications in JBOSS_HOME/server/default/deploy/mywar.war/, modifications don't work.

      If I modifiy manually the file in vfs directory, modifications work.

       

      Why xhtml in jar are deployed in vfs directory and how to resolve my problem ?

       

      Thanks for your help.