2 Replies Latest reply on Sep 18, 2010 11:20 AM by Josh Hill

    Latest Servlet Module breaks GlassFish 3.0

    Josh Hill Newbie

      A webapp containing the latest servlet module jar will no longer deploy to GlassFish 3.0


      Here's my pom.xml and the error i'm getting.




      <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
               xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
          <modelVersion>4.0.0</modelVersion>
          <groupId>test</groupId>
          <artifactId>testservlet</artifactId>
          <packaging>war</packaging>
          <version>1.0-SNAPSHOT</version>
          <name>testservlet Java EE 6 Webapp</name>
          <url>http://maven.apache.org</url>
          <dependencies>
              <dependency>
                  <groupId>javax</groupId>
                  <artifactId>javaee-web-api</artifactId>
                  <version>6.0</version>
                  <scope>provided</scope>
              </dependency>
              <dependency>
                  <groupId>org.jboss.seam.servlet</groupId>
                  <artifactId>seam-servlet</artifactId>
                  <version>3.0.0-SNAPSHOT</version>
              </dependency>
               <dependency>
                  <groupId>org.jboss.weld</groupId>
                  <artifactId>weld-extensions</artifactId>
                  <version>1.0.0.Alpha2</version>
               </dependency>
                  <dependency>
                      <groupId>org.slf4j</groupId>
                      <artifactId>slf4j-jdk14</artifactId>
                      <version>1.5.6</version>
                  </dependency>
          </dependencies>
      </project>



      java.lang.Exception: java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: java.lang.IllegalArgumentException: java.lang.IllegalArgumentException: PWC1430: Unable to add listener of type: org.jboss.seam.servlet.event.Servlet3EventBridge, because it does not implement any of the required ServletContextListener, ServletContextAttributeListener, ServletRequestListener, ServletRequestAttributeListener, HttpSessionListener, or HttpSessionAttributeListener interfaces