1 Reply Latest reply on Mar 28, 2008 4:49 PM by Pete Muir

    Question about "Getting Started Guide"

    jeff liu Newbie

      Hello all


      On http://docs.jboss.com/seam/2.0.0.GA/reference/en/html/gettingstarted.html, it states:




      EAR projects support EJB 3.0 and require Java EE 5. WAR projects do not support EJB 3.0, but may be deployed to a J2EE environment.

      Does it mean that if I deploy the application as a WAR file, EJB3 is not supported? When I use the hello world example for seam 1.2, the example is packed as WAR and using EJB. What should I do in Seam 2?


        • 1. Re: Question about "Getting Started Guide"
          Pete Muir Master

          jeff liu wrote on Mar 26, 2008 08:09 AM:


          Hello all

          On http://docs.jboss.com/seam/2.0.0.GA/reference/en/html/gettingstarted.html, it states:


          EAR projects support EJB 3.0 and require Java EE 5. WAR projects do not support EJB 3.0, but may be deployed to a J2EE environment.

          Does it mean that if I deploy the application as a WAR file, EJB3 is not supported?


          Yes.



          When I use the hello world example for seam 1.2, the example is packed as WAR and using EJB. What should I do in Seam 2?

          No its not. It's never been possible. And there is no hello world example.