6 Replies Latest reply on Mar 28, 2008 5:50 PM by Karl Beowulph

    Can't deploy seam project after upgrading

    Karl Beowulph Newbie

      Hello,


      I've just upgraded my software artifacts to the following:


      Ant 1.6.5 - Ant 1.7

      Eclipse JEE Europa Fall - Eclipse JEE Europa Winter

      JBoss Seam 2.0.0.GA - JBoss Seam 2.0.1.GA

      JBoss Tools 2.0.0.GA - JBoss Tools 2.0.1.GA

      I'm now having problems deploying a new Seam project.


      The steps I've done are:


      - Dropped in JBoss Tools into Eclipse

      - Created JBoss Runtime / Server within Eclipse

      - Added "jboss.home = C:\\opt\\jboss-4.2.2.GA" into my Seam build.properties file

      - Set up the server within Eclipse


      Now, the server can start up fine, but after I create a default Seam project and attempt to run "home.xhtml" on the server I get the following:


      
      7:05:58,003 INFO  [EARDeployer] Init J2EE application: file:/C:/opt/jboss-4.2.2.GA/server/default/deploy/testProject-ear.ear/
      
      17:05:58,018 ERROR [MainDeployer] Could not initialise deployment: file:/C:/opt/jboss-4.2.2.GA/server/default/deploy/testProject-ear.ear/
      
      org.jboss.deployment.DeploymentException: url file:/C:/opt/jboss-4.2.2.GA/server/default/deploy/testProject-ear.ear/jboss-seam.jar could not be opened, does it exist?
      
           at org.jboss.deployment.DeploymentInfo.<init>(DeploymentInfo.java:214)
      
           at org.jboss.deployment.EARDeployer.init(EARDeployer.java:288)
      
           at org.jboss.deployment.MainDeployer.init(MainDeployer.java:872)
      
           at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:809)
      
           at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:782)
      
           at sun.reflect.GeneratedMethodAccessor20.invoke(Unknown Source)
      
           at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      
           at java.lang.reflect.Method.invoke(Unknown Source)
      
           at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
      
           at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
      
           at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:133)
      
           at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
      
           at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterceptor.java:142)
      
           at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
      
           at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
      
           at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
      
           at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
      
           at $Proxy9.deploy(Unknown Source)
      
           at org.jboss.deployment.scanner.URLDeploymentScanner.deploy(URLDeploymentScanner.java:421)
      
           at org.jboss.deployment.scanner.URLDeploymentScanner.scan(URLDeploymentScanner.java:634)
      
           at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.doScan(AbstractDeploymentScanner.java:263)
      
           at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.loop(AbstractDeploymentScanner.java:274)
      
           at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.run(AbstractDeploymentScanner.java:225)
      
      



      Does anyone think they might know the potential cause?  If it helps, I'm on Windows XP and using Java 1.5