2 Replies Latest reply on Dec 11, 2007 3:26 AM by Blondel Michaël

    AjaxRendererUtils : NoClassDefFoundError

    Blondel Michaël Newbie

      Hello,

      I try to run my test with the release" JSFUnit Beta 1". But I have this error :

      java.lang.NoClassDefFoundError: org/ajax4jsf/framework/renderer/AjaxRendererUtils
      at org.jboss.jsfunit.richfaces.Ajax4jsfClient.buildEventOptions(Ajax4jsfClient.java:237)
      at org.jboss.jsfunit.richfaces.Ajax4jsfClient.ajaxSubmit(Ajax4jsfClient.java:171)
      at org.jboss.jsfunit.richfaces.Ajax4jsfClient.ajaxSubmit(Ajax4jsfClient.java:152)
      at com.exaprotect.gui.collecting.newequipmentwzd.ExaWizardStep1Test.fireProductAndProductHost(ExaWizardStep1Test.java:53)
      at com.exaprotect.gui.collecting.newequipmentwzd.ExaWizardStep1Test.executeTest(ExaWizardStep1Test.java:77)
      at com.exaprotect.gui.collecting.newequipmentwzd.ExaWizardStep1Test.executeTest(ExaWizardStep1Test.java:66)
      at com.exaprotect.gui.collecting.newequipmentwzd.ExaWizardStep1Test.testOK(ExaWizardStep1Test.java:92)


      JSFClientSession client = new JSFClientSession("/test.jsf");
      Ajax4jsfClient ajaxClient = new Ajax4jsfClient(client);
      client.setParameter("form:name", "JO");
      ajaxClient.ajaxSubmit("a4jsupport");


      <h:inputText value="#{exaWzdProductBean.productName}" size="50" id="productName" >
      <a4j:support id="a4jsupport"/>
      </h:inputText>


      I don't understabnd why it doesn't work whereas it worked before.
      Thanks