0 Replies Latest reply on Jul 17, 2009 11:29 AM by aarongupta1983zzz

    Richfaces filter configurations

    aarongupta1983zzz Newbie

      Hello everybody,


      versions


        -Seam 2.1.1 GA


        -Richfaces 3.3.0 GA



      problem


      I want to speed-up the richfaces dataTable component. Therefore i would like to disable the parser.
      My configuration within the components.xml:



       <web:ajax4jsf-filter force-parser="false" 
        enable-cache="true" 
        url-pattern="*.seam"/>
      



      Still all AJAX requests are being parsed.


      As I understand, i can not use the following configuration within the web.xml because seam dynamically configures the richfaces filters:



       
       <context-param>
        <param-name>org.ajax4jsf.xmlparser.ORDER</param-name>
        <param-value>NONE</param-value>
       </context-param>
       <context-param>
        <param-name>org.ajax4jsf.xmlparser.NONE</param-name>
        <param-value>.*</param-value>
       </context-param>
      





      sources


        - similar problem in the old forum


        - similar problem in this.forum


        - JIRA task?