3 Replies Latest reply on Jul 24, 2009 11:00 AM by Ronald van Kuijk

    Rich Pages not rendering with Seam.

    James Cain Newbie
      I get a HTTP 404 status message saying that it can't find home.seam

      my index.html

      Code:
      <html>
      <head>
        <meta http-equiv="Refresh" content="0; URL=home.seam">
      </head>
      </html>

           


      my home.xhtml
      Code:

      <rich:page xmlns="http://www.w3.org/1999/xhtml"
           xmlns:ui="http://java.sun.com/jsf/facelets"
           xmlns:h="http://java.sun.com/jsf/html"
           xmlns:f="http://java.sun.com/jsf/core"
           xmlns:rich="http://richfaces.org/rich"
           xmlns:a4j="http://richfaces.org/a4j" markupType="xhtml"
           contentType="text/html" theme="Simple"
           width="1300" sidebarWidth="300"
           sidebarPosition="right">
           <f:facet name="sidebar">
                <ui:include src="/richfaces/layouts/page/includes/sidebar.xhtml" />
           </f:facet>
           <f:facet name="header">
                <ui:include src="/layouts/page/includes/header.xhtml" />
           </f:facet>
           <f:facet name="footer">
                <ui:include src="/layouts/page/includes/footer.xhtml" />
           </f:facet>
           <rich:tabPanel switchType="client">
                <rich:tab label="overview">
                     <rich:layout>
                          <rich:layoutPanel position="top" width="100%">
                          </rich:layoutPanel>
                          <rich:layoutPanel position="left" width="50%">
                          </rich:layoutPanel>
                          <rich:layoutPanel position="center" width="50%">
                          </rich:layoutPanel>
                          <rich:layoutPanel position="bottom">
                          </rich:layoutPanel>
                     </rich:layout>
                </rich:tab>
                <rich:tab label="Themes support">
                </rich:tab>
           </rich:tabPanel>
      </rich:page>
           


      my web.xml

      Code:
      <?xml version="1.0" encoding="UTF-8"?>
      <web-app version="2.4" xmlns="http://java.sun.com/xml/ns/j2ee"
           xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
           xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd">
           <description>Richfaces Components demo</description>
           <display-name>richfaces-demo</display-name>
           <context-param>
                <param-name>javax.faces.DEFAULT_SUFFIX</param-name>
                <param-value>.xhtml</param-value>
           </context-param>
           <context-param>
                <param-name>facelets.REFRESH_PERIOD</param-name>
                <param-value>2</param-value>
           </context-param>
           <context-param>
                <param-name>facelets.DEVELOPMENT</param-name>
                <param-value>true</param-value>
           </context-param>
           <context-param>
                <param-name>javax.faces.STATE_SAVING_METHOD</param-name>
                <param-value>server</param-value>
           </context-param>
           <context-param>
                <param-name>com.sun.faces.validateXml</param-name>
                <param-value>true</param-value>
           </context-param>
           <context-param>
                <param-name>com.sun.faces.verifyObjects</param-name>
                <param-value>false</param-value>
           </context-param>
           <context-param>
                <param-name>org.richfaces.SKIN</param-name>
                <param-value>classic</param-value>
           </context-param>
           <context-param>
                <param-name>org.ajax4jsf.VIEW_HANDLERS</param-name>
                <param-value>com.sun.facelets.FaceletViewHandler</param-value>
           </context-param>
           <context-param>
           <context-param>
                <param-name>org.richfaces.CONTROL_SKINNING</param-name>
                <param-value>enable</param-value>
           </context-param>
           <context-param>
                <param-name>org.ajax4jsf.handleViewExpiredOnClient</param-name>
                <param-value>true</param-value>
           </context-param>
           <context-param>
                <param-name>org.richfaces.LoadStyleStrategy</param-name>
                <param-value>ALL</param-value>
           </context-param>
           <context-param>
                <param-name>org.richfaces.LoadScriptStrategy</param-name>
                <param-value>ALL</param-value>
           </context-param>

           <listener>
                <listener-class>org.jboss.seam.servlet.SeamListener</listener-class>
           </listener>

           <filter>
                <filter-name>Seam Filter</filter-name>
                <filter-class>org.jboss.seam.servlet.SeamFilter</filter-class>
                <init-param>
                     <param-name>createTempFiles</param-name>
                     <param-value>false</param-value>
                </init-param>
                <init-param>
                     <param-name>maxRequestSize</param-name>
                     <param-value>100000</param-value>
                </init-param>
           </filter>
           <filter-mapping>
                <filter-name>Seam Filter</filter-name>
                <servlet-name>Faces Servlet</servlet-name>
                <dispatcher>FORWARD</dispatcher>
                <dispatcher>REQUEST</dispatcher>
                <dispatcher>INCLUDE</dispatcher>
                <dispatcher>ERROR</dispatcher>
           </filter-mapping>

           <servlet>
                <servlet-name>Faces Servlet</servlet-name>
                <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
                <load-on-startup>1</load-on-startup>
           </servlet>
           <servlet-mapping>
                <servlet-name>Faces Servlet</servlet-name>
                <url-pattern>*.seam</url-pattern>
           </servlet-mapping>
           <login-config>
                <auth-method>BASIC</auth-method>
           </login-config>
      </web-app>     `




      I have the required libs in my WEB-INF/lib folder
      richfaces-api-3.3.1.GA.jar
      richfaces-impl-3.3.1.GA.jar
      richfaces-ui-3.3.1.GA.jar
      themes-3.3.1.GA.jar

      home.xtml is location at the root level of my war and I get nothing, but if I use

      <html xmlns="http://www.w3.org/1999/xhtml" xmlns:s="http://jboss.com/product/seam/taglib"
      xmlns:h="http://java.sun.com/jsf/html" xmlns:f="http://java.sun.com/jsf/core"
      xmlns:a4j="http://richfaces.org/a4j" xmlns:rich="http://richfaces.org/rich">
      everything works fine.

      Any help is greatly appreciated.

      Thanks