3 Replies Latest reply on Jan 15, 2011 10:37 AM by Célio Latorraca

    jboss-seam-jpa lib versions

    Bruno Krebs Newbie

      Hello there,


      what are the lib versions used in this example (jboss-seam-jpa)? I'm trying to build it with maven, but it is building with different libs and my build is not working...


      By the way, I'm deploying it in tomcat 6, and it works when I build the example with ant, but not with maven...


      This is my maven file:




      <project xmlns="http://maven.apache.org/POM/4.0.0"
                 xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                 xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
        <repositories>
           <repository>
             <id>jboss-snapshot</id>
             <name>The JBoss maven repo</name>
             <url>http://repository.jboss.org/maven2</url>
           </repository>
        </repositories>
        <parent>
           <groupId>org.jboss.seam</groupId>
           <artifactId>root</artifactId>
           <version>2.2.0.GA</version>
        </parent>
        <modelVersion>4.0.0</modelVersion>
        <groupId>org.jboss.seam.example.jpa</groupId>
        <artifactId>jboss-seam-jpa</artifactId>
        <name>jboss-seam-jpa</name>
        <version>1.0</version>
        <packaging>war</packaging>
        <url>http://maven.apache.org</url>
        <build>
           <finalName>jboss-seam-jpa</finalName>
           <plugins>
             <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <configuration>
                  <source>1.5</source>
                  <target>1.5</target>
                </configuration>
             </plugin>
           </plugins>
        </build>
        <dependencies>
           <dependency>
             <groupId>antlr</groupId>
             <artifactId>antlr</artifactId>
             <version>2.7.6</version>
           </dependency>
           <dependency>
             <groupId>commons-beanutils</groupId>
             <artifactId>commons-beanutils</artifactId>
             <version>1.7.0</version>
           </dependency>
           <dependency>
             <groupId>commons-collections</groupId>
             <artifactId>commons-collections</artifactId>
             <version>3.2</version>
           </dependency>
           <dependency>
             <groupId>commons-digester</groupId>
             <artifactId>commons-digester</artifactId>
             <version>1.8.1</version>
           </dependency>
           <dependency>
             <groupId>commons-lang</groupId>
             <artifactId>commons-lang</artifactId>
             <version>2.3</version>
           </dependency>
           <dependency>
             <groupId>commons-logging</groupId>
             <artifactId>commons-logging</artifactId>
             <version>1.1.1</version>
           </dependency>
           <dependency>
             <groupId>concurrent</groupId>
             <artifactId>concurrent</artifactId>
             <version>1.3.4</version>
           </dependency>
           <dependency>
             <groupId>dom4j</groupId>
             <artifactId>dom4j</artifactId>
             <version>1.6.1</version>
           </dependency>
           <dependency>
             <groupId>org.hibernate</groupId>
             <artifactId>hibernate-annotations</artifactId>
             <version>3.4.0.ga</version>
           </dependency>
           <dependency>
             <groupId>org.hibernate</groupId>
             <artifactId>hibernate-commons-annotations</artifactId>
             <version>3.1.0.ga</version>
           </dependency>
           <dependency>
             <groupId>org.hibernate</groupId>
             <artifactId>hibernate</artifactId>
             <version>3.1.3</version>
           </dependency>
           <dependency>
             <groupId>org.hibernate</groupId>
             <artifactId>hibernate-core</artifactId>
             <version>3.3.1.ga</version>
           </dependency>
           <dependency>
             <groupId>org.hibernate</groupId>
             <artifactId>hibernate-entitymanager</artifactId>
             <version>3.4.0.ga</version>
           </dependency>
           <dependency>
             <groupId>org.hibernate</groupId>
             <artifactId>hibernate-validator</artifactId>
             <version>3.1.0.ga</version>
           </dependency>
           <dependency>
             <groupId>javassist</groupId>
             <artifactId>javassist</artifactId>
             <version>3.8.0.ga</version>
           </dependency>
           <dependency>
             <groupId>org.jboss</groupId>
             <artifactId>jboss-common-core</artifactId>
             <version>2.0.5.GA</version>
           </dependency>
           <dependency>
             <groupId>org.jboss.seam</groupId>
             <artifactId>jboss-el</artifactId>
             <version>2.0.0.GA</version>
           </dependency>
           <dependency>
             <groupId>org.jboss.seam</groupId>
             <artifactId>jboss-seam-debug</artifactId>
             <version>2.2.0.GA</version>
           </dependency>
           <dependency>
             <groupId>org.jboss.seam</groupId>
             <artifactId>jboss-seam-ui</artifactId>
             <version>2.2.0.GA</version>
           </dependency>
           <dependency>
             <groupId>org.jboss.seam</groupId>
             <artifactId>jboss-seam</artifactId>
             <version>2.2.0.GA</version>
           </dependency>
           <dependency>
             <groupId>javax.faces</groupId>
             <artifactId>jsf-api</artifactId>
             <version>1.2_12</version>
           </dependency>
           <dependency>
             <groupId>com.sun.facelets</groupId>
             <artifactId>jsf-facelets</artifactId>
             <version>1.1.15.B1</version>
           </dependency>
           <dependency>
             <groupId>javax.faces</groupId>
             <artifactId>jsf-impl</artifactId>
             <version>1.2_12</version>
           </dependency>
           <dependency>
                <groupId>javax.transaction</groupId>
                <artifactId>jta</artifactId>
                <version>1.1</version>
           </dependency>
           <dependency>
                <groupId>javax.persistence</groupId>
                <artifactId>persistence-api</artifactId>
                <version>1.0</version>
           </dependency>
           <dependency>
             <groupId>log4j</groupId>
             <artifactId>log4j</artifactId>
             <version>1.2.14</version>
           </dependency>
           <dependency>
             <groupId>org.richfaces.framework</groupId>
             <artifactId>richfaces-api</artifactId>
             <version>3.3.1.GA</version>
           </dependency>
           <dependency>
             <groupId>org.richfaces.framework</groupId>
             <artifactId>richfaces-impl</artifactId>
             <version>3.3.1.GA</version>
           </dependency>
           <dependency>
             <groupId>org.richfaces.ui</groupId>
             <artifactId>richfaces-ui</artifactId>
             <version>3.3.1.GA</version>
           </dependency>
           <dependency>
             <groupId>org.slf4j</groupId>
             <artifactId>slf4j-api</artifactId>
             <version>1.4.2</version>
           </dependency>
           <dependency>
             <groupId>org.slf4j</groupId>
             <artifactId>slf4j-log4j12</artifactId>
             <version>1.4.2</version>
           </dependency>
        </dependencies>
      </project>