1 Reply Latest reply on Sep 20, 2001 4:45 PM by Sundaram Ramasamy

    JBoss 2.4.1 waits forever during initialization

    Stanislav Krainikov Newbie

      Hei,

      I've downloaded a latest version of JBoss and runnig it under NT4.0/SP3

      I'm trying to connect to Oracle 8.1.5 SE located on another computer.

      Connecting outside JBoss via jdbc works fine, but when I try starting JBoss with setting presented below it stops at the point
      [XADataSourceLoader] Starting
      [DefaultDS] XA Connection pool DefaultDS bound to java:/DefaultDS

      It was starting fine with version 2.4.0 I've the following settings in my conf/default/jboss.jcml:


      FurfixDB
      org.jboss.pool.jdbc.xa.wrapper.XADataSourceImpl

      jdbc:oracle:thin:@pc37:1521:ORCL
      furfix
      fx
      false
      false
      false
      true
      120000
      1800000
      false
      false
      1.0
      10
      100


      Can somebody give me a hint what's wrong in my case?

      Regards, Stanislav

        • 1. Re: JBoss 2.4.1 waits forever during initialization
          Sundaram Ramasamy Newbie

          Hi,

          This is problem with your JDBC connection URL.

          Make sure oracle JDBC driver in jboss/lib/ext directory.

          in jboss.jcml check for JDBC provider.


          oracle.jdbc.driver.OracleDriver


          This is for PostgreSQL JDBC pool. Change your connectin URL, user name and passowrd.


          DefaultDS
          org.jboss.pool.jdbc.xa.wrapper.XADataSourceImpl

          jdbc:postgresql://localhost:5432/percipia
          1200000
          sundaram
          sun123
          10
          false
          false
          false
          true
          120000
          1800000
          false
          false
          1.0
          0


          I hope this will work.

          Enjoy
          -SR