5 Replies Latest reply on Apr 8, 2013 4:07 PM by kamal_khadka

    IE compability issue

    kamal_khadka Newbie

      In my application following is attached before

       

       

       

      <link class="component" href="/myApp/a4j/s/3_3_1.GAorg/richfaces/renderkit/html/css/basic_classes.xcss/DATB/eAELXT5DOhSIAQ!sA18_;jsessionid=E192EF88EB0FD476187E05B706F68504.node1" rel="stylesheet" type="text/css" /><link class="component" href="/myApp/a4j/s/3_3_1.GAorg/richfaces/renderkit/html/css/extended_classes.xcss/DATB/eAELXT5DOhSIAQ!sA18_;jsessionid=E192EF88EB0FD476187E05B706F68504.node1" media="rich-extended-skinning" rel="stylesheet" type="text/css" /><script src="/myApp/a4j/g/3_3_1.GAorg.ajax4jsf.javascript.AjaxScript" type="text/javascript"></script><script src="/myApp/a4j/g/3_3_1.GAorg.ajax4jsf.javascript.PrototypeScript" type="text/javascript"></script><script src="/myApp/a4j/g/3_3_1.GAorg/richfaces/renderkit/html/scripts/utils.js" type="text/javascript"></script><script src="/myApp/a4j/g/3_3_1.GAorg/richfaces/renderkit/html/scripts/browser_info.js" type="text/javascript"></script><script src="/myApp/a4j/g/3_3_1.GAorg/richfaces/renderkit/html/scripts/modalPanel.js" type="text/javascript"></script><script src="/myApp/a4j/g/3_3_1.GAorg/richfaces/renderkit/html/scripts/modalPanelBorders.js" type="text/javascript"></script><link class="component" href="/myApp/a4j/s/3_3_1.GAorg/richfaces/renderkit/html/css/modalPanel.xcss/DATB/eAELXT5DOhSIAQ!sA18_;jsessionid=E192EF88EB0FD476187E05B706F68504.node1" rel="stylesheet" type="text/css" /><script type="text/javascript">window.RICH_FACES_EXTENDED_SKINNING_ON=true;</script><script src="/myApp/a4j/g/3_3_1.GAorg/richfaces/renderkit/html/scripts/skinning.js" type="text/javascript"></script>

       

       

      before

       

      <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

       

      so unless the user click the compability view manually the application is not functional.

       

      I have

       

      !--   <context-param>  -->

      <!--       <param-name>org.richfaces.LoadStyleStrategy</param-name>  -->

      <!--   <param-value>NONE</param-value>  -->

      <!--   </context-param>  -->

      <!--   <context-param>  -->

      <!--   <param-name>org.richfaces.LoadScriptStrategy</param-name>   -->

      <!--     <param-value>NONE</param-value>   -->

      <!--     </context-param>  -->

      <!--     <context-param>  -->

      <!--        <param-name>org.ajax4jsf.RESOURCE_URI_PREFIX</param-name>  -->

      <!--        <param-value>cbRes/</param-value>  -->

      <!--     </context-param>  -->

       

      commented this out in web.xml. If i uncomment this nothing is attached before the meta http-equiv.

       

      In one of the page I am using rich:tab and for this to functioning properly I had to uncomment the above from web.xml.

       

      How should I go about fixing this.

       

      Tried adding those link only in the page that uses rich:tab that didn't work.

       

      Thank you very much for helping me.