2 Replies Latest reply on Feb 15, 2012 7:17 AM by Yves Peter

    Mod_cluster 1.2.0 Method Not Implemented

    Yves Peter Newbie

      Hello everyone

       

      I'm trying to set up the new mod_cluster 1.2.0 and have run into problems. The documentation here and the also the example configuration is wrong for the non-cluster mode:

       

        <!-- The core mod_cluster service -->
        <bean name="ModClusterService" class="org.jboss.modcluster.ModClusterService" mode="On Demand">
          <annotation>@org.jboss.aop.microcontainer.aspects.jmx.JMX(name="jboss.web:service=ModCluster",exposedInterface=org.jboss.modcluster.ModClusterServiceMBean.class)</annotation>
          <constructor>
            <!-- wrong: <parameter class="org.jboss.modcluster.config.ModClusterConfig"><inject bean="ModClusterConfig"/></parameter>
            correct: -->
            <parameter class="org.jboss.modcluster.config.impl.ModClusterConfig"><inject bean="ModClusterConfig"/></parameter>
            <parameter class="org.jboss.modcluster.load.LoadBalanceFactorProvider"><inject bean="DynamicLoadBalanceFactorProvider"/></parameter>
          </constructor>
        </bean>
      

       

      After that, apache is now complaining:

      INFO / HTTP/1.1
      Host: sd06009.uyellow.yellowcorp.test:80
      Content-Length: 0
      User-Agent: ClusterListener/1.0
      Connection: Keep-Alive
      
      HTTP/1.1 501 Method Not Implemented
      Date: Mon, 13 Feb 2012 21:42:56 GMT
      Server: Apache/2.2.21 (Unix) mod_cluster/1.2.0.Final
      Allow: GET,HEAD,POST,OPTIONS,TRACE
      Content-Length: 206
      Connection: close
      Content-Type: text/html; charset=iso-8859-1
      
      <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
      <html><head>
      <title>501 Method Not Implemented</title>
      </head><body>
      <h1>Method Not Implemented</h1>
      <p>INFO to / not supported.<br />
      </p>
      </body></html>
      

       

       

      Here is my httpd.conf:

       

      LoadModule proxy_module /opt/jboss/httpd/lib/httpd/modules/mod_proxy.so
      LoadModule proxy_ajp_module /opt/jboss/httpd/lib/httpd/modules/mod_proxy_ajp.so
      LoadModule proxy_cluster_module /opt/jboss/httpd/lib/httpd/modules/mod_proxy_cluster.so
      LoadModule manager_module /opt/jboss/httpd/lib/httpd/modules/mod_manager.so
      LoadModule slotmem_module /opt/jboss/httpd/lib/httpd/modules/mod_slotmem.so
      LoadModule authn_default_module /opt/jboss/httpd/lib/httpd/modules/mod_authn_default.so
      LoadModule authz_host_module /opt/jboss/httpd/lib/httpd/modules/mod_authz_host.so
      
      User apache
      Group apache
      
      Listen 10.32.34.116:80
      
      ServerRoot "/data/jboss/httpd/jsplb01test"
      DocumentRoot "/opt/jboss/httpd/htdocs/htdocs"
      
      Timeout 300
      KeepAlive On
      KeepAliveTimeout 60
      MaxKeepAliveRequests 0
      
      ManagerBalancerName mycluster 
      
      <VirtualHost 10.32.34.116:80>
      
         <Directory />
            Order deny,allow
            Allow from all
         </Directory>
      
      </VirtualHost>
      
      <Location /mod_cluster-manager>
        SetHandler mod_cluster-manager
      </Location>
      

       

      I can access /mod_cluster-manager and it shows that 1.2.0 is installed. Are there some changes to the configuration that I missed? I'm using the apache from here.

       

      I also noticed that the change list in the announcement on the front page doesn't include the changes for 1.2.0: http://docs.jboss.org/mod_cluster/1.2.0/html/changelog.html

       

      Thanks,

      Yves