1 Reply Latest reply on Mar 15, 2012 10:06 AM by Zaheer Ahmed

    Error: tried to access class com.google.common.base.Platform

    Zaheer Ahmed Novice

      Hi All

      I'm using 4.1.0 - Final richfaces version.  At runtime I'm getting this error ;

       

      java.lang.IllegalAccessError: tried to access class com.google.common.base.Platform from class com.google.common.base.CharMatcher

       

      has anyone face this problem ?

      This is how my pom.xml looks like;

       



      <dependency>



      <groupId>com.oracle</groupId>



      <artifactId>orai18n-mapping</artifactId>



      <version>11.2.0</version>


      </dependency>


      <dependency>



      <groupId>org.richfaces.core</groupId>



      <artifactId>richfaces-core-api</artifactId>



      <version>4.1.0.Final</version>


      </dependency>


      <dependency>



      <groupId>org.richfaces.core</groupId>



      <artifactId>richfaces-core-impl</artifactId>



      <version>4.1.0.Final</version>


      </dependency>


      <dependency>



      <groupId>org.richfaces.ui</groupId>



      <artifactId>richfaces-components-api</artifactId>



      <version>4.1.0.Final</version>


      </dependency>


      <dependency>



      <groupId>org.richfaces.ui</groupId>



      <artifactId>richfaces-components-ui</artifactId>



      <version>4.1.0.Final</version>


      </dependency>
      <!--
      <dependency> -->
      <!--

      <groupId>org.apache.myfaces.core</groupId> -->
      <!--

      <artifactId>myfaces-impl</artifactId> -->
      <!--

      <version>2.1.1</version> -->
      <!--
      </dependency> -->


      <dependency>



      <groupId>com.google.guava</groupId>



      <artifactId>guava</artifactId>



      <version>r08</version>


      </dependency>


      <dependency>



      <groupId>net.sourceforge.cssparser</groupId>



      <artifactId>cssparser</artifactId>



      <version>0.9.5</version>



      <type>pom</type>


      </dependency>


      <dependency>



      <groupId>org.w3c.css</groupId>



      <artifactId>sac</artifactId>



      <version>1.3</version>


      </dependency>

       

       

      Many thanks