3 Replies Latest reply on Oct 1, 2013 1:24 PM by Wolf-Dieter Fink

    Accessing JBOSS AS7 Remotely

    Brent Rogers Newbie

      I just installed JBOSS AS7  [7.1.1].

      It is up and running -- I can access via http://localhost:8080

       

      However when I try other machines on my network, I cannot connect.

       

      I doubt that this is a firewall issue, as I previoulsy had tomcat setup on the 8080 port [it is now 8081] and I could connect fine then.

       

      Is there a configuration setting somewhere that would allow connections from other machines?

       

       

      Thank You

      Brent Rogers

      brogers@cips.ca

        • 1. Re: Accessing JBOSS AS7 Remotely
          Wolf-Dieter Fink Master

          How do you start JBoss?

          If you start only bin/standalone.* without any configuration change it will be bound to 'localhost' which mean you can not access from other computer than this.

          Change configuration or use '-b <ip address>' with the real address or even 0.0.0.0

          • 2. Re: Accessing JBOSS AS7 Remotely
            Brent Rogers Newbie

            Thank you.

            The -b command line option works.

            Is there a configuration file setting that I can set/change such that I do not need to use the -b startup option?

            • 3. Re: Accessing JBOSS AS7 Remotely
              Wolf-Dieter Fink Master

              AS7 will be started with the 127.0.0.1 binding by default.

              If you look to the standalone/configuration/standalone*.xml you can change the default 127.0.0.1 with your IP for the configuration and maybe drop the ${} replacement expression

               

              <interfaces>
                  <interface name="management">
                      <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>
                  </interface>
                  <interface name="public">
                      <inet-address value="${jboss.bind.address:127.0.0.1}"/>
                  </interface>
                  ...
              1 of 1 people found this helpful