1 Reply Latest reply on Mar 30, 2012 8:01 AM by teejay78

    Question about RichFaces 3.3.3 Final and TinyMCE standard PlugIns

    teejay78 Newbie

      Hi,

       

      I am using RichFaces 3.3.3 Final and the integrated TinyMCE with standard plugins. However, I have problems using the plugins lists and print. If I add those to my configuration, the editor is not rendered. My configuration (external) looks like follows:

       

      theme = "advanced"

      plugins = "searchreplace,paste,table,fullscreen,contextmenu"

       

      theme_advanced_buttons1 = "undo,redo,|,bold,italic,underline,strikethrough,|,justifyleft,justifycenter,justifyright,justifyfull,|,bullist,numlist,|,outdent,indent,|,styleselect,formatselect,fontselect,fontsizeselect"

      theme_advanced_buttons2 = "cut,copy,paste,pastetext,pasteword,|,search,replace,|,link,unlink,|,removeformat,cleanup,visualaid,code,help,|,sub,sup,|,charmap,|,hr,|,image"

      theme_advanced_buttons3 = "tablecontrols,|,insertdate,inserttime,preview,|,forecolor,backcolor,|,fullscreen"

      theme_advanced_buttons4 = ""

       

      theme_advanced_toolbar_location = "top"                            

      theme_advanced_toolbar_align = "left"

       

      content_css = "#{facesContext.externalContext.requestContextPath}/stylesheets/richeditor.css"

       

      I am using MyFaces 1.2 and Facelets.

       

      <rich:editor id="#{id}" width="#{width}" height="#{height}" viewMode="visual" value="#{value}" configuration="tinymce_config">

      </rich:editor>

       

      Accessing with MacOS X and Chrome ... but doesn't work in Firefox also. The other plugins are working as expected. Does anyone had a similar problem and a possible solution to this? Thank you!

        • 1. Re: Question about RichFaces 3.3.3 Final and TinyMCE standard PlugIns
          teejay78 Newbie

          Hi,

           

          may be I have to explain the problem a bit more. If I use the following configuration ...

           

          theme = "advanced"

          plugins = "searchreplace,paste,table,fullscreen,contextmenu"

           

          theme_advanced_buttons1 = "undo,redo,|,bold,italic,underline,strikethrough,|,justifyleft,justifycenter,justifyright,justifyfull,|,bullist,numlist,|,outdent,indent,|,styleselect,formatselect,fontselect,fontsizeselect"

          theme_advanced_buttons2 = "cut,copy,paste,pastetext,pasteword,|,search,replace,|,link,unlink,|,removeformat,cleanup,visualaid,code,help,|,sub,sup,|,charmap,|,hr,|,image"

          theme_advanced_buttons3 = "tablecontrols,|,insertdate,inserttime,preview,|,forecolor,backcolor,|,fullscreen"

          theme_advanced_buttons4 = ""

           

          theme_advanced_toolbar_location = "top"                            

          theme_advanced_toolbar_align = "left"

           

          content_css = "#{facesContext.externalContext.requestContextPath}/stylesheets/richeditor.css"

           

          ... the editor is shown:

          one.png

           

          But if I add the usage of the print plugin ...

           

          theme = "advanced"

          plugins = "searchreplace,paste,print,table,fullscreen,contextmenu"

           

          theme_advanced_buttons1 = "undo,redo,|,bold,italic,underline,strikethrough,|,justifyleft,justifycenter,justifyright,justifyfull,|,bullist,numlist,|,outdent,indent,|,styleselect,formatselect,fontselect,fontsizeselect"

          theme_advanced_buttons2 = "cut,copy,paste,pastetext,pasteword,|,search,replace,|,link,unlink,|,removeformat,cleanup,visualaid,code,help,|,sub,sup,|,charmap,|,hr,|,image"

          theme_advanced_buttons3 = "tablecontrols,|,insertdate,inserttime,preview,|,forecolor,backcolor,|,fullscreen,|,print"

          theme_advanced_buttons4 = ""

           

          theme_advanced_toolbar_location = "top"                            

          theme_advanced_toolbar_align = "left"

           

          content_css = "#{facesContext.externalContext.requestContextPath}/stylesheets/richeditor.css"

           

          ... the editor is not rendered:

          two.png