2 Replies Latest reply on Mar 30, 2012 10:17 AM by 孙 绪满

    I use jboss 7 to deploy my project (war page),when I use jboss 7's Manager Page to redeploy project it occurs error!

    孙 绪满 Newbie

      16:12:34,095 WARN  [org.jboss.as.deployment] (MSC service thread 1-4) Class Path entry activation.jar in "/C:/webserver/jboss-as-7.1.0/standalone/deployments/boe123.war/WEB-INF/lib/mail-1.4.jar"  does not point to a valid jar for a Class-Path reference.

      16:12:34,298 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC00001: Failed to start service jboss.deployment.unit."boe123.war".STRUCTURE: org.jboss.msc.service.StartException in service jboss.deployment.unit."boe123.war".STRUCTURE: Failed to process phase STRUCTURE of deployment "boe1

      23.war"

              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:121) [jboss-as-server-7.1.0.CR1-SNAPSHOT.jar:]

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1824) [jboss-msc-1.0.1.GA.jar:]

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1759) [jboss-msc-1.0.1.GA.jar:]

              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_10-rc2]

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_10-rc2]

              at java.lang.Thread.run(Thread.java:619) [:1.6.0_10-rc2]

      Caused by: java.lang.NoClassDefFoundError: java/util/zip/DataFormatException

              at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:141) [:1.6.0_10-rc2]

              at java.util.jar.Manifest$FastInputStream.fill(Manifest.java:422) [:1.6.0_10-rc2]

              at java.util.jar.Manifest$FastInputStream.readLine(Manifest.java:358) [:1.6.0_10-rc2]

              at java.util.jar.Manifest$FastInputStream.readLine(Manifest.java:390) [:1.6.0_10-rc2]

              at java.util.jar.Attributes.read(Attributes.java:359) [:1.6.0_10-rc2]

              at java.util.jar.Manifest.read(Manifest.java:182) [:1.6.0_10-rc2]

              at java.util.jar.Manifest.<init>(Manifest.java:52) [:1.6.0_10-rc2]

              at org.jboss.vfs.VFSUtils.readManifest(VFSUtils.java:216) [jboss-vfs-3.1.0.CR1.jar:]

              at org.jboss.vfs.VFSUtils.getManifest(VFSUtils.java:199) [jboss-vfs-3.1.0.CR1.jar:]

              at org.jboss.as.server.deployment.module.ManifestClassPathProcessor.getClassPathEntries(ManifestClassPathProcessor.java:209) [jboss-as-server-7.1.0.CR1-SNAPSHOT.jar:]

              at org.jboss.as.server.deployment.module.ManifestClassPathProcessor.deploy(ManifestClassPathProcessor.java:145) [jboss-as-server-7.1.0.CR1-SNAPSHOT.jar:]

              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:115) [jboss-as-server-7.1.0.CR1-SNAPSHOT.jar:]

              ... 5 more

       

       

      I must deploy several times to be successful!

       

      anyone can help me!  My native language is not English! sorry for my Wrong character!