3 Replies Latest reply: Apr 19, 2012 3:57 PM by Jeeva Paramasamy RSS

    "XAConnectionFactory not bound" error in 2 cluster nodes out of 10 nodes.

    Jeeva Paramasamy Newbie

      Jboss: jboss-4.0.5.GA

      Java: 1.6

      Os: linux

       

      We have 10 node clustered servers and deploying some MDBs, queue and topics in all servers. While starting servers getting below error for last 2 servers. other 8 servers have no issue.

       

      2012-04-10 16:20:57,582 DEBUG [org.jboss.ejb.plugins.jms.JMSContainerInvoker] Initializing

      2012-04-10 16:20:57,582 DEBUG [org.jboss.ejb.plugins.jms.JMSContainerInvoker] Looking up provider adapter: java:/DefaultJMSProvider

      2012-04-10 16:20:57,582 DEBUG [org.jboss.ejb.plugins.jms.JMSContainerInvoker] Provider adapter: org.jboss.jms.jndi.JNDIProviderAdapter@39cb0604

      2012-04-10 16:20:57,582 TRACE [org.jboss.ejb.plugins.jms.DLQHandler] Constructing

      2012-04-10 16:20:57,582 DEBUG [org.jboss.ejb.plugins.jms.DLQHandler] Creating DLQHandler

      2012-04-10 16:20:57,583 TRACE [org.jboss.ha.jndi.TreeHead] lookup, name=XAConnectionFactory

      2012-04-10 16:20:57,583 TRACE [org.jboss.ha.jndi.TreeHead] lookupLocally, name=XAConnectionFactory

      2012-04-10 16:20:57,583 TRACE [org.jboss.ha.jndi.TreeHead] lookupLocally failed, name=XAConnectionFactory

      javax.naming.NameNotFoundException: XAConnectionFactory not bound

              at org.jnp.server.NamingServer.getBinding(NamingServer.java:529)

              at org.jnp.server.NamingServer.getBinding(NamingServer.java:537)

              at org.jnp.server.NamingServer.getObject(NamingServer.java:543)

              at org.jnp.server.NamingServer.lookup(NamingServer.java:296)

              at org.jboss.ha.jndi.TreeHead.lookupLocally(TreeHead.java:296)

              at org.jboss.ha.jndi.TreeHead.lookup(TreeHead.java:215)

              at org.jboss.ha.jndi.HAJNDI.lookup(HAJNDI.java:155)

              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

              at java.lang.reflect.Method.invoke(Method.java:597)

              at org.jboss.ha.framework.interfaces.HARMIClient.invoke(HARMIClient.java:258)

              at $Proxy266.lookup(Unknown Source)

              at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:625)

       

      we have debugged whatever we can, but no luck. Please help us to resolve this production issue.

       

      here is the other server log, which has no error.

       

      2012-04-10 19:36:54,321 DEBUG [org.jboss.ejb.plugins.jms.DLQHandler] Creating DLQHandler

      2012-04-10 19:36:54,321 DEBUG [org.jboss.mq.referenceable.SpyConnectionFactoryObjectFactory] Extracting SpyConnectionFactory from reference

      2012-04-10 19:36:54,323 DEBUG [org.jboss.mq.referenceable.SpyConnectionFactoryObjectFactory] The GenericConnectionFactory is: GenericConnectionFactory[server=org.jboss.mq.il.uil2.UILServerIL@7f3424c5 connectionProperties={ClientILService=org.jboss.mq.il.uil2.UILClientILService, UIL_TCPNODELAY_KEY=yes, UIL_CHUNKSIZE_KEY=1000000, UIL_CONNECTADDRESS_KEY=null, UIL_CONNECTPORT_KEY=0, UIL_SOTIMEOUT_KEY=120000, UIL_RECEIVE_REPLIES_KEY=No, UIL_ADDRESS_KEY=10.2.7.121, UIL_PORT_KEY=8093, PingPeriod=60000, UIL_BUFFERSIZE_KEY=2048}]

      2012-04-10 19:36:54,323 DEBUG [org.jboss.ejb.plugins.jms.DLQHandler] Using factory: org.jboss.mq.SpyXAConnectionFactory@385a42c1

      2012-04-10 19:36:54,323 TRACE [org.jboss.mq.Connection] Connection Initializing userName=null Connection@768911822[clientID=null rcvstate=STOPPED]

      2012-04-10 19:36:54,323 TRACE [org.jboss.mq.Connection] Getting the serverIL Connection@768911822[clientID=null rcvstate=STOPPED]

      2012-04-10 19:36:54,323 TRACE [org.jboss.mq.Connection] serverIL=org.jboss.mq.il.uil2.UILServerIL@64d82ae3 Connection@768911822[clientID=null rcvstate=STOPPED]

      2012-04-10 19:36:54,323 TRACE [org.jboss.mq.Connection] Authenticating user null Connection@768911822[clientID=null rcvstate=STOPPED]

      2012-04-10 19:36:54,323 TRACE [org.jboss.mq.il.uil2.UILServerIL] Begin connect loop, maxRetries=10, delay=0

      2012-04-10 19:36:54,323 TRACE [org.jboss.mq.il.uil2.UILServerIL] Connecting with addr=10.2.7.121, port=8093, localAddr=null, localPort=0, socketFactory=javax.net.DefaultSocketFactory@1278c77c, enableTcpNoDelay=true, bufferSize=2048, chunkSize=1000000

      2012-04-10 19:36:54,324 TRACE [org.jboss.mq.il.uil2.UILServerILService] Accepted connection: Socket[addr=/10.2.7.121,port=35169,localport=8093]

       

       

       

      we were checking in jmx_console in all servers, we see "XAConnectionFactory" JNDI name only in master node and other cluster nodes have entry for this and some our queues and topics. is this correct behaviour?