0 Replies Latest reply: Apr 20, 2012 10:04 AM by jeremie Granat RSS

    Clusterings not working

    jeremie Granat Newbie

      Hi,

       

      I tried to create a simple cluster with explicit connections. Everything seems to be correctly configured as I have a ClusterConnection node in the JMX tree with a cluster and see the other node in the "nodes" attributes. The address is, same as in the examples "jmx.#".

       

      However, sending 1000 Messages on one server will just have its queue accept 1000 messages, there is no load balancing being done and when I connect to the other server to consume the messages, I get a time out on the "messageConsumer.receive(5000);".

       

      I'm not really sure what I'm doing wrong if anyone could help...

       

      Here the relevant config snippets. Both server are configured exactly the same way:

       

      <clustered>true</clustered>

      ...

      <cluster-connections>

            <cluster-connection name="my-cluster">

               <address>jms.#</address>

               <connector-ref>netty</connector-ref>

               <retry-interval>500</retry-interval>

               <use-duplicate-detection>true</use-duplicate-detection>

               <forward-when-no-consumers>true</forward-when-no-consumers>

               <static-connectors>

                  <connector-ref>otherServer-connector</connector-ref>

               </static-connectors>

            </cluster-connection>

         </cluster-connections>

      ...

        <address-settings>

            <!--default for catch all-->

            <address-setting match="jms.#">

               <dead-letter-address>jms.queue.DLQ</dead-letter-address>

               <expiry-address>jms.queue.ExpiryQueue</expiry-address>

               <redelivery-delay>0</redelivery-delay>

               <max-size-bytes>104857600</max-size-bytes>

               <page-size-bytes>10485760</page-size-bytes>

               <message-counter-history-day-limit>10</message-counter-history-day-limit>

               <address-full-policy>PAGE</address-full-policy>

               <redistribution-delay>0</redistribution-delay>

            </address-setting>

         </address-settings>