3 Replies Latest reply on Apr 26, 2012 9:30 AM by Brendan Healey

    Migration to RF 4.2.1 rich:tooltip behaviour

    bthalmayr Newbie

      After migration from 3.3.3 to 4.2.1 rich:tooltip component seems to behave differently; it does not render when using within a standard JSF or RF tag.

       

      Following works:

       

      {code:xml}

      <p>Text1

      <rich:tooltip id="tt1">

      <span>tooltip1</span>

      </rich:tooltip>

      </p>

      {code}

       

       

      {code:xml}

      <a4j:commandButton id="cbutton1" value="CB1"/>

      <rich:tooltip id="tt2" target="cbutton1">

        <span>tooltip2</span>

      </rich:tooltip>

      {code}

       

       

      {code:xml}

      <h:button id="button1" value="B1"/>

      <rich:tooltip target="button1">

        <span>tooltip3</span>

      </rich:tooltip>

      {code}

       

      Following does not work

       

      {code:xml}

      <a4j:commandButton id="cbutton1" value="CB1">

         <rich:tooltip id="tt4">

            <span>tooltip4</span>

         </rich:tooltip>

      </a4j:commandButton>

      {code}

       

       

      {code:xml}

      <aj4:commandButton id="cbutton2" value="CB2">

        <rich:tooltip id="tt5" target="cbutton2">

          <span>tooltip5</span>

         </rich:tooltip>

      </a4j:commandButton>

      {code}

       

      I've read the lot's of documentation, but probably the wrong one. I also had a look at the showcase. I tried wrapping everythin in 'a4j:outputPanel'

       

      I'm pretty sure I missed something.

       

      Thanks for any pointers.