0 Replies Latest reply on Apr 27, 2012 2:27 PM by tberne

    How to set org.apache.xalan.xsltc.trax.SmartTransformerFactoryImpl as transformer in Managed server

    tberne Newbie


      I'm having a problem setting the org.apache.xalan.xsltc.trax.SmartTransformerFactoryImpl as the javax.xml.transform.TransformerFactory when using the AS 7 in domain mode. If I put the following property in standalone.xml, everything works, but if I add the same in a server in host.xml (or in domain.xml) the server won't start.


                                                <property name="javax.xml.transform.TransformerFactory" value="org.apache.xalan.xsltc.trax.SmartTransformerFactoryImpl"/>


      I have in my deployment the xalan lib, but I even tried to put it as a global module. Nothing worked. I noticed the following error in console:


      [Server:server-one] Exception in thread "main" javax.xml.transform.TransformerFactoryConfigurationError: Provider org.apache.xalan.xsltc.trax.SmartTransformerFactoryImpl not found
      [Server:server-one]     at javax.xml.transform.TransformerFactory.newInstance(TransformerFactory.java:108)
      [Server:server-one]     at __redirected.__TransformerFactory.<clinit>(__TransformerFactory.java:66)
      [Server:server-one]     at __redirected.__JAXPRedirected.initAll(__JAXPRedirected.java:82)
      [Server:server-one]     at org.jboss.modules.Module$1.run(Module.java:88)
      [Server:server-one]     at org.jboss.modules.Module$1.run(Module.java:75)
      [Server:server-one]     at java.security.AccessController.doPrivileged(Native Method)
      [Server:server-one]     at org.jboss.modules.Module.<clinit>(Module.java:75)
      [Server:server-one]     at org.jboss.modules.Main.main(Main.java:257)


      If I simply remove the property the server works fine.


      What else can I do??


      I'm using the JBoss AS 7.0.2 Final.