2 Replies Latest reply on Jul 20, 2012 7:01 PM by Andres Bravo

    Problem starting multiple instances of JBoss in the same server:

    Andres Bravo Newbie

      Hi everybeody, I'm configuring multiples instances of JBoss in the same server.

      I did this:

      1. Copy the folder all to nodeaux2

      2. Cause I'm in a cluster mode, I copied the folder mod_cluster\deploy to nodeaux2\deploy

      3. I configured the files used by mod_cluster

      4. In bindingservice.beans I changed the file bindings-jboss-beans.xml to use the alternate ports

      <parameter>${jboss.service.binding.set:ports-01}</parameter>

       

      Then when I try to start the server I got this problem:

       

       

      DEPLOYMENTS MISSING DEPENDENCIES:

        Deployment "jboss.web.deployment:war=/ROOT" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/admin-console" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/invoker" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/jbossws" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/jmx-console" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/juddi" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/my-webapp-sample1" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/prototype-web" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/web-console" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

       

       

      DEPLOYMENTS IN ERROR:

        Deployment "vfsfile:/opt/jboss-eap-5.1/jboss-as/server/nodeaux2/farm/farm-service.xml" is in error due to the following reason(s): java.lang.ClassNotFoundException: org.jboss.ha.framework.server.FarmMemberService from BaseClassLoader@1d39e225{vfsfile:/opt/jboss-eap-5.1/jboss-as/server/nodeaux2/farm/farm-service.xml}

        Deployment "WebServer" is in error due to the following reason(s): java.lang.IllegalStateException: Unable to locate delegate bean HAModCluster; listener is nonfunctional

        Deployment "jboss.web:service=WebServer" is in error due to the following reason(s): ** NOT FOUND Depends on 'jboss.web:service=WebServer' **

       

       

      12:28:51,542 INFO  [ServerImpl] JBoss (Microcontainer) [5.1.0 (build: SVNTag=JBPAPP_5_1_0 date=201009150028)] Started in 56s:127ms

       

      sh /opt/jboss-eap-5.1/jboss-as/bin/run.sh -c nodeaux2 -g A -u 224.0.0.0 -m 1110 -b 192.168.0.244 -Djboss.Domain=A -Djboss.jvmRoute="nodeaux2" -Djboss.messaging.ServerPeerID:0=3

       

      Sincerely I hope someone can help me.

       

      Greeting and thanks!!

        • 1. Re: Problem starting multiple instances of JBoss in the same server:
          Wolf-Dieter Fink Master

          I supose you miss something during configuration.

          Could you do it step-by-step and start the instance after each step to be sure it works.

           

          In case of an error you should attach more of the logfile there is often a warn or error message before the MISSINGDEPENDENCIES message.

          • 2. Re: Problem starting multiple instances of JBoss in the same server:
            Andres Bravo Newbie

            Hi, thanks I checked and I found a problem with white spaces... ¬¬

             

            But there's a new problem.

            I have my two instances of JBoss in the server 192.168.0.244

            Running in this ports:

            instance 1: 192.168.0.244:8080

            instance 2: 192.168.0.244:8180

             

            When I go to the JBoss admin-console on instance 1 everything it's ok, then I go to the admin-console on instance2 with the same login (admin admin) the session in the instance1 terminates, and it's necesaray to start a new session. This occurs with each instance.

            They are mutually exclusive, I guess that they are sharing some elements, but I don't know which.

             

            Any suggest to fix this problem??

             

            Thank's again.