0 Replies Latest reply on Mar 21, 2002 6:46 AM by Jon Rickard

    Setting up non-XA Oracle datasource

    Jon Rickard Newbie

      I'm new to JBoss and am experiencing problems trying to connect to Oracle. I'm using JBoss 2.4.4 and Tomcat 3.2.3 and the application is just using servlets with no EJB. I am just trying to use JBoss for the JNDI and database connection pooling.

      The application appears to work fine, but when I insert data to the database it only actually arrives (or is visible) in the database when I shutdown the JBoss application server. As a test, I've ported everything to MySQL and it all works fine. I think this may be something to do with the fact that I'm using an XADataSource and that Oracle is never told to commit the data - but I'm guessing. But this would explain why it works OK with MySQL but not with Oracle as I'm not using transactional support in MySQL.

      It would really help if someone has an example of configuring an Oracle DB just for use as a connection pool.

      Here is the config from the jboss.jcml :


      ORADB
      oracle.jdbc.xa.client.OracleXADataSource
      jdbc:oracle:thin:@localhost:1521:ORCL2
      ufs
      ufs
      1
      10
      true
      false
      false
      true
      60000
      60000
      60000
      1.0


      I've tried all kinds of options here including using the org.jboss.pool.jdbc.xa.wrapper.XADataSourceImpl DataSourceClass but nothing has made any difference.

      Any help would be greatly appreciated.