0 Replies Latest reply on Jul 31, 2012 6:41 AM by Ramasubramaniam Chandrasekaran

    NullPointerException at org.jboss.as.webservices.util.ASHelper.getEndpointClassName(ASHelper.java:129)

    Ramasubramaniam Chandrasekaran Newbie

      Am trying to deploy a spring based web service WAR in JBoss AS 7.1.1, the WAR is already running fine in IBM WAS.

       

      While deploying, I get the following error

       

      20:42:27,387 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: JBoss AS 7.1.1.Final "Brontes" started in 2297ms - Started 198 of 278 services

      (78 services are passive or on-demand)

       

      20:43:26,682 INFO  [org.jboss.as.repository] (HttpManagementService-threads - 1) JBAS014900: Content added at location C:\Data\JBoss_Application_Serve

      r7\.\standalone\data\content\43\1678372d418f5c34ff3a2127667088303e7f4d\content

      20:43:36,385 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "MyService.war"

       

      20:43:36,994 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC00001: Failed to start service jboss.deployment.unit."MyService

      .war".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.unit."MyService.war".PARSE: Failed to process phase PARSE of

      deployment "MyService.war"

              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:119) [jboss-as-server-7.1.1.Final.jar:7.1.1

      .Final]

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_21]

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_21]

              at java.lang.Thread.run(Thread.java:619) [rt.jar:1.6.0_21]

      Caused by: java.lang.NullPointerException

              at org.jboss.as.webservices.util.ASHelper.getEndpointClassName(ASHelper.java:129)

              at org.jboss.as.webservices.deployers.WSIntegrationProcessorJAXRPC_POJO.newPojoEndpoint(WSIntegrationProcessorJAXRPC_POJO.java:84)

              at org.jboss.as.webservices.deployers.WSIntegrationProcessorJAXRPC_POJO.createJaxrpcDeployment(WSIntegrationProcessorJAXRPC_POJO.java:75)

              at org.jboss.as.webservices.deployers.WSIntegrationProcessorJAXRPC_POJO.deploy(WSIntegrationProcessorJAXRPC_POJO.java:57)

              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.1.Final.jar:7.1.1

      .Final]

              ... 5 more

       

      Please help.