0 Replies Latest reply on Aug 23, 2012 4:32 PM by suneelg

    Resource not registered : /org/richfaces/renderkit/html/css/basic_classes.xcss

    suneelg Newbie

      Hi,

           I am getting the followign errors in our dynatrace logs ( a client used to track and test the server performance).

       

      Exception Class:     org.ajax4jsf.resource.ResourceNotFoundException

      Message: Resource not registered : /org/richfaces/renderkit/html/css/basic_classes.xcss

       

      Exception Class:     org.ajax4jsf.resource.ResourceNotFoundException

      Message: Resource not registered : /org/richfaces/renderkit/html/css/extended_classes.xcss

       

      Weirdly, i don't see these errors in our test and production evnironments system logs ,except for in dynatrace. Out of all the other style sheets , these two style sheets are the only one that throw resource not found.

       

       

      My web.xml declaration

      <context-param>

              <param-name>org.ajax4jsf.RESOURCE_URI_PREFIX</param-name>

              <param-value>a4j_resource</param-value>

          </context-param>

       

      and my htmlhead code in prod and test environements.

       

      PROD

      <head>

      <link class="component" type="text/css" rel="stylesheet" href="/test/faces/a4j/s/3_3_3.Finalorg/richfaces/renderkit/html/css/basic_classes.xcss/DATB/eAELXT5DOhSIAQ!sA18_">

      <link class="component" type="text/css" rel="stylesheet" href="/test/faces/a4j/s/3_3_3.Finalorg/richfaces/renderkit/html/css/extended_classes.xcss/DATB/eAELXT5DOhSIAQ!sA18_">

      <script type="text/javascript" src="/test/faces/a4j/g/3_3_3.Finalorg.ajax4jsf.javascript.AjaxScript">

      <script type="text/javascript" src="/test/faces/a4j/g/3_3_3.Finalorg.ajax4jsf.javascript.PrototypeScript">

      <script type="text/javascript" src="/test/faces/a4j/g/3_3_3.Finalorg/richfaces/renderkit/html/scripts/utils.js">

      <script type="text/javascript" src="/test/faces/a4j/g/3_3_3.Finalorg/richfaces/renderkit/html/scripts/browser_info.js">

      <script type="text/javascript" src="/test/faces/a4j/g/3_3_3.Finalorg/richfaces/renderkit/html/scripts/modalPanel.js">

      <script type="text/javascript" src="/test/faces/a4j/g/3_3_3.Finalorg/richfaces/renderkit/html/scripts/modalPanelBorders.js">

      <link class="component" type="text/css" rel="stylesheet" href="/test/faces/a4j/s/3_3_3.Finalorg/richfaces/renderkit/html/css/modalPanel.xcss/DATB/eAELXT5DOhSIAQ!sA18_">

      <link class="component" type="text/css" rel="stylesheet" href="/test/faces/a4j/s/3_3_3.Finalcss/panel.xcss/DATB/eAELXT5DOhSIAQ!sA18_">

      </head>

       

       

      TEST

      <head>

      <script type="text/javascript" src="/test/faces/a4j_resource/org/ajax4jsf/framework.pack.js">

      <script type="text/javascript" src="/test/faces/a4j_resource/org/richfaces/ui.pack.js">

      <link class="component" type="text/css" rel="stylesheet" href="/test/faces/a4j_resourceorg/richfaces/renderkit/html/css/basic_classes.xcss/DATB/eAELXT5DOhSIAQ!sA18_">

      <link class="component" type="text/css" rel="stylesheet" href="/test/faces/a4j_resourceorg/richfaces/renderkit/html/css/extended_classes.xcss/DATB/eAELXT5DOhSIAQ!sA18_">

      <link class="component" type="text/css" rel="stylesheet" href="/test/faces/a4j_resource/org/richfaces/skin.xcss/DATB/eAELXT5DOhSIAQ!sA18_">

      </head>

       

      Could someone please tell me , why the exceptions are being thrown only in specific scenario? What's the cause for the exception beign thrown?

       

      Thanks,