3 Replies Latest reply on Aug 30, 2012 12:17 PM by Nicklas Karlsson

    Problem with jboss-app.xml in AS7.1.1

    tscheky Newbie

      Hi all,

       

      during startup of the AS7.1 with a simple ear-file following exception occurs:

       

      10:03:47,372 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC00001: Failed to start service jboss.deployment.unit."RFTwo.ear".STRUCTURE: org.jboss.msc.service.StartException in service jboss.deployment.unit."RFTwo.ear".STRUCTURE: Failed to process phase STRUCTURE of deployment "RFTwo.ear"

      at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:119) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

      at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_20]

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_20]

      at java.lang.Thread.run(Thread.java:619) [rt.jar:1.6.0_20]

      Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011059: Failed to parse "/D:/Programme/JBoss7.1/bin/content/RFTwo.ear/META-INF/jboss-app.xml"

      at org.jboss.as.ee.structure.EarMetaDataParsingProcessor.handleJbossMetadata(EarMetaDataParsingProcessor.java:123)

      at org.jboss.as.ee.structure.EarMetaDataParsingProcessor.deploy(EarMetaDataParsingProcessor.java:64)

      at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

      ... 5 more

      Caused by: com.ctc.wstx.exc.WstxParsingException: Received non-all-whitespace CHARACTERS or CDATA event in nextTag().

      at [row,col {unknown-source}]: [7,21]

      at com.ctc.wstx.sr.StreamScanner.constructWfcException(StreamScanner.java:606)

      at com.ctc.wstx.sr.StreamScanner.throwParseError(StreamScanner.java:479)

      at com.ctc.wstx.sr.StreamScanner.throwParseError(StreamScanner.java:464)

      at com.ctc.wstx.sr.BasicStreamReader.nextTag(BasicStreamReader.java:1137)

      at org.jboss.metadata.parser.jboss.JBossAppMetaDataParser.parse(JBossAppMetaDataParser.java:88)

      at org.jboss.as.ee.structure.EarMetaDataParsingProcessor.handleJbossMetadata(EarMetaDataParsingProcessor.java:120)

      ... 7 more

       

      My ear has following jboss-app.xml:

       

      <?xml version="1.0" encoding="UTF-8"?>

      <!DOCTYPE jboss-app

          PUBLIC "-//JBoss//DTD J2EE Application 4.2//EN"

          "http://www.jboss.org/j2ee/dtd/jboss-app_4_2.dtd">

       

      <jboss-app>

          <module-order>strict</module-order>

          <loader-repository>seam.jboss.org:loader=RFTwo.ear</loader-repository>

      </jboss-app>

       

       

      The same ear makes no problem when starting on AS7.0!

       

      Any ideas?

      Thank you!

      Regards Gerhard