5 Replies Latest reply on Oct 30, 2012 5:14 PM by jacktrades

    Forge 1.1.1, can't make ticket monster work

    jacktrades Newbie

      Trying to make Ticket Monster work, but I get nothing but erros, installed a couple of plugins, still no change. Enviroment is Win7, enviromental variables are set. Tried in CentOS, got errors too. (both x64).

       

      Tried with Forge 1.0.2.Final - Same story.

       

      forge.PNG

        • 1. Re: Forge 1.1.1, can't make ticket monster work
          George Gastaldi Master

          Hi jacktrades,

           

          I just tested and the "run admin_layer.fsh" runs perfectly. Can you please paste the commands you used to generate the application in this post ?

          Also, try with the following repositiory configured in your settings.xml :

           

              <profile>
                        <id>jboss-public-repository</id>
                        <repositories>
                                  <repository>
                                            <id>jboss-public-repository</id>
                                            <name>Repositorio JBoss</name>
                                            <url>https://repository.jboss.org/nexus/content/groups/public/</url>
                                            <releases>
                                                      <enabled>true</enabled>
                                            </releases>
                                            <snapshots>
                                                      <enabled>true</enabled>
                                            </snapshots>
                                  </repository>
                        </repositories>
                        <pluginRepositories>
                                    <pluginRepository>
                                              <id>jboss-public-repository</id>
                                              <name>JBoss Public Maven Repository Group</name>
                                              <url>https://repository.jboss.org/nexus/content/groups/public/</url>
                                              <layout>default</layout>
                                              <releases>
                                                        <enabled>true</enabled>
                                                        <updatePolicy>never</updatePolicy>
                                              </releases>
                                              <snapshots>
                                                        <enabled>true</enabled>
                                                        <updatePolicy>never</updatePolicy>
                                              </snapshots>
                          </pluginRepository>
                </pluginRepositories>
            </profile>
           <activeProfiles>
                      <activeProfile>jboss-public-repository</activeProfile>
            </activeProfiles>
          
          
          1 of 1 people found this helpful
          • 2. Re: Forge 1.1.1, can't make ticket monster work
            Pete Muir Master

            I think this is a bug in something around the maven integration for Forge. I've seen similar before. Cristian, try running the build from the command line first, to get all the dependencies resolved. George, try testing with an empty maven repo...

            • 3. Re: Forge 1.1.1, can't make ticket monster work
              George Gastaldi Master

              Pete,

               

              I just managed to reproduce the error by running it without having the jboss-repository set up in my settings.xml. I emptied my repository before testing and added it again and it all worked.

              However, I am getting "patch does not apply" errors when confirming to apply the patches.

              1 of 1 people found this helpful
              • 4. Re: Forge 1.1.1, can't make ticket monster work
                jacktrades Newbie

                Pete,

                 

                That exact thought came in to my mind, so I'm glad I can think like a guru like you 

                • 5. Re: Forge 1.1.1, can't make ticket monster work
                  jacktrades Newbie

                  After building with maven, got dependencies downloaded (indeed Pete was right), then a build error, then 'run admin_layer.fsh' then I got a String index out of range...

                   

                  EDIT: Did mvn clean package and BUILD was succesful. (made a mistake doing mvn clean build)

                   

                  Then I did run admin_layer.fsh and build was succeess!

                   

                  So in my case, basically, the steps were backwards, had to package the application first, then run forge

                   

                  forge.PNG