4 Replies Latest reply on Dec 4, 2012 11:21 AM by Michael G

    mod_cluster not seeing jboss cluster or not forwarding request.

    Michael G Novice

      Hello,

       

      I'm using the download for windows environment and followed the instructions of the quick start but nothing is happening when i run the cluster demo from the https://docs.jboss.org/author/display/AS71/AS7+Cluster+Howto wiki.

       

      I had troubles with getting httpd to run but found a machine that did work but when i start it up i see this in the jboss server console.

       

      [Server:server-three] 09:11:38,043 ERROR [org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) Error [null: null: {4}] sending command INFO to proxy serverOne.internal.testing.com/129.204.171.90:8888, configuration will be reset

       

      It just repeats on the slave machine.

       

      Here is what is in my error.log:

       

       

      Tue Dec 04 09:05:55 2012] [notice] Child 3512: Starting 64 worker threads.
      [Tue Dec 04 09:05:55 2012] [notice] Child 3512: Starting thread to listen on port 8000.
      [Tue Dec 04 09:05:55 2012] [notice] Child 3512: Starting thread to listen on port 8888.
      [Tue Dec 04 09:05:58 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:06:08 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:06:18 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:06:28 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:06:38 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:06:48 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:06:58 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:07:08 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:07:18 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:07:28 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:07:38 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:07:48 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:07:58 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:08:08 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:08:18 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:08:28 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:08:38 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:08:48 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:08:58 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:09:08 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:09:18 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:09:28 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:09:38 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:09:48 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:09:58 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:10:08 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:10:18 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:10:28 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:10:38 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:10:48 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:10:58 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:11:08 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:11:18 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:11:28 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:11:38 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:11:48 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:11:58 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:12:08 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:12:18 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:12:28 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:12:38 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:12:48 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:12:58 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:13:08 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:13:18 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:13:28 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:13:38 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:13:48 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:14:12 2012] [warn] (OS 64)The specified network name is no longer available.  : winnt_accept: Asynchronous AcceptEx failed.
      [Tue Dec 04 09:14:16 2012] [warn] (OS 64)The specified network name is no longer available.  : winnt_accept: Asynchronous AcceptEx failed.
      [Tue Dec 04 09:14:16 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:14:26 2012] [error] [client 129.204.170.206] client denied by server configuration: C:/
      [Tue Dec 04 09:14:29 2012] [error] [client 129.204.153.41] client denied by server configuration: proxy:balancer://main-server-group/
      
        • 1. Re: mod_cluster not seeing jboss cluster or not forwarding request.
          Radoslav Husar Master

          "client denied by server configuration"

          The INFO message is sent using HTTP. You need to allow your AS instance to communicate with mod_cluster Apache front-end. The log is hinting that you haven't allowed AS' IP address to connect to Apache. Look at lines "deny from all" and "allow from ...".

          1 of 1 people found this helpful
          • 2. Re: mod_cluster not seeing jboss cluster or not forwarding request.
            Michael G Novice

            Ok

             

            so i set it to allow all (temporarily for testing) and it seems like httpd and jboss can find each other.  I get this message on JBoss

             

            [org.jboss.modcluster.ModClusterService] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) Engine [jboss.web] will use jvmRoute: 8b3f1230-3038-3c32-984c-af985e265dcf

             

            However, when i try to hit the cluster-demo url i get the 404 again, i don't see errors in the httpd log.  When i try to hit the mod_cluster-manager url i get the service temporarily unavailable.

             

            Here is the change that is in httpd.conf that installconf set + my changes for my env.

             

            LoadModule proxy_module modules/mod_proxy.so

            LoadModule proxy_ajp_module modules/mod_proxy_ajp.so

            LoadModule proxy_http_module modules/mod_proxy_http.so

             

            LoadModule proxy_cluster_module modules/mod_proxy_cluster.so

             

            LoadModule manager_module modules/mod_manager.so

            LoadModule slotmem_module modules/mod_slotmem.so

            LoadModule advertise_module modules/mod_advertise.so

             

            # MOD_CLUSTER_ADDS

            # Adjust to you hostname and subnet.

            <IfModule manager_module>

              Listen 129.204.171.90:8888

              ManagerBalancerName other-server-group

              <VirtualHost 129.204.171.90:8888>

                <Location />

                 Order deny,allow

                 Deny from all

                 Allow from all

                </Location>

             

                KeepAliveTimeout 300

                MaxKeepAliveRequests 0

                Serveradvertise On

                #ServerAdvertise on http://129.204.171.90:6666

                AdvertiseFrequency 5

                #AdvertiseSecurityKey secret

                #AdvertiseGroup 224.0.1.105:23364

             

               

                <Location /mod_cluster_manager>

                   SetHandler mod_cluster-manager

                   Order deny,allow

                   Deny from all

                   Allow from 129.204.171

                </Location>

             

              </VirtualHost>

            </IfModule>

             

            So not sure why things aren't forwarding.

             

            Thanks

            • 3. Re: mod_cluster not seeing jboss cluster or not forwarding request.
              Michal Karm Babacek Apprentice

              Hi Michael, things would have been easier if we knew the version of mod_cluster you are working with...

              For instance, if it is anything above the very ancient 1.1.3, you will need to have EnableMCPMReceive in your VirtualHost in order to allow worker nodes to connect to your balancer.

              • 4. Re: mod_cluster not seeing jboss cluster or not forwarding request.
                Michael G Novice

                You are right, i should include the version and unfortunately it is 1.1.3. 

                 

                The issue is resolved and it happened to be the listen port, i thought we were still using 80 but instead it was 8000. 

                 

                So after fixing the allows things are working.  Will upgrade to 1.2.x soon.

                 

                Thanks