8 Replies Latest reply on Jan 9, 2013 9:08 AM by Vivek Mittal

    issue while deploying/enabling an EAR file

    Vivek Mittal Newbie

      Hi,

       

      When I try and enable the deployed EAR file in Jboss AS 7.1.1 final, I get the following stack trace and the deployment fails:

       

      17:15:49,917 INFO  [org.jboss.as.repository] (HttpManagementService-threads - 5) JBAS014900: Content added at location C:\Users\invmittal\Downloads\jboss-as-7.1.1.Final\jboss-as-7.1.1.Final\standalone\data\content\0f\892463010784f96eab69b437c05f7fae24875b\content
      17:16:59,901 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-7) JBAS015876: Starting deployment of "Test.ear"
      17:17:00,101 WARN  [org.jboss.metadata.parser.jboss.JBossAppMetaDataParser] (MSC service thread 1-2) loader-repository element in jboss-app.xml is deprecated and has been ignored
      17:17:22,671 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-2) Class Path entry ../lib/xerces.jar in "/C:/Users/invmittal/Downloads/jboss-as-7.1.1.Final/jboss-as-7.1.1.Final/bin/content/Test.ear/jdom.jar"  does not point to a valid jar for a Class-Path reference.
      17:17:22,674 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-2) Class Path entry xerces.jar in "/C:/Users/invmittal/Downloads/jboss-as-7.1.1.Final/jboss-as-7.1.1.Final/bin/content/Test.ear/jdom.jar"  does not point to a valid jar for a Class-Path reference.
      17:17:23,243 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-2) Class Path entry ../lib/xerces.jar in "/C:/Users/invmittal/Downloads/jboss-as-7.1.1.Final/jboss-as-7.1.1.Final/bin/content/Test.ear/jdom.jar"  does not point to a valid jar for a Class-Path reference.
      17:17:23,253 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-2) Class Path entry xerces.jar in "/C:/Users/invmittal/Downloads/jboss-as-7.1.1.Final/jboss-as-7.1.1.Final/bin/content/Test.ear/jdom.jar"  does not point to a valid jar for a Class-Path reference.
      17:17:23,323 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015876: Starting deployment of "TestAdminWeb.war"
      17:17:23,332 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "TestEntityEJB.jar"
      17:17:23,324 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-3) JBAS015876: Starting deployment of "TestSessionEJB.jar"
      17:17:23,332 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) JBAS015876: Starting deployment of "TestWebServiceWeb.war"
      17:17:23,331 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015876: Starting deployment of "TestWeb.war"
      17:18:01,790 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC00001: Failed to start service jboss.deployment.subunit."Test.ear"."TestWebServiceWeb.war".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.subunit."Test.ear"."TestWebServiceWeb.war".PARSE: Failed to process phase PARSE of subdeployment "TestWebServiceWeb.war" of deployment "Test.ear"
              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:119) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_31]
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_31]
              at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_31]
      Caused by: javax.xml.ws.WebServiceException: Failed to unmarshall:vfs:/C:/Users/invmittal/Downloads/jboss-as-7.1.1.Final/jboss-as-7.1.1.Final/bin/content/Test.ear/TestWebServiceWeb.war/WEB-INF/webservices.xml
              at org.jboss.wsf.spi.metadata.webservices.WebservicesFactory.load(WebservicesFactory.java:143)
              at org.jboss.wsf.spi.metadata.webservices.WebservicesFactory.loadFromVFSRoot(WebservicesFactory.java:126)
              at org.jboss.as.webservices.deployers.WebservicesDescriptorDeploymentProcessor.deploy(WebservicesDescriptorDeploymentProcessor.java:48)
              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
              ... 5 more
      Caused by: org.codehaus.stax2.typed.TypedXMLStreamException: ParseError at [row,col]:[11,5]
      Message: Element content can not contain child START_ELEMENT when using Typed Access methods
              at com.ctc.wstx.sr.BasicStreamReader._constructTypeException(BasicStreamReader.java:5482)
              at com.ctc.wstx.sr.BasicStreamReader._constructUnexpectedInTyped(BasicStreamReader.java:5475)
              at com.ctc.wstx.sr.BasicStreamReader.getElementText(BasicStreamReader.java:696)
              at org.jboss.wsf.spi.util.StAXUtils.elementAsString(StAXUtils.java:135)
              at org.jboss.wsf.spi.util.StAXUtils.elementAsQName(StAXUtils.java:141)
              at org.jboss.wsf.spi.metadata.webservices.WebservicesFactory.parsePortComponent(WebservicesFactory.java:328)
              at org.jboss.wsf.spi.metadata.webservices.WebservicesFactory.parseWebserviceDescription(WebservicesFactory.java:282)
              at org.jboss.wsf.spi.metadata.webservices.WebservicesFactory.parseWebservices(WebservicesFactory.java:233)
              at org.jboss.wsf.spi.metadata.webservices.WebservicesFactory.parse(WebservicesFactory.java:203)
              at org.jboss.wsf.spi.metadata.webservices.WebservicesFactory.load(WebservicesFactory.java:139)
              ... 8 more

      17:18:02,037 INFO  [org.jboss.as.server] (HttpManagementService-threads - 5) JBAS015870: Deploy of deployment "Test.ear" was rolled back with failure message {"JBAS014671: Failed services" => {"jboss.deployment.subunit.\"Test.ear\".\"TestWebServiceWeb.war\".PARSE" => "org.jboss.msc.service.StartException in service jboss.deployment.subunit.\"Test.ear\".\"TestWebServiceWeb.war\".PARSE: Failed to process phase PARSE of subdeployment \"TestWebServiceWeb.war\" of deployment \"Test.ear\""}}
      17:18:02,055 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-7) JBAS015877: Stopped deployment TestEntityEJB.jar in 18ms
      17:18:02,062 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-6) JBAS015877: Stopped deployment TestSessionEJB.jar in 24ms
      17:18:02,388 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015877: Stopped deployment TestAdminWeb.war in 351ms
      17:18:11,338 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-3) JBAS015877: Stopped deployment TestWeb.war in 9300ms
      17:18:20,196 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) JBAS015877: Stopped deployment TestWebServiceWeb.war in 18159ms
      17:18:21,611 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-6) JBAS015877: Stopped deployment Test.ear in 19574ms
      17:18:21,613 INFO  [org.jboss.as.controller] (HttpManagementService-threads - 5) JBAS014774: Service status report
      JBAS014777:   Services which failed to start:      service jboss.deployment.subunit."Test.ear"."TestWebServiceWeb.war".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.subunit."Test.ear"."TestWebServiceWeb.war".PARSE: Failed to process phase PARSE of subdeployment "TestWebServiceWeb.war" of deployment "Test.ear"

       

      Can someone please guide me what is happening in here?

       

      Thanks

      Vivek

        • 1. Re: issue while deploying/enabling an EAR file
          Nicklas Karlsson Master

          Something with

           

          Caused by: javax.xml.ws.WebServiceException: Failed to unmarshall:vfs:/C:/Users/invmittal/Downloads/jboss-as-7.1.1.Final/jboss-as-7.1.1.Final/bin/content/Test.ear/TestWebServiceWeb.war/WEB-INF/webservices.xml

          Caused by: org.codehaus.stax2.typed.TypedXMLStreamException: ParseError at [row,col]:[11,5]

          Message: Element content can not contain child START_ELEMENT when using Typed Access methods

           

           

          What happens at that row/col?

          • 2. Re: issue while deploying/enabling an EAR file
            Vivek Mittal Newbie

            Hi Nicklas,

             

            Thanks for the reply.

             

            In webservices.xml at line number 11 there is an entry for <namespaceURI>

             

            is there some different structure that I shall follow in the webservices.xml?

             

            Thanks

            Vivek

            • 3. Re: issue while deploying/enabling an EAR file
              Vivek Mittal Newbie

              Hi Nicklas,

               

              Can you provide me some input so I can look into that direction asto what I am doing wrong?

               

              Thanks

              Vivek

              • 4. Re: issue while deploying/enabling an EAR file
                Vivek Mittal Newbie

                This is the structure of webservice.xml that I am using:

                 

                <webservice-description>
                  <webservice-description-name>TestService</webservice-description-name>
                  <wsdl-file>WEB-INF/wsdllocation/TestService.wsdl</wsdl-file>
                  <jaxrpc-mapping-file>WEB-INF/TestService_mapping.xml</jaxrpc-mapping-file>
                  <port-component>
                   <port-component-name>TestService</port-component-name>
                   <wsdl-port>
                    <namespaceURI>http://TestService.webservices.testService.ws</namespaceURI>
                    <localpart>TestService</localpart>
                   </wsdl-port>
                   <service-endpoint-interface>ws.testService.webservices.testService</service-endpoint-interface>
                   <service-impl-bean>
                    <servlet-link>
                    ws_testService_webservices_testServiceImpl</servlet-link>
                   </service-impl-bean>
                  </port-component>
                </webservice-description>

                 

                 

                do I need to follow a different structure in here?

                 

                Thanks

                Vivek

                • 5. Re: issue while deploying/enabling an EAR file
                  Nicklas Karlsson Master

                  Are you using an exploded ear, exploded war combination or exploded ear, zipped war combination?

                  • 6. Re: issue while deploying/enabling an EAR file
                    Vivek Mittal Newbie

                    I am using an EAR file

                    but I am editing this EAR file on fly using 7-zip manager.

                     

                    Shall I try using the same by creating a new EAR file?

                     

                    Also can you please validate if the structure of webservices.xml?

                     

                    Thanks

                    Vivek

                    • 8. Re: issue while deploying/enabling an EAR file
                      Vivek Mittal Newbie

                      I am still facing issues deploying my EAR file even after changing the version of jboss to jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT:

                       

                      ERROR [org.jboss.msc.service.fail] (MSC service thread 1-8) MSC00001: Failed to start service jboss.deployment.subunit."Test.ear"."TestWebServiceWeb.war".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.subunit."Test.ear"."TestWebServiceWeb.war".PARSE: JBAS018733: Failed to process phase PARSE of subdeployment "TestWebServiceWeb.war" of deployment "Test.ear"
                      at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:127) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                      at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.3.GA.jar:1.0.3.GA]
                      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.3.GA.jar:1.0.3.GA]
                      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_31]
                      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_31]
                      at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_31]
                      Caused by: java.lang.NullPointerException
                      at org.jboss.as.webservices.util.ASHelper.getEndpointClassName(ASHelper.java:129)
                      at org.jboss.as.webservices.deployers.WSIntegrationProcessorJAXRPC_POJO.newPojoEndpoint(WSIntegrationProcessorJAXRPC_POJO.java:84)
                      at org.jboss.as.webservices.deployers.WSIntegrationProcessorJAXRPC_POJO.createJaxrpcDeployment(WSIntegrationProcessorJAXRPC_POJO.java:75)
                      at org.jboss.as.webservices.deployers.WSIntegrationProcessorJAXRPC_POJO.deploy(WSIntegrationProcessorJAXRPC_POJO.java:57)
                      at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:120) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                      ... 5 more

                       

                      but this time it throws some null pointer exception.

                       

                      Any pointers will be helpful.

                       

                      Thanks

                      Vivek