0 Replies Latest reply on Jan 21, 2013 2:33 PM by Tiago Frazão

    XA datasource is not been binding

    Tiago Frazão Newbie

      Hi guys,

       

      Please, I need a help !

       

      I was trying to use the Jboss 7.1.3.Final, but because this ISSUE (https://issues.jboss.org/browse/AS7-5761), i was forced to upgrade my current version to "trunk" one (7.2.0.Alpha1 - 19.01.2013).

      Unfortunately this new version (7.2.0.Alpha1) apparently seems to have a bug to bind a XA datasource defined in domain.xml. Yes! I am configuring a clustered environment.

      During the deployment fase, i am getting the followed exception:

       

      === [ console error ] ====================-=
      [Server:master-server-one] 20:28:09,627 ERROR [org.jboss.as.server] (host-controller-connection-threads - 1) JBAS015870: Deploy of deployment "xxxxx.ear" was rolled back with the following failure message:
      [Server:master-server-one] {"JBAS014771: Services with missing/unavailable dependencies" => [
      [Server:master-server-one]     "jboss.deployment.subunit.\"xxxxx.ear\".\"xxxxx.jar\".component.ReportCalendar.jdbc.store-manager.INIT is missing [jboss.data-source.java:jboss/datasources/XaDS]",
      [Server:master-server-one]     "jboss.deployment.subunit.\"xxxxx.ear\".\"xxxxx.jar\".component.ExternalDocument.jdbc.store-manager.INIT is missing [jboss.data-source.java:jboss/datasources/XaDS]",
      .....
      =================================

       

       

      My domain.xml entry looks like :

       

      === [ domain.xml ] ====================-=

      <subsystem xmlns="urn:jboss:domain:datasources:1.1">
      <datasources>
      <xa-datasource jta="true" jndi-name="java:jboss/datasources/XaDS" pool-name="XaDS" enabled="true" use-java-context="true" use-ccm="true">
      <xa-datasource-property name="URL">
      jdbc:oracle:thin:@localhost:1523:database
      </xa-datasource-property>
      <driver>oracle6</driver>
      <transaction-isolation>TRANSACTION_READ_COMMITTED</transaction-isolation>
      <xa-pool>
      <min-pool-size>0</min-pool-size>
      <max-pool-size>80</max-pool-size>
      <no-tx-separate-pools>true</no-tx-separate-pools>
      </xa-pool>
      <security>
      <user-name>appuser</user-name>
      <password>apppassword</password>
      </security>
      <validation>
      <validate-on-match>false</validate-on-match>
      <background-validation>false</background-validation>
      </validation>
      <timeout>
      <idle-timeout-minutes>35</idle-timeout-minutes>
      </timeout>
      </xa-datasource>
      ...
      </datasources>
      ...
      </subsystem>

      =================================

       

      Thanks