0 Replies Latest reply on Feb 12, 2013 1:22 AM by Manish Devraj

    Jboss AS 7.1.1-Final Remote JMX call fails with status “WAITING”

    Manish Devraj Newbie

      I am trying to connect to remote Jboss 7.1.1-Final from Visual VM over JMX protocol supported as "remoting-jmx". Jboss is running in standalone mode with port 9999 opened for remote access. I can perform telnet to confirm the access. URL looks something like below.

       

       

      managementuser@service:jmx:remoting-jmx://x.x.x.x:9999

       

       

      When I am trying to connect to server remotely it hit into following error.

       

       

          INFO [com.sun.tools.visualvm.jmx.impl.JmxModelImpl]: connect(service:jmx:remoting-jmx://x.x.x.x:9999)

          java.lang.RuntimeException: Operation failed with status WAITING

                    at org.jboss.remotingjmx.RemotingConnector.connect(RemotingConnector.java:172)

                    at com.sun.tools.visualvm.jmx.impl.JmxModelImpl$ProxyClient.tryConnect(JmxModelImpl.java:491)

          [catch] at com.sun.tools.visualvm.jmx.impl.JmxModelImpl$ProxyClient.connect(JmxModelImpl.java:440)

                    at com.sun.tools.visualvm.jmx.impl.JmxModelImpl.connect(JmxModelImpl.java:220)

                    at com.sun.tools.visualvm.jmx.impl.JmxModelImpl.<init>(JmxModelImpl.java:209)

                    at com.sun.tools.visualvm.jmx.impl.JmxModelProvider.createModelFor(JmxModelProvider.java:61)

                    at com.sun.tools.visualvm.jmx.impl.JmxModelProvider.createModelFor(JmxModelProvider.java:42)

                    at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111)

                    at com.sun.tools.visualvm.tools.jmx.JmxModelFactory.getJmxModelFor(JmxModelFactory.java:69)

                    at com.sun.tools.visualvm.jmx.impl.JmxApplicationProvider.addJmxApplication(JmxApplicationProvider.java:279)

                    at com.sun.tools.visualvm.jmx.impl.JmxApplicationProvider.createJmxApplication(JmxApplicationProvider.java:183)

                    at com.sun.tools.visualvm.jmx.JmxApplicationsSupport.createJmxApplicationImpl(JmxApplicationsSupport.java:293)

                    at com.sun.tools.visualvm.jmx.JmxApplicationsSupport.createJmxApplicationInteractive(JmxApplicationsSupport.java:270)

                    at com.sun.tools.visualvm.jmx.impl.AddJMXConnectionAction$1.run(AddJMXConnectionAction.java:80)

                    at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452)

                    at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032)

       

      I have deployed Jboss 7.1.1-final servers on CentOS and Windows 7. Same visual VM is able to connect to server running on Windows 7 but gives problem for server running on CentOS. Java version is Open JDK 1.6.0_24 on both servers.

       

      Any thoughts what might be an issue?