6 Replies Latest reply on Mar 1, 2013 5:29 AM by Juraj Húska

    RichFaces 4.2.3 Final Displaying Empty screen.No error in ecllipse console

    Siva P Master

      Hi,

       

      I have just setup the Richfaces4.2.3 Final for my project in Ecllipse Juno.After setting up every thing itried to run it it showing empty screen.

      Please see the below mail for my jar file added.

       

      EmptyScreen.jpg

       

      web.xml:

       

      <?xml version="1.0" encoding="UTF-8"?>

      <web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://java.sun.com/xml/ns/javaee" xmlns:web="http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd" xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd" id="WebApp_ID" version="2.5">

        <display-name>ReadEmployeeData</display-name>

        <welcome-file-list>

          <welcome-file>index.html</welcome-file>

          <welcome-file>index.htm</welcome-file>

          <welcome-file>index.jsp</welcome-file>

          <welcome-file>default.html</welcome-file>

          <welcome-file>default.htm</welcome-file>

          <welcome-file>default.jsp</welcome-file>

        </welcome-file-list>

        <!-- Richfaces set up starts here -->

       

        <display-name>richfaces-showcase</display-name>

       

           <context-param>

              <param-name>javax.faces.DISABLE_FACELET_JSF_VIEWHANDLER</param-name>

              <param-value>true</param-value>

          </context-param>

       

          <context-param>

            <param-name>org.richfaces.enableControlSkinning</param-name>

            <param-value>true</param-value>

          </context-param>

          <context-param>

            <param-name>org.richfaces.enableControlSkinningClasses</param-name>

            <param-value>false</param-value>

          </context-param>

          <context-param>

            <param-name>org.richfaces.skin</param-name>

            <param-value>#{skinBean.skin}</param-value>

          </context-param>

          <context-param>

            <param-name>javax.faces.PROJECT_STAGE</param-name>

            <param-value>Development</param-value>

          </context-param>

          <context-param>

            <param-name>javax.faces.STATE_SAVING_METHOD</param-name>

            <param-value>server</param-value>

          </context-param>

         

         

       

        <!-- Richfaces ends here -->

       

       

       

        <servlet>

          <servlet-name>Faces Servlet</servlet-name>

          <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>

          <load-on-startup>1</load-on-startup>

        </servlet>

        <servlet-mapping>

          <servlet-name>Faces Servlet</servlet-name>

          <url-pattern>*.jsf</url-pattern>

        </servlet-mapping>

        <context-param>

          <param-name>javax.servlet.jsp.jstl.fmt.localizationContext</param-name>

          <param-value>resources.application</param-value>

        </context-param>

        <context-param>

          <description>State saving method: 'client' or 'server' (=default). See JSF Specification 2.5.2</description>

          <param-name>javax.faces.STATE_SAVING_METHOD</param-name>

          <param-value>client</param-value>

        </context-param>

        <context-param>

          <description>

          This parameter tells MyFaces if javascript code should be allowed in

          the rendered HTML output.

          If javascript is allowed, command_link anchors will have javascript code

          that submits the corresponding form.

          If javascript is not allowed, the state saving info and nested parameters

          will be added as url parameters.

          Default is 'true'</description>

          <param-name>org.apache.myfaces.ALLOW_JAVASCRIPT</param-name>

          <param-value>true</param-value>

        </context-param>

        <context-param>

          <description>

          If true, rendered HTML code will be formatted, so that it is 'human-readable'

          i.e. additional line separators and whitespace will be written, that do not

          influence the HTML code.

          Default is 'true'</description>

          <param-name>org.apache.myfaces.PRETTY_HTML</param-name>

          <param-value>true</param-value>

        </context-param>

        <context-param>

          <param-name>org.apache.myfaces.DETECT_JAVASCRIPT</param-name>

          <param-value>false</param-value>

        </context-param>

        <context-param>

          <description>

          If true, a javascript function will be rendered that is able to restore the

          former vertical scroll on every request. Convenient feature if you have pages

          with long lists and you do not want the browser page to always jump to the top

          if you trigger a link or button action that stays on the same page.

          Default is 'false'

      </description>

          <param-name>org.apache.myfaces.AUTO_SCROLL</param-name>

          <param-value>true</param-value>

        </context-param>

        <listener>

          <listener-class>org.apache.myfaces.webapp.StartupServletContextListener</listener-class>

        </listener>

      </web-app>

       

      How can i run the sample application.......

       

      Thanks,

      Siva