1 Reply Latest reply on Mar 28, 2013 5:51 AM by Alessio Soldano

    StackOverflow error with WSDL11Reader when trying to instantiate client service

    Jessica Lundberg Newbie

      Hello!

       

      I've got a frontend client setup with Apache CXF 2.7 and I'm running JBoss 4.3 EAP (I know.. ancient). At first I was generating with my WSDL hard coded, with the following:

       

                                    <wsdlOptions>

                                      <wsdlOption>

                                          <wsdl>${basedir}/src/main/resources/myWSDL.wsdl</wsdl>

                                          <extraargs>

                                              <extraarg>-p</extraarg>

                                              <extraarg>http://webservice/address=com.softwarepoint.thisproject.generated</extraarg>

                                              <extraarg>-verbose</extraarg>

                                          </extraargs>

                                      </wsdlOption>

                                  </wsdlOptions>

       

      But this didn't work for deployment at our customer so I switched to the following:

       

                                    <wsdlOptions>

                                      <wsdlOption>

                                          <wsdl>${basedir}/src/main/resources/myWSDL.wsdl</wsdl>

                                          <wsdlLocation>classpath:myWSDL.wsdl</wsdlLocation>

                                          <extraargs>

                                              <extraarg>-p</extraarg>

                                              <extraarg>http://webservice/address=com.softwarepoint.thisproject.generated</extraarg>

                                              <extraarg>-verbose</extraarg>

                                          </extraargs>

                                      </wsdlOption>

                                  </wsdlOptions>

       

       

      which is supposed to look on the classpath instead.

       

       

      Now when I run this though I am getting the following:

       

      Jbosserror.PNG

       

       

      The system worked locally when the wsdl was hard coded: I came as far as to get an Unknown Host Exception (I can't access the web service locally). But now after generating the code to point to the wsdl on the classpath, I get this.

       

      Any help would be great Let me know if I need to provide more information!