3 Replies Latest reply on Apr 23, 2013 8:42 AM by Van Halbert

    JBAS014884: No operation named 'composite' exists at address

    Van Halbert Master

      I'm using EAP 6.1 ER5, and trying to execute the following using CLI:

       

      /profile=ha/subsystem=security/security-domain=teiid-security:add(cache-type=default)

      /profile=ha/subsystem=security/security-domain=teiid-security/authentication=classic/:add(login-modules=[{"code"=>"org.jboss.security.auth.spi.UsersRolesLoginModule", "flag"=>"required", "module-options"=>[("usersProperties"=>"${jboss.domain.config.dir}/teiid-security-users.properties"), ("rolesProperties"=>"${jboss.domain.config.dir}/teiid-security-roles.properties")]}])

       

      but I get the following:

       

      {

          "outcome" => "failed",

          "result" => undefined,

          "failure-description" => "JBAS010839: Operation failed or was rolled back on all servers.",

          "rolled-back" => true,

          "server-groups" => {"main-server-group" => {"host" => {"master" => {

              "server-one" => {"response" => {

                  "outcome" => "failed",

                  "failure-description" => "JBAS014884: No operation named 'composite' exists at address [

          (\"subsystem\" => \"security\"),

          (\"security-domain\" => \"teiid-security\"),

          (\"authentication\" => \"classic\")

      ]",

                  "rolled-back" => true,

                  "response-headers" => {"process-state" => "restart-required"}

              }},

              "server-two" => {"response" => {

                  "outcome" => "failed",

                  "failure-description" => "JBAS014884: No operation named 'composite' exists at address [

          (\"subsystem\" => \"security\"),

          (\"security-domain\" => \"teiid-security\"),

          (\"authentication\" => \"classic\")

      ]",

                  "rolled-back" => true,

                  "response-headers" => {"process-state" => "restart-required"}

              }}

          }}}}

      }

       

      Any thoughts?

       

      Van

        • 1. Re: JBAS014884: No operation named 'composite' exists at address
          Tomaz Cerar Master

          This looks like a bug.

           

          And it looks like it is related only to domain mode operation, as i know this works in standalone.

           

          can you file jira in https://issues.jboss.org/browse/JBEAP

           

          Other option for you is to use new format for adding domain, something between lines:

           

          /profile=ha/subsystem=security/security-domain=teiid-security:add(cache-type=default)

          /profile=ha/subsystem=security/security-domain=teiid-security/authentication=classic:add

          /profile=ha/subsystem=security/security-domain=teiid-security/authentication=classic/login-module=UsersRolesLoginModule:add(code=org.jboss.security.auth.spi.UsersRolesLoginModule, flag=required, module-options=[("usersProperties"=>"${jboss.domain.config.dir}/teiid-security-users.properties"),  ("rolesProperties"=>"${jboss.domain.config.dir}/teiid-security-roles.properties")])

           

          (there might be mistake somewhere just typed this from my memmory)

           

          --

          tomaz

          • 2. Re: JBAS014884: No operation named 'composite' exists at address
            jaikiran pai Master

            By the way, I haven't checked it, but is the CLI tolerant with syntax like:

             

            /profile=ha/subsystem=security/security-domain=teiid-security/authentication=classic/:add

             

            instead of

             

            /profile=ha/subsystem=security/security-domain=teiid-security/authentication=classic:add

            • 3. Re: JBAS014884: No operation named 'composite' exists at address
              Van Halbert Master

              That worked.  By splitting the line for adding authentication, into 2 steps, I no longer see the issue.

               

              As for the CLI syntax, I had originally tried without the addition '/', just so happens what i pasted here was my last failed attempt.

               

              As for the jira, I'll go ahead an file it, as I suspect, the 1 liner should work.

               

              Thanks for responding so quickly.

               

              Van