1 Reply Latest reply on Sep 12, 2013 7:22 AM by Pradeepa A

    Maven Build Faild

    Pradeepa A Newbie

      Hi all,

      I am a newbie to Jboss..I have installed JBoss EAP 6.1 , its repository and the quickstarts and followed the readme file in the quickstart.. When i tried to build the " HelloWorld " from the quickstart, it got failed and 'm not able to understand the error.. I will be happy if anyone Help me on this..

       

      D:\Jboss 6.1\jboss-eap-6.1.0.GA-quickstarts\helloworld>mvn clean package

      [INFO] Scanning for projects...

      Downloading: http://repository.jboss.org/nexus/content/groups/public/org/jboss/s

      pec/jboss-javaee-6.0/3.0.2.Final-redhat-3/jboss-javaee-6.0-3.0.2.Final-redhat-3.

      pom

      Downloading: file:///D:/jboss 6.1/jboss-eap-6.1.0.GA-maven-repository/org/jboss/

      spec/jboss-javaee-6.0/3.0.2.Final-redhat-3/jboss-javaee-6.0-3.0.2.Final-redhat-3

      .pom

      Downloaded: file:///D:/jboss 6.1/jboss-eap-6.1.0.GA-maven-repository/org/jboss/s

      pec/jboss-javaee-6.0/3.0.2.Final-redhat-3/jboss-javaee-6.0-3.0.2.Final-redhat-3.

      pom (18 KB at 244.3 KB/sec)

      Downloading: http://repository.jboss.org/nexus/content/groups/public/org/jboss/j

      boss-parent/10-redhat-2/jboss-parent-10-redhat-2.pom

      Downloading: file:///D:/jboss 6.1/jboss-eap-6.1.0.GA-maven-repository/org/jboss/

      jboss-parent/10-redhat-2/jboss-parent-10-redhat-2.pom

      Downloaded: file:///D:/jboss 6.1/jboss-eap-6.1.0.GA-maven-repository/org/jboss/j

      boss-parent/10-redhat-2/jboss-parent-10-redhat-2.pom (41 KB at 682.0 KB/sec)

      Downloading: http://repository.jboss.org/nexus/content/groups/public/org/jboss/c

      omponent/management/jboss-component-version-master/6.1.0-redhat-2/jboss-componen

      t-version-master-6.1.0-redhat-2.pom

      Downloading: file:///D:/jboss 6.1/jboss-eap-6.1.0.GA-maven-repository/org/jboss/

      component/management/jboss-component-version-master/6.1.0-redhat-2/jboss-compone

      nt-version-master-6.1.0-redhat-2.pom

      Downloaded: file:///D:/jboss 6.1/jboss-eap-6.1.0.GA-maven-repository/org/jboss/c

      omponent/management/jboss-component-version-master/6.1.0-redhat-2/jboss-componen

      t-version-master-6.1.0-redhat-2.pom (28 KB at 548.6 KB/sec)

      [INFO]

      [INFO] ------------------------------------------------------------------------

      [INFO] Building JBoss AS Quickstarts: Helloworld 7.1.2-SNAPSHOT

      [INFO] ------------------------------------------------------------------------

      Downloading: http://repository.jboss.org/nexus/content/groups/public/org/apache/

      maven/plugins/maven-clean-plugin/2.5/maven-clean-plugin-2.5.pom

      Downloading: file:///D:/jboss 6.1/jboss-eap-6.1.0.GA-maven-repository/org/apache

      /maven/plugins/maven-clean-plugin/2.5/maven-clean-plugin-2.5.pom

      Downloading: http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-

      clean-plugin/2.5/maven-clean-plugin-2.5.pom

      [INFO] ------------------------------------------------------------------------

      [INFO] BUILD FAILURE

      [INFO] ------------------------------------------------------------------------

      [INFO] Total time: 7.560s

      [INFO] Finished at: Thu Sep 12 15:28:52 IST 2013

      [INFO] Final Memory: 4M/15M

      [INFO] ------------------------------------------------------------------------

      [ERROR] Plugin org.apache.maven.plugins:maven-clean-plugin:2.5 or one of its dep

      endencies could not be resolved: Failed to read artifact descriptor for org.apac

      he.maven.plugins:maven-clean-plugin:jar:2.5: Could not transfer artifact org.apa

      che.maven.plugins:maven-clean-plugin:pom:2.5 from/to jboss-community-plugin-repo

      sitory (http://repository.jboss.org/nexus/content/groups/public/): Connection to

      http://repository.jboss.org refused: Connection refused: connect -> [Help 1]

      [ERROR]

      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e swit

      ch.

      [ERROR] Re-run Maven using the -X switch to enable full debug logging.

      [ERROR]

      [ERROR] For more information about the errors and possible solutions, please rea

      d the following articles:

      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResoluti

      onException

        • 1. Re: Maven Build Faild
          Pradeepa A Newbie

          now working ...just added the below statement

           

          <proxies>

             <proxy>

                <active>true</active>

                <protocol>http</protocol>

                <host>NEED TO ADD OUR PROXY eg: proxy.abc.com</host>---- plz check out thz line need to set ur own proxy

                <port>OUR PORT NUMBER eg: 6777</port>plz check out thz line need to set ur own port number

               

              </proxy>

            </proxies>