4 Replies Latest reply on Oct 16, 2013 5:33 PM by Michael Hirsch

    Errai 2.4.0.Final jar dependecies documentation

    Hristo Stoyanov Master

      Hello everyone,

      Can someone point me to Erari documentation (I could not find this information in the latest Errai on-line docs), which clearly explains:

      a/ which JARS are needed at Java compile time for Errai

      b/ which JARs are needed at GWT compile time for Errai

      c/ which JARs are needed at run-time in the server (to be bundled in the WEB-INF/lib) for Errai

       

      I would like to keep my  Errai WAR as clean as possible, so c/ is the most important one for me.

       

      I do not use Maven (an do not want to use Maven, because I use Gradle). I just need a clean list of jars for a/ , b/ and c/ above and some explanation around them.

       

      Here is the very scary dependency graph reported off the root artifact: org.jboss.errai:errai-javaee-all:2.4.0.Final. I do not think I need all these jars at run-time and packaged in my WAR file.

       

      +--- org.jboss.errai:errai-javaee-all:2.4.0.Final

      |    +--- com.google.gwt:gwt-user:2.5.1

      |    |    +--- javax.validation:validation-api:1.0.0.GA

      |    |    \--- org.json:json:20090211

      |    +--- org.jboss.errai:errai-bus:2.4.0.Final

      |    |    +--- org.jboss.errai:errai-common:2.4.0.Final

      |    |    |    \--- org.jboss.errai.reflections:reflections:2.4.0.Final

      |    |    |         +--- com.google.guava:guava:14.0.1 -> 15.0

      |    |    |         +--- org.javassist:javassist:3.15.0-GA

      |    |    |         +--- org.slf4j:slf4j-api:1.6.1

      |    |    |         \--- dom4j:dom4j:1.6.1

      |    |    |              \--- xml-apis:xml-apis:1.0.b2

      |    |    +--- org.jboss.errai:errai-config:2.4.0.Final

      |    |    +--- org.jboss.errai:errai-marshalling:2.4.0.Final

      |    |    |    +--- org.jboss.errai:errai-common:2.4.0.Final (*)

      |    |    |    +--- org.jboss.errai:errai-config:2.4.0.Final

      |    |    |    +--- org.jboss.errai:errai-codegen:2.4.0.Final

      |    |    |    |    +--- org.jboss.errai:errai-common:2.4.0.Final (*)

      |    |    |    |    +--- org.mvel:mvel2:2.1.Beta8

      |    |    |    |    \--- junit:junit:4.10 -> 4.11

      |    |    |    |         \--- org.hamcrest:hamcrest-core:1.3

      |    |    |    +--- org.jboss.errai:errai-codegen-gwt:2.4.0.Final

      |    |    |    +--- javax.inject:javax.inject:1

      |    |    |    +--- javax.annotation:jsr250-api:1.0

      |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4

      |    |    |         +--- org.jboss.spec.javax.interceptor:jboss-interceptors-api_1.1_spec:1.0.0.Beta1

      |    |    |         +--- javax.annotation:jsr250-api:1.0

      |    |    |         \--- javax.inject:javax.inject:1

      |    |    +--- com.google.inject:guice:3.0

      |    |    |    +--- aopalliance:aopalliance:1.0

      |    |    |    \--- org.sonatype.sisu.inject:cglib:2.2.1-v20090111

      |    |    |         \--- asm:asm:3.1

      |    |    +--- javax.inject:javax.inject:1

      |    |    +--- org.mvel:mvel2:2.1.Beta8

      |    |    +--- org.slf4j:slf4j-api:1.6.1

      |    |    +--- junit:junit:4.10 -> 4.11 (*)

      |    |    +--- org.javassist:javassist:3.15.0-GA

      |    |    +--- org.jboss.errai.io.netty:netty:4.0.0.Alpha1.errai.r1

      |    |    +--- com.google.guava:guava:14.0.1 -> 15.0

      |    |    \--- org.jgroups:jgroups:3.2.0.Final

      |    +--- org.jboss.errai:errai-ioc:2.4.0.Final

      |    |    +--- org.jboss.errai:errai-config:2.4.0.Final

      |    |    +--- org.jboss.errai:errai-codegen:2.4.0.Final (*)

      |    |    +--- org.jboss.errai:errai-codegen-gwt:2.4.0.Final

      |    |    +--- com.google.inject:guice:3.0 (*)

      |    |    +--- javax.inject:javax.inject:1

      |    |    +--- org.jboss.errai:errai-javax-enterprise:2.4.0.Final

      |    |    +--- javax.annotation:jsr250-api:1.0

      |    |    \--- javax.enterprise:cdi-api:1.0-SP4 (*)

      |    +--- org.jboss.errai:errai-tools:2.4.0.Final

      |    |    \--- hsqldb:hsqldb:1.8.0.7

      |    +--- org.jboss.errai:errai-cdi-client:2.4.0.Final

      |    |    +--- org.jboss.errai:errai-bus:2.4.0.Final (*)

      |    |    +--- org.jboss.errai:errai-ioc-bus-support:2.4.0.Final

      |    |    |    +--- org.jboss.errai:errai-ioc:2.4.0.Final (*)

      |    |    |    +--- org.jboss.errai:errai-common:2.4.0.Final (*)

      |    |    |    +--- org.jboss.errai:errai-bus:2.4.0.Final (*)

      |    |    |    +--- org.jboss.errai:errai-codegen:2.4.0.Final (*)

      |    |    |    +--- javax.inject:javax.inject:1

      |    |    |    +--- org.jboss.errai:errai-javax-enterprise:2.4.0.Final

      |    |    |    +--- javax.annotation:jsr250-api:1.0

      |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4 (*)

      |    |    \--- org.jboss.errai:errai-ioc:2.4.0.Final (*)

      |    +--- org.jboss.errai:errai-jpa-client:2.4.0.Final

      |    |    +--- org.hibernate:hibernate-entitymanager:4.2.0.Final

      |    |    |    +--- org.jboss.logging:jboss-logging:3.1.0.GA

      |    |    |    +--- org.hibernate:hibernate-core:4.2.0.Final

      |    |    |    |    +--- antlr:antlr:2.7.7

      |    |    |    |    +--- org.jboss.logging:jboss-logging:3.1.0.GA

      |    |    |    |    +--- org.jboss.spec.javax.transaction:jboss-transaction-api_1.1_spec:1.0.0.Final

      |    |    |    |    +--- dom4j:dom4j:1.6.1 (*)

      |    |    |    |    +--- org.hibernate.javax.persistence:hibernate-jpa-2.0-api:1.0.1.Final

      |    |    |    |    +--- org.javassist:javassist:3.15.0-GA

      |    |    |    |    \--- org.hibernate.common:hibernate-commons-annotations:4.0.1.Final

      |    |    |    |         \--- org.jboss.logging:jboss-logging:3.1.0.CR2 -> 3.1.0.GA

      |    |    |    +--- org.jboss.spec.javax.transaction:jboss-transaction-api_1.1_spec:1.0.0.Final

      |    |    |    +--- dom4j:dom4j:1.6.1 (*)

      |    |    |    +--- org.hibernate.javax.persistence:hibernate-jpa-2.0-api:1.0.1.Final

      |    |    |    +--- org.javassist:javassist:3.15.0-GA

      |    |    |    \--- org.hibernate.common:hibernate-commons-annotations:4.0.1.Final (*)

      |    |    +--- org.hibernate.javax.persistence:hibernate-jpa-2.0-api:1.0.1.Final

      |    |    +--- org.jboss.errai:errai-ioc:2.4.0.Final (*)

      |    |    +--- org.jboss.errai:errai-data-binding:2.4.0.Final

      |    |    |    +--- org.jboss.errai:errai-marshalling:2.4.0.Final (*)

      |    |    |    \--- com.google.guava:guava-gwt:14.0.1

      |    |    |         +--- com.google.code.findbugs:jsr305:1.3.9

      |    |    |         \--- com.google.guava:guava:14.0.1 -> 15.0

      |    |    +--- com.google.gwt:gwt-user:2.5.1 (*)

      |    |    \--- com.google.guava:guava-gwt:14.0.1 (*)

      |    +--- org.jboss.errai:errai-jpa-datasync:2.4.0.Final

      |    |    +--- org.jboss.errai:errai-jpa-client:2.4.0.Final (*)

      |    |    +--- org.jboss.errai:errai-bus:2.4.0.Final (*)

      |    |    \--- org.jboss.errai:errai-cdi-client:2.4.0.Final (*)

      |    +--- org.jboss.errai:errai-jaxrs-client:2.4.0.Final

      |    |    +--- org.jboss.errai:errai-marshalling:2.4.0.Final (*)

      |    |    +--- org.jboss.resteasy:jaxrs-api:2.3.6.Final

      |    |    \--- com.google.guava:guava-gwt:14.0.1 (*)

      |    +--- org.jboss.errai:errai-jaxrs-provider:2.4.0.Final

      |    |    +--- org.jboss.resteasy:jaxrs-api:2.3.6.Final

      |    |    \--- org.jboss.errai:errai-marshalling:2.4.0.Final (*)

      |    +--- org.jboss.errai:errai-javax-enterprise:2.4.0.Final

      |    +--- org.jboss.errai:errai-weld-integration:2.4.0.Final

      |    +--- org.jboss.errai:errai-ui:2.4.0.Final

      |    |    +--- org.jboss.errai:errai-cdi-client:2.4.0.Final (*)

      |    |    +--- org.codehaus.jackson:jackson-mapper-asl:1.9.12

      |    |    |    \--- org.codehaus.jackson:jackson-core-asl:1.9.12

      |    |    +--- org.jsoup:jsoup:1.7.1

      |    |    +--- org.apache.stanbol:org.apache.stanbol.enhancer.engines.htmlextractor:0.10.0

      |    |    |    +--- org.apache.clerezza:rdf.core:0.12-incubating

      |    |    |    |    +--- org.osgi:org.osgi.core:4.2.0

      |    |    |    |    +--- org.osgi:org.osgi.compendium:4.2.0

      |    |    |    |    +--- org.apache.clerezza:utils:0.1-incubating

      |    |    |    |    |    +--- commons-codec:commons-codec:1.5

      |    |    |    |    |    +--- org.apache.httpcomponents:httpcore:4.1

      |    |    |    |    |    +--- org.osgi:org.osgi.core:4.2.0

      |    |    |    |    |    +--- org.wymiwyg:wymiwyg-commons-core:0.7.6

      |    |    |    |    |    |    +--- commons-logging:commons-logging-api:1.1

      |    |    |    |    |    |    +--- javax.activation:activation:1.1

      |    |    |    |    |    |    \--- org.slf4j:slf4j-api:1.5.8 -> 1.6.1

      |    |    |    |    |    \--- org.slf4j:slf4j-api:1.6.1

      |    |    |    |    \--- org.slf4j:slf4j-api:1.6.1

      |    |    |    +--- org.slf4j:slf4j-api:1.6.1

      |    |    |    \--- org.jsoup:jsoup:1.7.1

      |    |    \--- org.lesscss:lesscss:1.3.3

      |    |         +--- commons-io:commons-io:2.4

      |    |         +--- commons-logging:commons-logging:1.1.1

      |    |         +--- org.apache.commons:commons-lang3:3.1

      |    |         \--- org.mozilla:rhino:1.7R4

      |    +--- org.jboss.errai:errai-navigation:2.4.0.Final

      |    |    \--- com.google.guava:guava-gwt:14.0.1 (*)

      |    +--- org.jboss.errai:errai-data-binding:2.4.0.Final (*)

      |    +--- org.jboss.errai:errai-marshalling:2.4.0.Final (*)

      |    +--- org.jboss.errai:errai-validation:2.4.0.Final

      |    |    +--- org.jboss.errai:errai-marshalling:2.4.0.Final (*)

      |    |    \--- org.jboss.errai:errai-data-binding:2.4.0.Final (*)

      |    +--- javax.enterprise:cdi-api:1.0-SP4 (*)

      |    +--- javax.validation:validation-api:1.0.0.GA

      |    \--- org.hibernate:hibernate-validator:4.2.0.Final

      |         +--- javax.validation:validation-api:1.0.0.GA

      |         \--- org.slf4j:slf4j-api:1.6.1

        • 1. Re: Errai 2.4.0.Final jar dependecies documentation
          Christian Sadilek Master

          Hi Hristo,

           

          I understand we need to document our dependency graph. In the meantime, it's best to look at the graph of one of our existing demos. Here's the full graph of the Errai tutorial project (https://github.com/errai/errai-tutorial). It's using all Errai modules. The ones marked as "compile" are needed for both compilation and at runtime. The ones marked "provided" do not need to be (and shouldn't be) deployed. Not really less scary but it should get you started if you're not using maven.

           

          org.jboss.errai.demo:errai-tutorial:war:1.0.0-SNAPSHOT

          +- com.google.gwt:gwt-user:jar:2.5.1:provided (scope not updated to compile)

          |  \- org.json:json:jar:20090211:provided

          +- org.jboss.errai:errai-javaee-all:jar:2.4.1-SNAPSHOT:compile

          |  +- org.jboss.errai:errai-bus:jar:2.4.1-SNAPSHOT:compile

          |  |  +- org.jboss.errai:errai-config:jar:2.4.1-SNAPSHOT:compile

          |  |  +- com.google.inject:guice:jar:3.0:compile

          |  |  |  \- aopalliance:aopalliance:jar:1.0:compile

          |  |  +- org.mvel:mvel2:jar:2.1.6.Final:compile

          |  |  +- org.javassist:javassist:jar:3.15.0-GA:compile

          |  |  +- com.google.guava:guava:jar:13.0.1:compile

          |  |  \- org.jgroups:jgroups:jar:3.2.0.Final:compile

          |  +- org.jboss.errai:errai-ioc:jar:2.4.1-SNAPSHOT:compile

          |  |  \- org.jboss.errai:errai-codegen:jar:2.4.1-SNAPSHOT:compile

          |  +- org.jboss.errai:errai-cdi-client:jar:2.4.1-SNAPSHOT:compile

          |  |  \- org.jboss.errai:errai-ioc-bus-support:jar:2.4.1-SNAPSHOT:compile

          |  +- org.jboss.errai:errai-jpa-datasync:jar:2.4.1-SNAPSHOT:compile

          |  +- org.jboss.errai:errai-jaxrs-provider:jar:2.4.1-SNAPSHOT:compile

          |  +- org.jboss.errai:errai-weld-integration:jar:2.4.1-SNAPSHOT:compile

          |  +- org.jboss.errai:errai-ui:jar:2.4.1-SNAPSHOT:compile

          |  |  +- org.codehaus.jackson:jackson-mapper-asl:jar:1.9.12:compile

          |  |  |  \- org.codehaus.jackson:jackson-core-asl:jar:1.9.12:compile

          |  |  +- org.jsoup:jsoup:jar:1.7.1:compile

          |  |  +- org.apache.stanbol:org.apache.stanbol.enhancer.engines.htmlextractor:jar:0.10.0:compile

          |  |  |  \- org.apache.clerezza:rdf.core:jar:0.12-incubating:compile

          |  |  |     +- org.osgi:org.osgi.core:jar:4.2.0:compile

          |  |  |     +- org.osgi:org.osgi.compendium:jar:4.2.0:compile

          |  |  |     \- org.apache.clerezza:utils:jar:0.1-incubating:compile

          |  |  |        +- commons-codec:commons-codec:jar:1.4:compile (version managed from 1.5)

          |  |  |        +- org.apache.httpcomponents:httpcore:jar:4.1:compile

          |  |  |        \- org.wymiwyg:wymiwyg-commons-core:jar:0.7.6:compile

          |  |  |           +- commons-logging:commons-logging-api:jar:1.1:compile

          |  |  |           \- javax.activation:activation:jar:1.1.1:compile (version managed from 1.1)

          |  |  \- org.lesscss:lesscss:jar:1.3.3:compile

          |  |     +- commons-logging:commons-logging:jar:1.1.1:compile

          |  |     +- org.apache.commons:commons-lang3:jar:3.1:compile

          |  |     \- org.mozilla:rhino:jar:1.7R4:compile

          |  +- org.jboss.errai:errai-marshalling:jar:2.4.1-SNAPSHOT:compile

          |  \- org.jboss.errai:errai-validation:jar:2.4.1-SNAPSHOT:compile

          +- org.jboss.errai:errai-cordova:jar:2.4.1-SNAPSHOT:compile

          |  +- org.jboss.errai:errai-html5:jar:2.4.1-SNAPSHOT:compile

          |  |  \- org.jboss.errai.reflections:reflections:jar:2.4.1-SNAPSHOT:compile

          |  \- com.googlecode.gwtphonegap:gwtphonegap:jar:2.4.0.0:compile

          |     \- commons-io:commons-io:jar:2.4:compile

          +- org.jboss.spec:jboss-javaee-6.0:pom:3.0.2.Final:provided

          |  +- javax.jws:jsr181-api:jar:1.0-MR1:provided

          |  +- org.jboss.spec.javax.annotation:jboss-annotations-api_1.1_spec:jar:1.0.1.Final:provided

          |  +- org.jboss.spec.javax.ejb:jboss-ejb-api_3.1_spec:jar:1.0.2.Final:provided

          |  +- org.jboss.spec.javax.el:jboss-el-api_2.2_spec:jar:1.0.2.Final:provided

          |  +- org.jboss.spec.javax.enterprise.deploy:jboss-jad-api_1.2_spec:jar:1.0.1.Final:provided

          |  +- org.jboss.spec.javax.faces:jboss-jsf-api_2.1_spec:jar:2.0.9.Final:provided

          |  +- org.jboss.spec.javax.management.j2ee:jboss-j2eemgmt-api_1.1_spec:jar:1.0.1.Final:provided

          |  +- org.jboss.spec.javax.resource:jboss-connector-api_1.6_spec:jar:1.0.1.Final:provided

          |  +- org.jboss.spec.javax.rmi:jboss-rmi-api_1.0_spec:jar:1.0.4.Final:provided

          |  +- org.jboss.spec.javax.security.jacc:jboss-jacc-api_1.4_spec:jar:1.0.2.Final:provided

          |  +- org.jboss.spec.javax.security.auth.message:jboss-jaspi-api_1.0_spec:jar:1.0.1.Final:provided

          |  +- org.jboss.spec.javax.xml.registry:jboss-jaxr-api_1.0_spec:jar:1.0.2.Final:provided

          |  +- org.jboss.spec.javax.jms:jboss-jms-api_1.1_spec:jar:1.0.1.Final:provided

          |  +- org.jboss.spec.javax.servlet:jboss-servlet-api_3.0_spec:jar:1.0.0.Final:provided

          |  +- org.jboss.spec.javax.servlet.jsp:jboss-jsp-api_2.2_spec:jar:1.0.1.Final:provided

          |  +- org.jboss.spec.javax.servlet.jstl:jboss-jstl-api_1.2_spec:jar:1.0.3.Final:provided

          |  |  \- xalan:xalan:jar:2.7.1.jbossorg-2:provided

          |  |     \- xalan:serializer:jar:2.7.1.jbossorg-2:provided

          |  +- org.jboss.spec.javax.ws.rs:jboss-jaxrs-api_1.1_spec:jar:1.0.1.Final:provided

          |  +- org.jboss.spec.javax.xml.bind:jboss-jaxb-api_2.2_spec:jar:1.0.4.Final:provided

          |  +- org.jboss.spec.javax.xml.rpc:jboss-jaxrpc-api_1.1_spec:jar:1.0.1.Final:provided

          |  +- org.jboss.spec.javax.xml.soap:jboss-saaj-api_1.3_spec:jar:1.0.2.Final:provided

          |  \- org.jboss.spec.javax.xml.ws:jboss-jaxws-api_2.2_spec:jar:2.0.1.Final:provided

          +- org.slf4j:slf4j-log4j12:jar:1.6.1:compile

          |  +- org.slf4j:slf4j-api:jar:1.6.1:compile

          |  \- log4j:log4j:jar:1.2.16:compile

          +- junit:junit:jar:4.8.1:provided (scope not updated to compile)

          +- org.jboss.errai:errai-jboss-as-support:jar:2.4.1-SNAPSHOT:compile

          |  \- org.jboss.errai:errai-common:jar:2.4.1-SNAPSHOT:compile

          +- com.google.guava:guava-gwt:jar:13.0.1:provided (scope not updated to compile)

          +- hsqldb:hsqldb:jar:1.8.0.7:provided (scope not updated to compile)

          +- javax.annotation:jsr250-api:jar:1.0:provided (scope not updated to compile)

          +- javax.enterprise:cdi-api:jar:1.0-SP4:provided (scope not updated to compile)

          +- javax.inject:javax.inject:jar:1:provided (scope not updated to compile)

          +- javax.validation:validation-api:jar:sources:1.0.0.GA:provided (scope not updated to compile)

          +- javax.validation:validation-api:jar:1.0.0.GA:provided (scope not updated to compile)

          +- org.hibernate.common:hibernate-commons-annotations:jar:4.0.1.Final:provided (scope not updated to compile)

          +- org.hibernate.javax.persistence:hibernate-jpa-2.0-api:jar:1.0.1.Final:provided (scope not updated to compile)

          +- org.hibernate:hibernate-core:jar:4.2.0.Final:provided (scope not updated to compile)

          |  \- antlr:antlr:jar:2.7.7:provided

          +- org.hibernate:hibernate-entitymanager:jar:4.2.0.Final:provided (scope not updated to compile)

          |  \- dom4j:dom4j:jar:1.6.1:provided

          +- org.hibernate:hibernate-validator:jar:4.2.0.Final:provided (scope not updated to compile)

          +- org.hibernate:hibernate-validator:jar:sources:4.2.0.Final:provided (scope not updated to compile)

          +- org.jboss.errai:errai-cdi-jetty:jar:2.4.1-SNAPSHOT:provided (scope not updated to compile)

          |  \- org.mortbay.jetty:jetty-plus:jar:6.1.25:provided

          |     \- geronimo-spec:geronimo-spec-jta:jar:1.0.1B-rc4:provided

          +- org.jboss.errai:errai-codegen-gwt:jar:2.4.1-SNAPSHOT:provided (scope not updated to compile)

          +- org.jboss.errai:errai-data-binding:jar:2.4.1-SNAPSHOT:provided (scope not updated to compile)

          +- org.jboss.errai:errai-javax-enterprise:jar:2.4.1-SNAPSHOT:provided (scope not updated to compile)

          +- org.jboss.errai:errai-jaxrs-client:jar:2.4.1-SNAPSHOT:provided (scope not updated to compile)

          +- org.jboss.errai:errai-jpa-client:jar:2.4.1-SNAPSHOT:provided (scope not updated to compile)

          +- org.jboss.errai:errai-navigation:jar:2.4.1-SNAPSHOT:provided (scope not updated to compile)

          +- org.jboss.errai:errai-tools:jar:2.4.1-SNAPSHOT:provided (scope not updated to compile)

          +- org.jboss.logging:jboss-logging:jar:3.1.0.GA:provided

          +- org.jboss.resteasy:jaxrs-api:jar:2.3.6.Final:provided

          +- org.jboss.spec.javax.interceptor:jboss-interceptors-api_1.1_spec:jar:1.0.1.Final:provided

          +- org.jboss.spec.javax.transaction:jboss-transaction-api_1.1_spec:jar:1.0.1.Final:provided

          +- org.jboss.weld.servlet:weld-servlet-core:jar:1.1.5.Final:provided (scope not updated to compile)

          |  \- org.jboss.weld:weld-build-config:jar:1.1.5.Final:provided

          +- org.jboss.weld:weld-core:jar:1.1.5.Final:provided

          |  +- org.jboss.interceptor:jboss-interceptor-spi:jar:2.0.0.CR1:provided

          |  +- org.jboss.interceptor:jboss-interceptor-core:jar:2.0.0.CR1:provided

          |  +- org.slf4j:slf4j-ext:jar:1.6.1:provided

          |  \- ch.qos.cal10n:cal10n-api:jar:0.7.4:provided

          +- org.jboss.weld:weld-api:jar:1.1.Final:provided

          +- org.jboss.weld:weld-spi:jar:1.1.Final:provided

          +- xml-apis:xml-apis:jar:1.4.01:provided (version managed from 1.0.b2)

          +- org.jboss.errai.io.netty:netty:jar:4.0.0.Alpha1.errai.r1:provided (scope not updated to compile)

          \- org.mortbay.jetty:jetty-naming:jar:6.1.25:provided

              \- javax.mail:mail:jar:1.4.4:provided (version managed from 1.4)

           

          Cheers,

          Christian

          • 2. Re: Errai 2.4.0.Final jar dependecies documentation
            Hristo Stoyanov Master

            Thanks Christian,

            One additional issue I find with the dependency tree above is that gwt-user.jar ends up in the final WAR file and it should not. This is due to:

            errai-jpa-datasync --->errai-jpa-client--->gwt-user. Is this a bug?

             

            ...And while waiting for better on-line documentation, here is a snippet of Gradle code Errai users can use for more precise jars dependencies:

            ========================================

            //Project properties

            project.ext {

                erraiVersion = "2.4.1.Final"

            }



            //Java EE

                providedCompile "javax:javaee-api:7.0"

             

            //    THIS IS TOO BROAD! DO NOT USE! compile "org.jboss.errai:errai-javaee-all:"+project.erraiVersion

                compile "org.jboss.errai:errai-bus:"+project.erraiVersion

                compile "org.jboss.errai:errai-ioc:"+project.erraiVersion

                compile "org.jboss.errai:errai-cdi-client:"+project.erraiVersion

                compile "org.jboss.errai:errai-jpa-datasync:"+project.erraiVersion

                compile "org.jboss.errai:errai-jaxrs-provider:"+project.erraiVersion

                compile "org.jboss.errai:errai-javax-enterprise:"+project.erraiVersion

                compile "org.jboss.errai:errai-weld-integration:"+project.erraiVersion

                compile "org.jboss.errai:errai-ui:"+project.erraiVersion

                compile "org.jboss.errai:errai-ui:"+project.erraiVersion

                compile "org.jboss.errai:errai-cordova:"+project.erraiVersion

                compile "org.jboss.errai:errai-marshalling:"+project.erraiVersion

                compile "org.jboss.errai:errai-jboss-as-support:"+project.erraiVersion

            • 3. Re: Errai 2.4.0.Final jar dependecies documentation
              Christian Sadilek Master

              Hi Hristo,

               

              Thanks for sharing. Great you got your build working with Gradle! If you like to share the full build script we could incorporate it into the errai tutorial project:

              https://github.com/errai/errai-tutorial

               

              This will help others to get started with Errai and Gradle. So, if you feel like it, just send us a pull request .

               

              Thanks,

              Christian

              • 4. Re: Errai 2.4.0.Final jar dependecies documentation
                Michael Hirsch Newbie

                We recently switched from ant to gradle for our build.  One big reason that we switched was so we could get the dependency management of gradle which is similar to that of maven or ivy.

                 

                In our ant build we would include each jar file explicitly, but now we only need to include a couple.  I think we should only need to include the one(s) that we pull gwt.xml files from.  But here is what we have:

                 

                ext.gwtVersion = "2.5.1"

                ext.erraiVersion = "2.3.2.Final"

                 

                dependencies {

                    compile "com.google.gwt:gwt-dev:$gwtVersion"

                    compile "com.google.gwt:gwt-user:$gwtVersion"

                 

                    compile "org.jboss.errai:errai-ui:${erraiVersion}"

                    compile "org.jboss.errai:errai-data-binding:${erraiVersion}"

                    compile "org.jboss.errai:errai-data-binding:${erraiVersion}"

                    compile "org.jboss.errai:errai-ioc:${erraiVersion}"

                }

                 

                There is actually a whole lot more in our gradle script, of course, but this pulls in all the errai dependencies for us.

                 

                Michael