4 Replies Latest reply on Feb 4, 2014 9:00 AM by Lokesh Kumar Padhanvis

    Jboss EAP 6.2 Remote EJB lookup from a standalone client

    Lokesh Kumar Padhanvis Newbie

      Hi All,

       

      I have followed these links "EJB invocations from a remote client using JNDI - JBoss AS 7.1 - Project Documentation Editor" and this "jboss-eap-quickstarts/ejb-remote at master · jboss-developer/jboss-eap-quickstarts · GitHub"  to lookup a remote EJB and call some methods on that.

       

      My configuration

      ================================

      standalone-full.xml

       

      <!-- Security realms -->
      <security-realms>
          <security-realm name="ManagementRealm">
             <authentication>
                 <local default-user="$local"/>
                 <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>
             </authentication>
             <authorization map-groups-to-roles="false">
                 <properties path="mgmt-groups.properties" relative-to="jboss.server.config.dir"/>
             </authorization>
          </security-realm>
          <security-realm name="ApplicationRealm">
             <authentication>
                  <local default-user="$local" allowed-users="*"/>
                  <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>
             </authentication>
             <authorization>
                  <properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>
             </authorization>
          </security-realm>
      </security-realms>
      
      <!-- remoting subsystem config -->
      
      <subsystem xmlns="urn:jboss:domain:remoting:1.1">
           <connector name="remoting-connector" socket-binding="remoting" security-realm="ApplicationRealm"/>
      </subsystem>
      
      <!-- Security domain -->
      <security-domain name="customDomain" cache-type="default">
           <authentication>
               <login-module code="com.example.SecurityManagerLoginModule" flag="required">
                   <module-option name="debug" value="true"/>
               </login-module>
            </authentication>
      </security-domain>
      
      

       

       

      jboss-ejb-client.properties

      --------------------------------------------------------------

      remote.connectionprovider.create.options.org.xnio.Options.SSL_ENABLED=false

      remote.connections=default

      remote.connection.default.host=localhost

      remote.connection.default.port = 4447

      remote.connection.default.connect.options.org.xnio.Options.SASL_POLICY_NOANONYMOUS=false

      remote.connection.default.username=username

      remote.connection.default.password=passw0rd

      remote.connection.default.connect.options.org.xnio.Options.SASL_POLICY_NOPLAINTEXT=false

       

      The Problem

      =====================================

       

      The password which I am passing through the above properties file, is a plain text password but at the server end its getting encrypted somehow and the authentication fails.

      I have gone through several threads similar to this issue, and was not able to succesfully login.

       

      Can anyone please help me out?