3 Replies Latest reply on Feb 6, 2014 8:59 AM by Gaspar Kuhnen

    como corrigir esse problema?

    Gaspar Kuhnen Newbie

      JBoss 7.1.1 + Hibernate Deploy Fail

       

      Depois de migrar a persistencia de todo meu projeto do EclipseLink para Hibernate 4.0.1 não consigo fazer o deploy no Jboss AS 7.1.1.Final.

      Após a exportação do schema aparece a mensagem de erro sem nehuma pista mais consistente onde está o problema.

       

      16:57:33,133 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC00001: Failed to start service jboss.persistenceunit."axbi-ear.ear/axbi-ejb.jar#axbiEJBModulePU": org.jboss.msc.service.StartException in service jboss.persistenceunit."axbi-ear.ear/axbi-ejb.jar#axbiEJBModulePU": Failed to start service
        at org
      .jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1767) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
        at java
      .util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_51]
        at java
      .util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_51]
        at java
      .lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51]
      Caused by: java.lang.NullPointerException
        at sun
      .reflect.UnsafeFieldAccessorImpl.ensureObj(UnsafeFieldAccessorImpl.java:54) [rt.jar:1.7.0_51]
        at sun
      .reflect.UnsafeObjectFieldAccessorImpl.set(UnsafeObjectFieldAccessorImpl.java:75) [rt.jar:1.7.0_51]
        at java
      .lang.reflect.Field.set(Field.java:741) [rt.jar:1.7.0_51]
        at org
      .hibernate.ejb.metamodel.MetadataContext.registerAttribute(MetadataContext.java:415)
        at org
      .hibernate.ejb.metamodel.MetadataContext.registerAttributes(MetadataContext.java:373)
        at org
      .hibernate.ejb.metamodel.MetadataContext.populateStaticMetamodel(MetadataContext.java:350)
        at org
      .hibernate.ejb.metamodel.MetadataContext.wrapUp(MetadataContext.java:242)
        at org
      .hibernate.ejb.metamodel.MetamodelImpl.buildMetamodel(MetamodelImpl.java:83)
        at org
      .hibernate.ejb.EntityManagerFactoryImpl.<init>(EntityManagerFactoryImpl.java:106)
        at org
      .hibernate.ejb.Ejb3Configuration.buildEntityManagerFactory(Ejb3Configuration.java:914)
        at org
      .hibernate.ejb.Ejb3Configuration.buildEntityManagerFactory(Ejb3Configuration.java:899)
        at org
      .hibernate.ejb.HibernatePersistence.__createContainerEntityManagerFactory(HibernatePersistence.java:76)
        at org
      .hibernate.ejb.HibernatePersistence.createContainerEntityManagerFactory(HibernatePersistence.java)
        at org
      .jboss.as.jpa.service.PersistenceUnitServiceImpl.createContainerEntityManagerFactory(PersistenceUnitServiceImpl.java:162)
        at org
      .jboss.as.jpa.service.PersistenceUnitServiceImpl.start(PersistenceUnitServiceImpl.java:85)
        at org
      .jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
        at org
      .jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
        
      ... 3 more

      16:57:33,366 INFO  [org.jboss.as.server] (HttpManagementService-threads - 2) JBAS015870: Deploy of deployment "axbi-ear.ear"


      Tudo indica ser um erro no JBoss devido ao NullPointer ocorrer na classe ServiceControllerImpl.

      Alguma idéia do que possa ser ou alguém já passou por isso?