6 Replies Latest reply on Apr 14, 2014 9:29 AM by Justin Bertram

    Connecting to Remote Topic in JBoss EAP 6.1

    Sankalp Madaan Newbie

      Hi All,

       

      I am trying to connect to a remote topic using an EJB application. But I am getting the following error by while setting the Context


      01:08:06,249 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1) javax.naming.NamingException: JBAS011843: Failed instantiate InitialContextFactory org.jboss.naming.remote.client.InitialContextFactory from classloader ModuleClassLoader for Module "deployment.NORSAPP.ear.NORS.war:main" from Service Mod

      ule Loader

      01:08:06,249 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.jboss.as.naming.InitialContextFactoryBuilder.createInitialContextFactory(InitialContextFactoryBuilder.java:64)

      01:08:06,249 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:664)

      01:08:06,249 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:288)

      01:08:06,250 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at javax.naming.InitialContext.init(InitialContext.java:223)

      01:08:06,250 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at javax.naming.InitialContext.<init>(InitialContext.java:197)

      01:08:06,250 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at com.nissanusa.nors.util.NORSCLientUtility.getInitialContext(NORSCLientUtility.java:32)

      01:08:06,250 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at com.nissanusa.nors.service.NORSWebService.publishMessage(NORSWebService.java:160)

      01:08:06,250 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at com.nissanusa.nors.service.NORSWebService.abc(NORSWebService.java:108)

      01:08:06,251 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

      01:08:06,251 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

      01:08:06,251 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

      01:08:06,251 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at java.lang.reflect.Method.invoke(Method.java:597)

      01:08:06,251 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.jboss.resteasy.core.MethodInjectorImpl.invoke(MethodInjectorImpl.java:167)

      01:08:06,251 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.jboss.resteasy.core.ResourceMethod.invokeOnTarget(ResourceMethod.java:257)

      01:08:06,252 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:222)

      01:08:06,252 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:211)

      01:08:06,252 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.jboss.resteasy.core.SynchronousDispatcher.getResponse(SynchronousDispatcher.java:542)

      01:08:06,252 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:524)

      01:08:06,252 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:126)

      01:08:06,253 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.jboss.resteasy.plugins.server.servlet.ServletContainerDispatcher.service(ServletContainerDispatcher.java:208)

      01:08:06,253 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:55)

      01:08:06,253 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:50)

      01:08:06,253 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)

      01:08:06,253 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:295)

      01:08:06,253 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)

      01:08:06,254 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)

      01:08:06,254 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149)

      01:08:06,254 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169)

      01:08:06,254 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145)

      01:08:06,254 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97)

      01:08:06,254 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102)

      01:08:06,255 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336)

      01:08:06,255 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)

      01:08:06,255 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653)

      01:08:06,255 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:920)

      01:08:06,255 ERROR [stderr] (http-127.0.0.1/127.0.0.1:18080-1)  at java.lang.Thread.run(Thread.java:662)

       

       

       

      I am using the following code for setting the initial context:

       

       

      Properties properties = new Properties();
      properties.put(Context.INITIAL_CONTEXT_FACTORY, JNDI_FACTORY);
      properties.put(Context.PROVIDER_URL, "remote://localhost:4447");
      properties.put(Context.SECURITY_PRINCIPAL, "NORSUser1");
      properties.put(Context.SECURITY_CREDENTIALS, "NORSPassword123$");
      properties.put("jboss.naming.client.ejb.context", true);  
      Context context = new InitialContext(properties); 
      

       


      Please let me know if any other information is required.

        • 1. Re: Connecting to Remote Topic in JBoss EAP 6.1
          Justin Bertram Master

          I think you should not use this:

           

          properties.put("jboss.naming.client.ejb.context", true);

           

          See this for an example of a traditional JMS client.

          • 2. Re: Re: Connecting to Remote Topic in JBoss EAP 6.1
            Sankalp Madaan Newbie

            I tried removing it. Again I got the same exception. I tried using that example also. But still getting same exception. I think the problem is in configuration. I am running two instances of JBoss on my local by binding the ports. Here is my standalone-full.xml where I have deployed my project.

             

             

            <?xml version='1.0' encoding='UTF-8'?>
            <server xmlns="urn:jboss:domain:1.4">
                <extensions>
                    <extension module="org.jboss.as.clustering.infinispan"/>
                    <extension module="org.jboss.as.cmp"/>
                    <extension module="org.jboss.as.connector"/>
                    <extension module="org.jboss.as.deployment-scanner"/>
                    <extension module="org.jboss.as.ee"/>
                    <extension module="org.jboss.as.ejb3"/>
                    <extension module="org.jboss.as.jacorb"/>
                    <extension module="org.jboss.as.jaxr"/>
                    <extension module="org.jboss.as.jaxrs"/>
                    <extension module="org.jboss.as.jdr"/>
                    <extension module="org.jboss.as.jmx"/>
                    <extension module="org.jboss.as.jpa"/>
                    <extension module="org.jboss.as.jsf"/>
                    <extension module="org.jboss.as.jsr77"/>
                    <extension module="org.jboss.as.logging"/>
                    <extension module="org.jboss.as.mail"/>
                    <extension module="org.jboss.as.messaging"/>
                    <extension module="org.jboss.as.naming"/>
                    <extension module="org.jboss.as.pojo"/>
                    <extension module="org.jboss.as.remoting"/>
                    <extension module="org.jboss.as.sar"/>
                    <extension module="org.jboss.as.security"/>
                    <extension module="org.jboss.as.threads"/>
                    <extension module="org.jboss.as.transactions"/>
                    <extension module="org.jboss.as.web"/>
                    <extension module="org.jboss.as.webservices"/>
                    <extension module="org.jboss.as.weld"/>
                </extensions>
            
                <management>
                    <security-realms>
                        <security-realm name="ManagementRealm">
                            <authentication>
                                <local default-user="$local"/>
                                <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>
                            </authentication>
                        </security-realm>
                        <security-realm name="ApplicationRealm">
                            <authentication>
                                <local default-user="$local" allowed-users="*"/>
                                <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>
                            </authentication>
                            <authorization>
                                <properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>
                            </authorization>
                        </security-realm>
                    </security-realms>
                    <management-interfaces>
                        <native-interface security-realm="ManagementRealm">
                            <socket-binding native="management-native"/>
                        </native-interface>
                        <http-interface security-realm="ManagementRealm">
                            <socket-binding http="management-http"/>
                        </http-interface>
                    </management-interfaces>
                </management>
                <profile>
                    <subsystem xmlns="urn:jboss:domain:logging:1.2">
                        <console-handler name="CONSOLE">
                            <level name="INFO"/>
                            <formatter>
                                <pattern-formatter pattern="%K{level}%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>
                            </formatter>
                        </console-handler>
                        <periodic-rotating-file-handler name="FILE" autoflush="true">
                            <formatter>
                                <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>
                            </formatter>
                            <file relative-to="jboss.server.log.dir" path="server.log"/>
                            <suffix value=".yyyy-MM-dd"/>
                            <append value="true"/>
                        </periodic-rotating-file-handler>
                        <logger category="com.arjuna">
                            <level name="WARN"/>
                        </logger>
                        <logger category="org.apache.tomcat.util.modeler">
                            <level name="WARN"/>
                        </logger>
                        <logger category="org.jboss.as.config">
                            <level name="DEBUG"/>
                        </logger>
                        <logger category="sun.rmi">
                            <level name="WARN"/>
                        </logger>
                        <logger category="jacorb">
                            <level name="WARN"/>
                        </logger>
                        <logger category="jacorb.config">
                            <level name="ERROR"/>
                        </logger>
                        <root-logger>
                            <level name="INFO"/>
                            <handlers>
                                <handler name="CONSOLE"/>
                                <handler name="FILE"/>
                            </handlers>
                        </root-logger>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:cmp:1.1"/>
                    <subsystem xmlns="urn:jboss:domain:datasources:1.1">
                        <datasources>
                            <datasource jndi-name="java:jboss/datasources/ExampleDS" pool-name="ExampleDS" enabled="true" use-java-context="true">
                                <connection-url>jdbc:h2:mem:test;DB_CLOSE_DELAY=-1</connection-url>
                                <driver>h2</driver>
                                <security>
                                    <user-name>sa</user-name>
                                    <password>sa</password>
                                </security>
                            </datasource>
                            <drivers>
                                <driver name="h2" module="com.h2database.h2">
                                    <xa-datasource-class>org.h2.jdbcx.JdbcDataSource</xa-datasource-class>
                                </driver>
                            </drivers>
                        </datasources>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.1">
                        <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="5000"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:ee:1.1">
                        <spec-descriptor-property-replacement>false</spec-descriptor-property-replacement>
                        <jboss-descriptor-property-replacement>true</jboss-descriptor-property-replacement>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:ejb3:1.4">
                        <session-bean>
                            <stateless>
                                <bean-instance-pool-ref pool-name="slsb-strict-max-pool"/>
                            </stateless>
                            <stateful default-access-timeout="5000" cache-ref="simple"/>
                            <singleton default-access-timeout="5000"/>
                        </session-bean>
                        <mdb>
                            <resource-adapter-ref resource-adapter-name="hornetq-ra"/>
                            <bean-instance-pool-ref pool-name="mdb-strict-max-pool"/>
                        </mdb>
                        <pools>
                            <bean-instance-pools>
                                <strict-max-pool name="slsb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
                                <strict-max-pool name="mdb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
                            </bean-instance-pools>
                        </pools>
                        <caches>
                            <cache name="simple" aliases="NoPassivationCache"/>
                            <cache name="passivating" passivation-store-ref="file" aliases="SimpleStatefulCache"/>
                        </caches>
                        <passivation-stores>
                            <file-passivation-store name="file"/>
                        </passivation-stores>
                        <async thread-pool-name="default"/>
                        <timer-service thread-pool-name="default">
                            <data-store path="timer-service-data" relative-to="jboss.server.data.dir"/>
                        </timer-service>
                        <remote connector-ref="remoting-connector" thread-pool-name="default"/>
                        <thread-pools>
                            <thread-pool name="default">
                                <max-threads count="10"/>
                                <keepalive-time time="100" unit="milliseconds"/>
                            </thread-pool>
                        </thread-pools>
                        <iiop enable-by-default="false" use-qualified-name="false"/>
                        <default-security-domain value="other"/>
                        <default-missing-method-permissions-deny-access value="true"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:infinispan:1.4">
                        <cache-container name="web" aliases="standard-session-cache" default-cache="local-web" module="org.jboss.as.clustering.web.infinispan">
                            <local-cache name="local-web" batching="true">
                                <file-store passivation="false" purge="false"/>
                            </local-cache>
                        </cache-container>
                        <cache-container name="hibernate" default-cache="local-query" module="org.jboss.as.jpa.hibernate:4">
                            <local-cache name="entity">
                                <transaction mode="NON_XA"/>
                                <eviction strategy="LRU" max-entries="10000"/>
                                <expiration max-idle="100000"/>
                            </local-cache>
                            <local-cache name="local-query">
                                <transaction mode="NONE"/>
                                <eviction strategy="LRU" max-entries="10000"/>
                                <expiration max-idle="100000"/>
                            </local-cache>
                            <local-cache name="timestamps">
                                <transaction mode="NONE"/>
                                <eviction strategy="NONE"/>
                            </local-cache>
                        </cache-container>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jacorb:1.3">
                        <orb socket-binding="jacorb" ssl-socket-binding="jacorb-ssl">
                            <initializers security="identity" transactions="spec"/>
                        </orb>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jaxr:1.1">
                        <connection-factory jndi-name="java:jboss/jaxr/ConnectionFactory"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:jca:1.1">
                        <archive-validation enabled="true" fail-on-error="true" fail-on-warn="false"/>
                        <bean-validation enabled="true"/>
                        <default-workmanager>
                            <short-running-threads>
                                <core-threads count="50"/>
                                <queue-length count="50"/>
                                <max-threads count="50"/>
                                <keepalive-time time="10" unit="seconds"/>
                            </short-running-threads>
                            <long-running-threads>
                                <core-threads count="50"/>
                                <queue-length count="50"/>
                                <max-threads count="50"/>
                                <keepalive-time time="10" unit="seconds"/>
                            </long-running-threads>
                        </default-workmanager>
                        <cached-connection-manager/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jdr:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:jmx:1.2">
                        <expose-resolved-model/>
                        <expose-expression-model/>
                        <remoting-connector/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jpa:1.1">
                        <jpa default-datasource="" default-extended-persistence-inheritance="DEEP"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jsf:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:jsr77:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:mail:1.1">
                        <mail-session jndi-name="java:jboss/mail/Default">
                            <smtp-server outbound-socket-binding-ref="mail-smtp"/>
                        </mail-session>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:messaging:1.3">
                        <hornetq-server>
                            <persistence-enabled>true</persistence-enabled>
                            <journal-type>NIO</journal-type>
                            <journal-file-size>102400</journal-file-size>
                            <journal-min-files>2</journal-min-files>
                            <connectors>
                                <netty-connector name="netty" socket-binding="messaging"/>
                                <netty-connector name="netty-throughput" socket-binding="messaging-throughput">
                                    <param key="batch-delay" value="50"/>
                                </netty-connector>
                                <in-vm-connector name="in-vm" server-id="0"/>
                                <connector name="remote-jms">
                                    <factory-class>org.hornetq.core.remoting.impl.netty.NettyConnectorFactory</factory-class>
                                    <param key="host" value="10.112.9.40"/>
                                    <param key="port" value="5445"/>
                                </connector>
                            </connectors>
                            <acceptors>
                                <netty-acceptor name="netty" socket-binding="messaging"/>
                                <netty-acceptor name="netty-throughput" socket-binding="messaging-throughput">
                                    <param key="batch-delay" value="50"/>
                                    <param key="direct-deliver" value="false"/>
                                </netty-acceptor>
                                <in-vm-acceptor name="in-vm" server-id="0"/>
                            </acceptors>
                            <security-settings>
                                <security-setting match="#">
                                    <permission type="send" roles="guest"/>
                                    <permission type="consume" roles="guest"/>
                                    <permission type="createNonDurableQueue" roles="guest"/>
                                    <permission type="deleteNonDurableQueue" roles="guest"/>
                                </security-setting>
                            </security-settings>
                            <address-settings>
                                <address-setting match="#">
                                    <dead-letter-address>jms.queue.DLQ</dead-letter-address>
                                    <expiry-address>jms.queue.ExpiryQueue</expiry-address>
                                    <redelivery-delay>0</redelivery-delay>
                                    <max-size-bytes>10485760</max-size-bytes>
                                    <address-full-policy>BLOCK</address-full-policy>
                                    <message-counter-history-day-limit>10</message-counter-history-day-limit>
                                </address-setting>
                            </address-settings>
                            <jms-connection-factories>
                                <connection-factory name="InVmConnectionFactory">
                                    <connectors>
                                        <connector-ref connector-name="in-vm"/>
                                    </connectors>
                                    <entries>
                                        <entry name="java:/ConnectionFactory"/>
                                    </entries>
                                </connection-factory>
                                <connection-factory name="RemoteConnectionFactory">
                                    <connectors>
                                        <connector-ref connector-name="remote-jms"/>
                                    </connectors>
                                    <entries>
                                        <entry name="RemoteConnectionFactory"/>
                                        <entry name="java:jboss/exported/jms/RemoteConnectionFactory"/>
                                    </entries>
                                </connection-factory>
                                <pooled-connection-factory name="hornetq-ra">
                                    <transaction mode="xa"/>
                                    <connectors>
                                        <connector-ref connector-name="in-vm"/>
                                    </connectors>
                                    <entries>
                                        <entry name="java:/JmsXA"/>
                                    </entries>
                                </pooled-connection-factory>
                            </jms-connection-factories>
                            <jms-destinations>
                                <jms-queue name="MyQueue">
                                    <entry name="/queue/MyQueue"/>
                                    <entry name="java:jboss/exported/jms/queue/MyQueue"/>
                                </jms-queue>
                            </jms-destinations>
                        </hornetq-server>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:naming:1.3">
                        <remote-naming/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:pojo:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:remoting:1.1">
                        <connector name="remoting-connector" socket-binding="remoting" security-realm="ApplicationRealm"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:resource-adapters:1.1"/>
                    <subsystem xmlns="urn:jboss:domain:sar:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:security:1.2">
                        <security-domains>
                            <security-domain name="other" cache-type="default">
                                <authentication>
                                    <login-module code="Remoting" flag="optional">
                                        <module-option name="password-stacking" value="useFirstPass"/>
                                    </login-module>
                                    <login-module code="RealmDirect" flag="required">
                                        <module-option name="password-stacking" value="useFirstPass"/>
                                    </login-module>
                                </authentication>
                            </security-domain>
                            <security-domain name="jboss-web-policy" cache-type="default">
                                <authorization>
                                    <policy-module code="Delegating" flag="required"/>
                                </authorization>
                            </security-domain>
                            <security-domain name="jboss-ejb-policy" cache-type="default">
                                <authorization>
                                    <policy-module code="Delegating" flag="required"/>
                                </authorization>
                            </security-domain>
                        </security-domains>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:threads:1.1"/>
                    <subsystem xmlns="urn:jboss:domain:transactions:1.3">
                        <core-environment>
                            <process-id>
                                <uuid/>
                            </process-id>
                        </core-environment>
                        <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>
                        <coordinator-environment default-timeout="300"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:web:1.4" default-virtual-server="default-host" native="false">
                        <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>
                        <virtual-server name="default-host" enable-welcome-root="true">
                            <alias name="localhost"/>
                            <alias name="example.com"/>
                        </virtual-server>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:webservices:1.2">
                        <modify-wsdl-address>true</modify-wsdl-address>
                        <wsdl-host>${jboss.bind.address:127.0.0.1}</wsdl-host>
                        <endpoint-config name="Standard-Endpoint-Config"/>
                        <endpoint-config name="Recording-Endpoint-Config">
                            <pre-handler-chain name="recording-handlers" protocol-bindings="##SOAP11_HTTP ##SOAP11_HTTP_MTOM ##SOAP12_HTTP ##SOAP12_HTTP_MTOM">
                                <handler name="RecordingHandler" class="org.jboss.ws.common.invocation.RecordingServerHandler"/>
                            </pre-handler-chain>
                        </endpoint-config>
                        <client-config name="Standard-Client-Config"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:weld:1.0"/>
                </profile>
                <interfaces>
                    <interface name="management">
                        <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>
                    </interface>
                    <interface name="public">
                        <inet-address value="${jboss.bind.address:127.0.0.1}"/>
                    </interface>
                    <interface name="unsecure">
                        <inet-address value="${jboss.bind.address.unsecure:127.0.0.1}"/>
                    </interface>
                </interfaces>
                <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">
                    <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>
                    <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>
                    <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>
                    <socket-binding name="ajp" port="8009"/>
                    <socket-binding name="http" port="8080"/>
                    <socket-binding name="https" port="8443"/>
                    <socket-binding name="jacorb" interface="unsecure" port="3528"/>
                    <socket-binding name="jacorb-ssl" interface="unsecure" port="3529"/>
                    <socket-binding name="messaging" port="5445"/>
                    <socket-binding name="messaging-group" port="0" multicast-address="${jboss.messaging.group.address:231.7.7.7}" multicast-port="${jboss.messaging.group.port:9876}"/>
                    <socket-binding name="messaging-throughput" port="5455"/>
                    <socket-binding name="remoting" port="4447"/>
                    <socket-binding name="txn-recovery-environment" port="4712"/>
                    <socket-binding name="txn-status-manager" port="4713"/>
                    <outbound-socket-binding name="mail-smtp">
                        <remote-destination host="localhost" port="25"/>
                    </outbound-socket-binding>
                </socket-binding-group>
            </server>
            
            • 3. Re: Re: Connecting to Remote Topic in JBoss EAP 6.1
              Justin Bertram Master

              I think I see the issue now.  I believe the problem is related to your application's dependencies (or lack thereof).  It looks like you need a dependency on the "org.jboss.remote-naming" module.

              • 4. Re: Re: Connecting to Remote Topic in JBoss EAP 6.1
                Justin Bertram Master

                BTW...

                 

                Based on your stack-trace it looks like your trying to send a JMS message from an application hosted by JBoss AS.  If that's the case then I would recommend you configure a local <pooled-connection-factory> to do the sending as the performance will be better and it will be easier to manage.

                • 5. Re: Re: Connecting to Remote Topic in JBoss EAP 6.1
                  Sankalp Madaan Newbie

                  Thanks Justin, I am able to do it. I added jboss-client.jar and it worked. But can you tell how to configure a local <pooled-connection-factory>?

                  • 6. Re: Re: Connecting to Remote Topic in JBoss EAP 6.1
                    Justin Bertram Master

                    First please describe your use-case in detail.