1 2 Previous Next 22 Replies Latest reply on Apr 26, 2014 8:25 AM by al carvalho

    Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows

    lightsail pro Newbie

      I am struggling to find a combination of teiid and teiid designer version that works on X64 version of Windows 7 with jdk1.6.0_37 x64. So far I have not found a perfect combination. All with issues. Here is the what I found. Could someone share the version combo that does not have the following issues?

       

      1) Teiid 8.6 + Teiid designer 8.32:

           Best combination so far. But with the following issue: Teiid Connection >> Source Model importer does not work (nothing happens when clicking). LDAP importer is missing.

       

      2) Teiid 8.6 + Teiid designer 8.4:

           LDAP importer shows up. But data preview breaks. Teiid Connection >> Source Model importer still does not work.

       

      3) Teiid 8.7 + Teiid designer 8.4:

           Could not connect at all. Got the following error:

      org.teiid.adminapi.AdminProcessingException: TEIID70026 Parameter "type" missing is required.
      at org.teiid.adminapi.AdminFactory$AdminImpl$BuildPropertyDefinitions.onFailure(AdminFactory.java:1205)
      at org.teiid.adminapi.AdminFactory$AdminImpl.cliCall(AdminFactory.java:1489)
      at org.teiid.adminapi.AdminFactory$AdminImpl.getTranslatorPropertyDefinitions(AdminFactory.java:1182)
      at org.teiid84.runtime.ExecutionAdmin.refreshTranslators(ExecutionAdmin.java:672)
      at org.teiid84.runtime.ExecutionAdmin.refresh(ExecutionAdmin.java:627)
      at org.teiid84.runtime.ExecutionAdmin.connect(ExecutionAdmin.java:616)
      at org.teiid.designer.runtime.TeiidServer.connect(TeiidServer.java:215)
      at org.teiid.designer.runtime.TeiidServer.reconnect(TeiidServer.java:254)
      at org.teiid.designer.runtime.TeiidParentServerListener.serverChanged(TeiidParentServerListener.java:165)
      at org.eclipse.wst.server.core.internal.ServerNotificationManager.broadcastChange(ServerNotificationManager.java:125)
      at org.eclipse.wst.server.core.internal.Server.fireServerStateChangeEvent(Server.java:742)
      at org.eclipse.wst.server.core.internal.Server.setServerState(Server.java:650)
      at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.setServerState(ServerBehaviourDelegate.java:143)
      at org.jboss.ide.eclipse.as.core.server.internal.DeployableServerBehavior.setServerStarted(DeployableServerBehavior.java:210)
      at org.jboss.ide.eclipse.as.core.server.internal.DelegatingServerBehavior.setServerStarted(DelegatingServerBehavior.java:100)
      at org.jboss.ide.eclipse.as.core.server.internal.launch.AbstractJBossStartLaunchConfiguration.preLaunchCheck(AbstractJBossStartLaunchConfiguration.java:66)
      at org.jboss.ide.eclipse.as.core.server.internal.v7.LocalJBoss7StartLaunchDelegate.preLaunchCheck(LocalJBoss7StartLaunchDelegate.java:39)
      at org.jboss.ide.eclipse.as.core.server.internal.launch.DelegatingStartLaunchConfiguration.preLaunchCheck(DelegatingStartLaunchConfiguration.java:67)
      at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:813)
      at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:707)
      at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:700)
      at org.eclipse.wst.server.core.internal.Server.startImpl2(Server.java:3538)
      at org.eclipse.wst.server.core.internal.Server.startImpl(Server.java:3474)
      at org.eclipse.wst.server.core.internal.Server$StartJob.run(Server.java:367)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

          

       

      --4) On windows, both 8.6 and 8.7 gave the following error. But it seems that the error is not critical. Most of the features still work.

      18:07:54,112 ERROR [org.apache.catalina.core] (ServerService Thread Pool -- 53)  JBWEB001103: Error detected during cont
      ext /odata start, will stop it
      18:07:54,139 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 53)  MSC00001: Failed to start service jbo
      ss.web.deployment.default-host./odata: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host
      ./odata: org.jboss.msc.service.StartException in anonymous service: JBAS018040: Failed to start context
              at org.jboss.as.web.deployment.WebDeploymentService$1.run(WebDeploymentService.java:96)
              at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439) [rt.jar:1.6.0_37]
              at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) [rt.jar:1.6.0_37]
              at java.util.concurrent.FutureTask.run(FutureTask.java:138) [rt.jar:1.6.0_37]
              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_37]
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_37]
              at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_37]
              at org.jboss.threads.JBossThread.run(JBossThread.java:122)
      Caused by: org.jboss.msc.service.StartException in anonymous service: JBAS018040: Failed to start context
              at org.jboss.as.web.deployment.WebDeploymentService.doStart(WebDeploymentService.java:161)
              at org.jboss.as.web.deployment.WebDeploymentService.access$000(WebDeploymentService.java:60)
              at org.jboss.as.web.deployment.WebDeploymentService$1.run(WebDeploymentService.java:93)
              ... 7 more

      18:07:54,402 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 44)  JBAS018559: Deployed "teiid-odata-8.7.0.Fina
      l.war" (runtime-name : "teiid-odata-8.7.0.Final.war")
      18:07:54,404 INFO  [org.jboss.as.controller] (Controller Boot Thread)  JBAS014774: Service status report
      JBAS014777:   Services which failed to start:      service jboss.web.deployment.default-host./odata: org.jboss.msc.servi
      ce.StartException in service jboss.web.deployment.default-host./odata: org.jboss.msc.service.StartException in anonymous
      service: JBAS018040: Failed to start context

        • 1. Re: Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows
          Mark Drilling Novice

          #2 are the latest compatible versions (Teiid 8.6 with Teiid Designer 8.4), but apparently there are Windows related issues.  Teiid Designer 8.4 is not compatible with Teiid 8.7 due to some api changes.  We expect to produce a Designer 8.5 alpha today which will be compatible with Teiid 8.7.  We will recommend using that combination, then we can address any specific issues with it.  We will let you know when it is available.

          • 2. Re: Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows
            Mark Drilling Novice

            Here is the Teiid Designer update site for our Designer 8.5 alpha - http://download.jboss.org/jbosstools/updates/development/kepler/integration-stack/teiiddesigner/8.5.0.Alpha1/

            This is compatible with Teiid 8.7.  Any issues with this combination can be logged and we will address -  Teiid Designer - JBoss Issue Tracker

            • 3. Re: Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows
              lightsail pro Newbie

              I am new. How do I install the 8.50 alpha? I have JBDS 7.1.0.GA. I tried from Help - Install new software, then paste the http://download.jboss.org/jbosstools/updates/development/kepler/integration-stack/teiiddesigner/8.5.0.Alpha1/. But the installation will not continue. It tries to install 8.32 instead. Thanks.

               

              Also tried on Eclipse 4.32 64bit and 32bit, get the following error:

               

              Cannot complete the install because one or more required items could not be found.

                Software being installed: Teiid DataTools Connectivity 8.5.0.Alpha1-v20140421-1409-B2575 (org.teiid.datatools.connectivity.feature.feature.group 8.5.0.Alpha1-v20140421-1409-B2575)

                Missing requirement: org.teiid.datatools.connectivity.ui 8.5.0.Alpha1-v20140421-1409-B2575 (org.teiid.datatools.connectivity.ui 8.5.0.Alpha1-v20140421-1409-B2575) requires 'bundle org.jboss.tools.locus.sf.saxon [9.2.1,10.0.0)' but it could not be found

                Cannot satisfy dependency:

                  From: Teiid DataTools Connectivity 8.5.0.Alpha1-v20140421-1409-B2575 (org.teiid.datatools.connectivity.feature.feature.group 8.5.0.Alpha1-v20140421-1409-B2575)

                  To: org.teiid.datatools.connectivity.ui [8.5.0.Alpha1-v20140421-1409-B2575]

              • 4. Re: Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows
                Mark Drilling Novice

                I installed a clean copy of JBDS 7.1.1, then followed the "Into Eclipse IDE" instructions at the bottom of this page Download & Install - JBoss Community .  The update site is the url from your previous post.  I'll retry on a Windows laptop.

                • 5. Re: Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows
                  lightsail pro Newbie

                  I tried JBDS 7.1.1 version and the suggested steps. I still get error on window 7

                   

                  Cannot complete the install because one or more required items could not be found.

                    Software being installed: Teiid Designer Runtime 8.5.0.Alpha1-v20140421-1409-B2575 (org.teiid.designer.runtime.feature.feature.group 8.5.0.Alpha1-v20140421-1409-B2575)

                    Missing requirement: Core Designer Plug-in 8.5.0.Alpha1-v20140421-1409-B2575 (org.teiid.core.designer 8.5.0.Alpha1-v20140421-1409-B2575) requires 'bundle org.jboss.tools.locus.sf.saxon [9.2.1,10.0.0)' but it could not be found

                    Cannot satisfy dependency:

                      From: Relational Plug-in 8.5.0.Alpha1-v20140421-1409-B2575 (org.teiid.designer.relational 8.5.0.Alpha1-v20140421-1409-B2575)

                      To: bundle org.teiid.core.designer [8.1.0,9.0.0)

                    Cannot satisfy dependency:

                      From: Teiid Designer Runtime 8.5.0.Alpha1-v20140421-1409-B2575 (org.teiid.designer.runtime.feature.feature.group 8.5.0.Alpha1-v20140421-1409-B2575)

                      To: org.teiid.designer.relational [8.1.0,9.0.0)

                  • 6. Re: Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows
                    Mark Drilling Novice

                    Sorry, we're dealing with some Windows install issues right now.  We'll be working through them in the next day or so.  I logged an issue - [TEIIDDES-2123] 8.5Alpha1 installation issues on Windows - JBoss Issue Tracker .  I was able to complete the install successfully, but had to install couple other dependencies first.  If you follow the 'Steps to reproduce' on the issue you should be able to complete the install.  We may have a separate issue with server connectivity also - I'll let you know tomorrow the status on that one.

                    • 7. Re: Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows
                      lightsail pro Newbie

                      Hi, Mark:

                           I was able to install Teiid Designer 8.5 0n JBDS 7.1.1 by following your instruction. Thanks a lot.  There are still a few show-stoppers with Teiid 8.7 and designer 8.5 combination on Windows 7 x64. Here they are the show stopper scenarios:

                       

                      --Issue 1: Execute VDB error (new error)
                      Could not connect to OverdriveVDB - localhost - Teiid Connection.
                        Error creating SQL Model Connection connection to OverdriveVDB - localhost - Teiid Connection. (Error: Could not initialize class org.teiid.jdbc.TeiidDriver)
                        Could not initialize class org.teiid.jdbc.TeiidDriver
                        Error creating JDBC Connection connection to OverdriveVDB - localhost - Teiid Connection. (Error: Could not initialize class org.teiid.jdbc.TeiidDriver)
                        Could not initialize class org.teiid.jdbc.TeiidDriver


                      --Issue 2: table data preview JDBC connection error (Tested salesforce, works well in teiid 8.6 and designer 8.32)
                      Salesforce tabble data preview - error creating JDBC connection - Validate the JDBC username and password in the default Teiid Instance

                       

                      --Issue 3 - Importer "Teiid Connection >> Source Model" exception (same as beore)

                      null
                      Error
                      Mon Apr 21 21:43:15 EDT 2014
                      Unhandled event loop exception

                      java.lang.IllegalArgumentException: The supplied model folder refers to an existing non-model project.
                      at org.teiid.designer.ddl.importer.DdlImporter.setModelFolder(DdlImporter.java:344)
                      at org.teiid.designer.teiidimporter.ui.wizard.TeiidImportManager.setTargetModelLocation(TeiidImportManager.java:479)
                      at org.teiid.designer.teiidimporter.ui.wizard.TeiidImportWizard.init(TeiidImportWizard.java:135)
                      at org.eclipse.ui.internal.dialogs.WorkbenchWizardNode.getWizard(WorkbenchWizardNode.java:185)
                      at org.eclipse.jface.wizard.WizardSelectionPage.getNextPage(WizardSelectionPage.java:104)
                      at org.eclipse.ui.internal.dialogs.WorkbenchWizardSelectionPage.getNextPage(WorkbenchWizardSelectionPage.java:100)
                      at org.eclipse.ui.internal.dialogs.ImportExportPage.getNextPage(ImportExportPage.java:448)
                      at org.eclipse.jface.wizard.WizardDialog.nextPressed(WizardDialog.java:908)
                      at org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDialog.java:428)
                      at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:628)
                      at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
                      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
                      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1057)
                      at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4170)
                      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3759)
                      at org.eclipse.jface.window.Window.runEventLoop(Window.java:826)
                      at org.eclipse.jface.window.Window.open(Window.java:802)
                      at org.eclipse.ui.internal.handlers.WizardHandler$Import.executeHandler(WizardHandler.java:152)
                      at org.eclipse.ui.internal.handlers.WizardHandler.execute(WizardHandler.java:279)
                      at org.eclipse.ui.internal.handlers.HandlerProxy.execute(HandlerProxy.java:290)
                      at org.eclipse.ui.internal.handlers.E4HandlerProxy.execute(E4HandlerProxy.java:90)
                      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                      at java.lang.reflect.Method.invoke(Method.java:597)
                      at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:56)
                      at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:243)
                      at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:224)
                      at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
                      at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:167)
                      at org.eclipse.core.commands.Command.executeWithChecks(Command.java:499)
                      at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:508)
                      at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:213)
                      at org.eclipse.ui.internal.handlers.LegacyHandlerService.executeCommand(LegacyHandlerService.java:420)
                      at org.eclipse.ui.internal.actions.CommandAction.runWithEvent(CommandAction.java:157)
                      at org.eclipse.ui.internal.actions.CommandAction.run(CommandAction.java:171)
                      at org.eclipse.ui.actions.ImportResourcesAction.run(ImportResourcesAction.java:97)
                      at org.eclipse.ui.actions.BaseSelectionListenerAction.runWithEvent(BaseSelectionListenerAction.java:168)
                      at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
                      at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
                      at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)
                      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
                      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1057)
                      at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4170)
                      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3759)
                      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1113)
                      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
                      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:997)
                      at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:140)
                      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:611)
                      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
                      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:567)
                      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
                      at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:124)
                      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
                      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
                      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
                      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)
                      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)
                      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                      at java.lang.reflect.Method.invoke(Method.java:597)
                      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
                      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
                      at org.eclipse.equinox.launcher.Main.run(Main.java:1450)
                      at org.eclipse.equinox.launcher.Main.main(Main.java:1426)

                      • 8. Re: Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows
                        Mark Drilling Novice

                        We will be updating the designer install instructions per latest comments on [TEIIDDES-2123] 8.5Alpha1 installation issues on Windows - JBoss Issue Tracker .  However we still have issues with the teiid 8.5 alpha install - I suspect they are all related to this - [TEIIDDES-2124] Cannot create Teiid Driver connection - JBoss Issue Tracker .  Please follow this JIRA as we are actively working.

                        • 9. Re: Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows
                          lightsail pro Newbie

                          Just tested the latest build 8.5.0.Alpha1-v20140423-1406-B2577. I can confirm "Teiid Connection >> Source Model" exception and other jdbc connection error (issue1, 2) all got fixed. Teiid 8.7 and designer 8.5 alpha seems the best combo so far for Windows platform. Great works! Thanks a lot.


                          "Flat file - Remote url" (https://community.jboss.org/thread/240313) is still an issue (got "x" sign on the data source view at the end of the wizard, preview button is greyed out). There is exception in the log. I will post the stack trace in that 240313 thread.

                          • 10. Re: Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows
                            Mark Drilling Novice

                            Thanks for the info - I was in process of testing the latest designer 8.5 alpha build myself.  Also thanks in advance for the additional info on the flat file issue - and for your patience while we work through this!

                            • 11. Re: Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows
                              Mark Drilling Novice

                              also, we've just logged a different issue against the flat file import - [TEIIDDES-2128] Error generating SQL for Flat File Procedure - JBoss Issue Tracker

                               

                              You can log the stacktrace you mentioned earlier directly in our issue tracker if you want - Teiid Designer - JBoss Issue Tracker

                              • 12. Re: Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows
                                al carvalho Newbie

                                I am still trying to get a successful Designer/Teiid combination using Kepler 3.2

                                I've tried every combination and keep getting same Install errors - This is the latest trying to get Designer 8.5 installed in Kepler SR2 Build ID 20140224-0627 - What am I missing ??

                                 

                                Cannot complete the install because one or more required items could not be found.

                                  Software being installed: Teiid Designer Runtime 8.5.0.Alpha1-v20140423-1406-B2577 (org.teiid.designer.runtime.feature.feature.group 8.5.0.Alpha1-v20140423-1406-B2577)

                                  Missing requirement: Designer Datatools Plug-in 8.2.0.Final-v20130817-0508-B2400 (org.teiid.designer.datatools 8.2.0.Final-v20130817-0508-B2400) requires 'bundle org.codehaus.jackson.core [1.6.0,2.0.0)' but it could not be found

                                  Missing requirement: Designer Datatools Plug-in 8.3.0.Final-v20131206-1521-B2475 (org.teiid.designer.datatools 8.3.0.Final-v20131206-1521-B2475) requires 'bundle org.codehaus.jackson.core [1.6.0,2.0.0)' but it could not be found

                                  Missing requirement: Designer Datatools Plug-in 8.4.0.Final-v20140312-0402-B2536 (org.teiid.designer.datatools 8.4.0.Final-v20140312-0402-B2536) requires 'bundle org.codehaus.jackson.core [1.6.0,2.0.0)' but it could not be found

                                  Missing requirement: Designer Datatools Plug-in 8.5.0.Alpha1-v20140423-1406-B2577 (org.teiid.designer.datatools 8.5.0.Alpha1-v20140423-1406-B2577) requires 'bundle org.codehaus.jackson.core [1.6.0,2.0.0)' but it could not be found

                                  Missing requirement: DQP Plug-in 8.2.0.Final-v20130817-0508-B2400 (org.teiid.designer.dqp 8.2.0.Final-v20130817-0508-B2400) requires 'bundle org.jboss.ide.eclipse.as.core [2.4.0,3.0.0)' but it could not be found

                                  Missing requirement: DQP Plug-in 8.3.0.Final-v20131206-1521-B2475 (org.teiid.designer.dqp 8.3.0.Final-v20131206-1521-B2475) requires 'bundle org.jboss.ide.eclipse.as.core [2.4.0,3.0.0)' but it could not be found

                                  Cannot satisfy dependency:

                                    From: Designer Datatools UI Plug-in 8.2.0.Final-v20130817-0508-B2400 (org.teiid.designer.datatools.ui 8.2.0.Final-v20130817-0508-B2400)

                                    To: bundle org.teiid.designer.datatools [8.1.0,9.0.0)

                                  Cannot satisfy dependency:

                                    From: Designer Datatools UI Plug-in 8.3.0.Final-v20131206-1521-B2475 (org.teiid.designer.datatools.ui 8.3.0.Final-v20131206-1521-B2475)

                                    To: bundle org.teiid.designer.datatools [8.1.0,9.0.0)

                                  Cannot satisfy dependency:

                                    From: Designer Datatools UI Plug-in 8.4.0.Final-v20140312-0402-B2536 (org.teiid.designer.datatools.ui 8.4.0.Final-v20140312-0402-B2536)

                                    To: bundle org.teiid.designer.datatools [8.1.0,9.0.0)

                                  Cannot satisfy dependency:

                                    From: Designer Datatools UI Plug-in 8.5.0.Alpha1-v20140423-1406-B2577 (org.teiid.designer.datatools.ui 8.5.0.Alpha1-v20140423-1406-B2577)

                                    To: bundle org.teiid.designer.datatools [8.1.0,9.0.0)

                                  Cannot satisfy dependency:

                                    From: DQP Plug-in 8.4.0.Final-v20140312-0402-B2536 (org.teiid.designer.dqp 8.4.0.Final-v20140312-0402-B2536)

                                    To: bundle org.teiid.designer.datatools [8.1.0,9.0.0)

                                  Cannot satisfy dependency:

                                    From: DQP Plug-in 8.5.0.Alpha1-v20140423-1406-B2577 (org.teiid.designer.dqp 8.5.0.Alpha1-v20140423-1406-B2577)

                                    To: bundle org.teiid.designer.datatools [8.1.0,9.0.0)

                                  Cannot satisfy dependency:

                                    From: DQP Ui Plug-in 8.2.0.Final-v20130817-0508-B2400 (org.teiid.designer.dqp.ui 8.2.0.Final-v20130817-0508-B2400)

                                    To: bundle org.teiid.designer.jdbc.ui [8.1.0,9.0.0)

                                  Cannot satisfy dependency:

                                    From: DQP Ui Plug-in 8.3.0.Final-v20131206-1521-B2475 (org.teiid.designer.dqp.ui 8.3.0.Final-v20131206-1521-B2475)

                                    To: bundle org.teiid.designer.dqp [8.1.0,9.0.0)

                                  Cannot satisfy dependency:

                                    From: DQP Ui Plug-in 8.4.0.Final-v20140312-0402-B2536 (org.teiid.designer.dqp.ui 8.4.0.Final-v20140312-0402-B2536)

                                    To: bundle org.teiid.designer.jdbc.ui [8.1.0,9.0.0)

                                  Cannot satisfy dependency:

                                    From: DQP Ui Plug-in 8.5.0.Alpha1-v20140423-1406-B2577 (org.teiid.designer.dqp.ui 8.5.0.Alpha1-v20140423-1406-B2577)

                                    To: bundle org.teiid.designer.jdbc.ui [8.1.0,9.0.0)

                                  Cannot satisfy dependency:

                                    From: Teiid Designer JDBC UI Plug-in 8.2.0.Final-v20130817-0508-B2400 (org.teiid.designer.jdbc.ui 8.2.0.Final-v20130817-0508-B2400)

                                    To: bundle org.teiid.designer.datatools.ui [8.1.0,9.0.0)

                                  Cannot satisfy dependency:

                                    From: Teiid Designer JDBC UI Plug-in 8.3.0.Final-v20131206-1521-B2475 (org.teiid.designer.jdbc.ui 8.3.0.Final-v20131206-1521-B2475)

                                    To: bundle org.teiid.designer.datatools [8.1.0,9.0.0)

                                  Cannot satisfy dependency:

                                    From: Teiid Designer JDBC UI Plug-in 8.4.0.Final-v20140312-0402-B2536 (org.teiid.designer.jdbc.ui 8.4.0.Final-v20140312-0402-B2536)

                                    To: bundle org.teiid.designer.datatools [8.1.0,9.0.0)

                                  Cannot satisfy dependency:

                                    From: Teiid Designer JDBC UI Plug-in 8.5.0.Alpha1-v20140423-1406-B2577 (org.teiid.designer.jdbc.ui 8.5.0.Alpha1-v20140423-1406-B2577)

                                    To: bundle org.teiid.designer.datatools [8.1.0,9.0.0)

                                  Cannot satisfy dependency:

                                    From: Teiid Designer Runtime 8.5.0.Alpha1-v20140423-1406-B2577 (org.teiid.designer.runtime.feature.feature.group 8.5.0.Alpha1-v20140423-1406-B2577)

                                    To: org.teiid.designer.dqp.ui [8.1.0,9.0.0)

                                • 13. Re: Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows
                                  Mark Drilling Novice

                                  Did you try the updated instructions at Download & Install - JBoss Community ?  I just retested using a clean Kepler 4.3.2 install and it worked for me.  Condensed steps:

                                  1) install eclipse

                                  2) Help > Install new software... > add JBossToolsAS update site - http://download.jboss.org/jbosstools/updates/release/kepler/integration-stack/  Select the 4 teiid 8.3.2 features in the Data Virtualization group.

                                  3) Help >Install new software... > add BIRT update site - http://download.eclipse.org/birt/update-site/4.3

                                  4) Help >Install new software... > add Designer85Alpha update site - http://download.jboss.org/jbosstools/updates/development/kepler/integration-stack/teiiddesigner/8.5.0.Alpha1  - You will get a warning that you are updating the 8.3.2 teiid features...

                                  Steps 2 and 3 are extra for now - (until we get dependencies into the 8.5 alpha update site)

                                  Thanks -

                                  Mark

                                  • 14. Re: Teiid designer 8.32, 8.4 with teiid 8.6 and 8.7 issue summary on Windows
                                    al carvalho Newbie

                                    Installing .... Thanks so much ! Seems I was using the wrong installation

                                    site for Designer

                                    1 2 Previous Next