5 Replies Latest reply on Apr 23, 2014 5:29 PM by Dmitry Shultz

    Switchyard Software Install in JBDS stuck forever

    Dmitry Shultz Novice

      Hi,

       

      I'm having hard time to follow this guide : Installing Eclipse Tooling - SwitchYard - Project Documentation Editor


      The process is stuck in the 'Available Software' dialogue trying to install Switchyard Tools, the same behaviour for JBDS 8 & JBDS 7 and there is no obvious way to download the old JBDS 6 (as required by the guide).


      I'm not the Eclipse user (IDEA is my tool), so I even don't know where to look for the stacktrace or something. There is one log in the jbdevstudio\studio\configuration folder (1398188428169.log) and it has this (not sure how relevant it is):


      !SESSION 2014-04-22 10:40:27.636 -----------------------------------------------

      eclipse.buildId=unknown

      java.version=1.6.0_24

      java.vendor=Sun Microsystems Inc.

      BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_CA

      Framework arguments:  -application com.jboss.jbds.product.EclipseGenerator

      Command-line arguments:  -application com.jboss.jbds.product.EclipseGenerator -clean

       

       

      !ENTRY org.eclipse.osgi 4 0 2014-04-22 10:40:34.203

      !MESSAGE An unexpected runtime error has occurred.

      !STACK 0

      java.lang.IllegalStateException: BundleContext is no longer valid

        at org.eclipse.osgi.framework.internal.core.BundleContextImpl.checkValid(BundleContextImpl.java:931)

        at org.eclipse.osgi.framework.internal.core.BundleContextImpl.removeBundleListener(BundleContextImpl.java:303)

        at org.eclipse.ui.plugin.AbstractUIPlugin$2.bundleChanged(AbstractUIPlugin.java:604)

        at org.eclipse.osgi.framework.internal.core.BundleContextImpl.dispatchEvent(BundleContextImpl.java:847)

        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)

        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

       

       

      !ENTRY org.eclipse.ui 4 0 2014-04-22 10:40:34.223

      !MESSAGE FrameworkEvent ERROR

      !STACK 0

      java.lang.IllegalStateException: BundleContext is no longer valid

        at org.eclipse.osgi.framework.internal.core.BundleContextImpl.checkValid(BundleContextImpl.java:931)

        at org.eclipse.osgi.framework.internal.core.BundleContextImpl.removeBundleListener(BundleContextImpl.java:303)

        at org.eclipse.ui.plugin.AbstractUIPlugin$2.bundleChanged(AbstractUIPlugin.java:604)

        at org.eclipse.osgi.framework.internal.core.BundleContextImpl.dispatchEvent(BundleContextImpl.java:847)

        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)

        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)