0 Replies Latest reply on Jun 24, 2014 6:28 AM by Igor Malinovskyy

    Disabling security audit does not work in wildfly 8.1.0

    Igor Malinovskyy Newbie

      I have foollwing jboss-web:

      <jboss-web>

         <security-domain>zert</security-domain>

         <context-root>/</context-root>

         <disable-audit>true</disable-audit>

       

      </jboss-web>

      And foollwing context.xml:

      <Context cookies="true" crossContext="true">

        <!-- Valve className="se.zert.web.core.server.ZFormAuthValve" characterEncoding="utf-8" includePassword="true" /-->

         <!-- valve>

             <class-name>org.jboss.web.tomcat.security.ExtendedFormAuthenticator</class-name>

             <param>

                 <param-name>includePassword</param-name>

                 <param-value>true</param-value>

             </param>

          </valve-->

        <Valve className="org.jboss.web.tomcat.security.ExtendedFormAuthenticator" includePassword="true" />

        <!-- Valve className="org.apache.catalina.authenticator.FormAuthenticator"

          disableProxyCaching="false" /-->    

      </Context>

       

      And I have own LoginModule. In wildfly 8.0.0 It works to login with Form Auth. In 8.1.0 Same aproach does not work,

      Also  tracing of audit not possible to turn on inside 8.1.0 Final.

      <logger category="org.jboss.security.audit">

                      <level name="TRACE"/> 

                      <handlers>

                          <handler name="AUDIT"/> 

                      </handlers> 

                  </logger>


      That does not work