3 Replies Latest reply on Jul 30, 2014 2:21 AM by André Faber

    Unsatisfied dependencies for fileupload in 4.5.0.Alpha3

    André Faber Newbie

      Hello,

       

      I'm trying to upgrade from 4.3.6.Final to 4.5.0.Alpha3 but when I'm deploying my package I'm getting the error:

       

      org.jboss.weld.exceptions.DeploymentException: WELD-001408: Unsatisfied dependencies for type ConvoiRealiseBean with qualifiers @Default
        at injection point [BackedAnnotatedField] @Inject private lu.etat.pch.cex.ejb.controllers.ConvoiFormBean.convoiRealiseBean
        at lu.etat.pch.cex.ejb.controllers.ConvoiFormBean.convoiRealiseBean(ConvoiFormBean.java:0)
      WELD-001474: Class lu.etat.pch.cex.ejb.controllers.ConvoiRealiseBean is on the classpath, but was ignored because a class it references was not found:
      org.richfaces.event.FileUploadEvent from [Module "deployment.cex.war:main" from Service Module Loader].
      

       

      It seems that it cannot find the FileUploadEvent. Nevertheless maven gives no error back when doing the package.

       

      The dependencies are declared as follows in my POM file:

      <dependency>
                  <groupId>org.richfaces.core</groupId>
                  <artifactId>richfaces-core-impl</artifactId>
                  <version>4.5.0.Alpha3</version>
                  <scope>system</scope>
                  <systemPath>D:/java/dev/richfaces-distribution-4.5.0.Alpha3/richfaces-core-4.5.0.Alpha3.jar</systemPath>
              </dependency>
              <dependency>
                  <groupId>org.richfaces.ui</groupId>
                  <artifactId>richfaces-components-ui</artifactId>
                  <version>4.5.0.Alpha3</version>
                  <scope>system</scope>
                  <systemPath>D:/java/dev/richfaces-distribution-4.5.0.Alpha3/richfaces-components-rich-4.5.0.Alpha3.jar</systemPath>
              </dependency>
      

       

      Am I missing something?