5 Replies Latest reply on Sep 16, 2008 6:08 AM by Dariusz Dziadek

    Problem with interaction between OSGi and JBI components on FuseESB 4.0 ...

    Dariusz Dziadek Newbie

      Hi all (once again ),

       

      I'm trying to investigate how OSGi and JBI components could interact.

      So I've created OSGi component that exposes service on NMR (please see attached test-scenario-2-cxf-nmr-1.0-SNAPSHOT.jar for details) and JBI SA with CXF BC consumer

      to invoke service (please see attached test-scenario-2-sa-1.0-SNAPSHOT.zip for details).

       

      Inside console I've run:

       

      servicemix> features addUrl mvn:org.apache.servicemix.nmr/apache-servicemix-nmr/1.0.0.0-fuse/xml/features

      servicemix> features addUrl mvn:org.apache.servicemix.features/apache-servicemix/4.0.0.0-fuse/xml/features

      servicemix> features list

      wrapper

      nmr

      jbi

      web-core

      web

      activemq

      cxf

      cxf-osgi

      cxf-nmr

      camel

      camel-nmr

      examples-cxf-osgi

      examples-cxf-nmr

      examples-camel-osgi

      examples-camel-nmr

      examples-cxf-camel-nmr

       

      and next I've deployed components.

       

      After sending SOAP message:

       

      <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"

      xmlns:typens="http://www.softwaremind.pl/WKI/WP4-test/TestScenario2/types">

      <soapenv:Body>

      <typens:DoGraphAnalyze>

      <typens:graphIdIn>Hello</typens:graphIdIn>

      </typens:DoGraphAnalyze>

      </soapenv:Body>

      </soapenv:Envelope>

       

      an error is occur:

       

      STATUS: 200

      <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Body><soap:Fault><faultcode>soap:Server</faultcode><faultstring>"http://java.sun.com/xml/ns/jbi/wsdl-11-wrapper", the namespace on the "message" element, is not a valid SOAP version.</faultstring></soap:Fault></soap:Body></soap:Envelope>

       

      I'm suspecting (I don't know how to debug NMR messages ) there is something wrong with NMR message format and/or (maybe) with WSDL's wrapper classes (placed at com/pl/swmind/wp4/types|exception at test-scenario-2-cxf-nmr-1.0-SNAPSHOT.jar)

      (useJBIWrapper="true" attribute for CXF BC doesn't couse any results)

       

       

      Does someone have any idea what could be wrong?

       

      Best regards,

       

      Darek

       

      Edited by: ddziadek on Aug 13, 2008 5:20 PM

       

      Edited by: ddziadek on Aug 14, 2008 9:32 AM