2 Replies Latest reply on Dec 14, 2010 2:35 PM by Mike Reeves

    PAX https  org.osgi.service.http.port.secure has failed

    Mike Reeves Newbie

      I realize that you need to add the org.ops4j.pax.web.cfg file in order to set the http port. Now I?m trying to set the https port using the same file below.  When I start Fuse 4.3 I get an error saying,  "Reading configuration property org.osgi.service.http.port.secure has failed", not sure why this would be incorrect.  I know that password is correct since I can use keytool to access the keystore.   Any ideas on what I?m doing wrong? 

       

      org.ops4j.pax.web.cfg

       

      1. Added - set http port

      org.osgi.service.http.port=9191

      #https settings

      org.osgi.service.http.secure.enabled=true

      org.ops4j.pax.web.ssl.keystore=c:/users/reeve011/fusejetty

      org.ops4j.pax.web.ssl.password=password

      org.ops4j.pax.web.ssl.keypassword=password

      org.osgi.service.http.port.secure=8443

       

      servicemix.log

       

      16:35:33,427 | DEBUG | guration Updater | ConfigurationImpl                | rvice.internal.ConfigurationImpl  287 | 107 - org.ops4j.pax.web.pax-web-runtime - 0.7.3 | Reading configuration property org.osgi.service.http.port.secure has failed

      16:35:33,427 | DEBUG | guration Updater | ConfigurationImpl                | rvice.internal.ConfigurationImpl  287 | 107 - org.ops4j.pax.web.pax-web-runtime - 0.7.3 | Reading configuration property org.ops4j.pax.web.session.timeout has failed

      16:35:33,427 | DEBUG | guration Updater | ServerControllerImpl             | ty.internal.ServerControllerImpl   74 | 108 - org.ops4j.pax.web.pax-web-jetty - 0.7.3 | Configuring server -> [ConfigurationImpl{http enabled=true,http port=9191,http secure enabled=true,http secure port=null,ssl keystore=c:/users/reeve011/fusejetty,ssl keystoreType=null,session timeout=null,session url=null,session cookie=null,worker name=null,listening addresses=[Ljava.lang.String;@15373f8}]

      16:35:33,427 | DEBUG | guration Updater | HttpServiceStarted               | ce.internal.HttpServiceStarted$1   82 | 107 - org.ops4j.pax.web.pax-web-runtime - 0.7.3 | Handling event:

      16:35:33,427 | DEBUG | guration Updater | HttpServiceStarted               | ce.internal.HttpServiceStarted$1   82 | 107 - org.ops4j.pax.web.pax-web-runtime - 0.7.3 | Handling event:

      16:35:33,427 | DEBUG | guration Updater | ConfigurationImpl                | rvice.internal.ConfigurationImpl  287 | 107 - org.ops4j.pax.web.pax-web-runtime - 0.7.3 | Reading configuration property org.osgi.service.http.port.secure has failed

      16:35:33,428 | DEBUG | guration Updater | ConfigurationImpl                | rvice.internal.ConfigurationImpl  287 | 107 - org.ops4j.pax.web.pax-web-runtime - 0.7.3 | Reading configuration property org.osgi.service.http.port.secure has failed

      16:35:33,428 | DEBUG | guration Updater | ConfigurationImpl                | rvice.internal.ConfigurationImpl  287 | 107 - org.ops4j.pax.web.pax-web-runtime - 0.7.3 | Reading configuration property org.ops4j.pax.web.session.timeout has failed

        • 1. Re: PAX https  org.osgi.service.http.port.secure has failed
          Freeman(Yue) Fang Master

          Hi,

           

          I believe there's something wrong in your keystore or password.

           

          I do almost same thing like

           

          org.osgi.service.http.port=9191

          #https settings

          org.osgi.service.http.secure.enabled=true

          org.ops4j.pax.web.ssl.keystore=/Users/ffang/projects/smx/component/trunk/bindings/servicemix-cxf-bc/src/test/resources/org/apache/servicemix/cxfbc/ws/security/alice.jks

          org.ops4j.pax.web.ssl.password=password

          org.ops4j.pax.web.ssl.keypassword=password

          org.osgi.service.http.port.secure=8443

           

          The only difference is that I use my keystore and password, and I can see the secure port 8443 get started, and in the log I get

           

          10:04:07,976 | DEBUG | guration Updater | ServerControllerImpl             | ty.internal.ServerControllerImpl   74 | 108 - org.ops4j.pax.web.pax-web-jetty - 0.7.3 | Configuring server -> [ConfigurationImpl{http enabled=true,http port=9191,http secure enabled=true,http secure port=8443,ssl keystore=/Users/ffang/projects/smx/component/trunk/bindings/servicemix-cxf-bc/src/test/resources/org/apache/servicemix/cxfbc/ws/security/alice.jks,ssl keystoreType=null,session timeout=null,session url=null,session cookie=null,worker name=null,listening addresses=[Ljava.lang.String;@b6bce19}]

           

          Btw, I'm using FUSE ESB 4.3.0-fuse-03-00.

           

          Also, you need ensure that port 8443 not used by other process.

           

          Freeman

          • 2. Re: PAX https  org.osgi.service.http.port.secure has failed
            Mike Reeves Newbie

            Thanks for the help with verifying that I was using the correct cfg file and settings.  The problem was in the file and had to due with a "space" at the end of the org.osgi.service.http.port.secure=8443 property, everything works now.